Emulation Station starts fine using a Raspberry pi 4 with recalbox 7.1.1-Reloaded and my monitor but some games have a black screen with audio.




  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @Rocky-Hill Sorry, but without enough information, it is not possible to help you.
    If you have the same problem as the topic you mentioned, follow all the instructions that are described there.

    What's your version of Recalbox (say the version, don't say "the last one")?
    Did you build your Recalbox yourself, or download a ready-made image from the internet, or did you buy everything ready?
    What games have this problem? Are they all from the same console?
    Are your BIOS all correct? How did you check?



  • I have a monitor that I sort of made from an iMac G3 DV. This monitor has a resolution of
    1024x768 @ 75 Hz which is supported by the raspberry pi.

    Recalbox 7.1.1-Reloaded

    Indeed, I have used this monitor with several operating systems without any issues.

    Here is the configuration I'm using.

    config.txt

    hdmi_group=2
    hdmi_mode=18

    recalbox.conf

    global.videomode=DMT 18 HDMI

    This same configuration works fine with recalbox on a raspberry pi 3

    Here is a link to a video showing what I am describing.

    https://youtu.be/VeglywfdoQU



  • @Zing

    I'm still putting this post together.
    I was going to post on the older thread but I was instructed to start a newer one.



  • @Zing

    I just posted a video so you can see what I,m talking about.
    https://youtu.be/VeglywfdoQU

    I downloaded Recalbox 7.1.1-Reloaded for the raspberry pi 4 and I loaded unto the sd card several ways.

    1- raspberry pi imager.
    2-sudo dd if=./image of=/dev/sdX
    3-using the ubuntu disk imager

    All with the same result.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @Rocky-Hill I took a look at the video, but I have to confess that since I don't speak English fluently, I didn't understand everything you said.
    I'll focus on the main information:

    • You have a monitor with an unusual resolution (but, compatible)
    • You have already set the resolution and some games start normally
    • Games like NES are starting without video, only audio, even games that come with the system do not work (NES does not require BIOS)

    Have you tried global.videomode=default?
    Have you tried with another emulator/core?

    Okay, the ideal is to do a test on another monitor, if it works, the problem may be in the resolution of the NES, you can define some other videomode in recalbox.conf by adding a line nes.videomode=XXXX



  • @Zing
    Have you tried global.videomode=default?
    yes, that is the first mode I used
    Have you tried with another emulator/core?
    yes I cycled hrough several

    I want to add that most of the systems listed do not display anything, only the audio works.

    I tested with a different monitor as you suggested with the following config.

    global.videomode=default

    I also commented the following in config.txt
    #hdmi_group=2
    #hdmi_mode=18

    This worked, see attached image.

    moitor.jpg

    Recalbox loads games correctly when using a raspberry pi 3.

    see video
    https://youtu.be/sQ73Ow83Xuo


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @Rocky-Hill Okay, if in Rpi3 the same configuration works, I suppose the problem is in the RPI4 detection of EDID: your iMac G3 DV monitor is not being able to communicate correctly with RPi4.

    • Have you tried with both RPi4's HDMI ports?
    • Have you tried with another HDMI adapter?

    Analyzing the CHANGELOG of the next version of Recalbox (https://gitlab.com/recalbox/recalbox/blob/master/CHANGELOG.md), it is noticed that there are some changes related to Rpi4, such as:

    • Fix detection of 4k screen (I know your monitor is not 4k, but it is also about screen detection)
    • Bump RPI4 kernel (may be related)
      I believe that in the next version this error can be solved, if you are patient, wait for the next version and test.

    If you are impatient, test the following:

    • Use the default video setting, leave config.txt unchanged (commented out as you did)
    • Turn on the monitor first, start Recalbox
    • If the resolution is distorted even after starting the Monitor first, disconnect and reconnect the HDMI cable
    • Regardless of the resolution, if possible, try to start an NES game


  • @Zing

    It's possible that there is an issue with EDID detection but I thought that was the whole
    purpose of forcing a resolution and refresh rate....

    I have tried with the other HDMI port but it behaves the same way and I tried with another HDMI adapter with the same result.

    I do believe there is a bug with the Rpi4 version but it's odd that this is where it would manifest
    itself.

    I really like recalbox so I I'll investigate some more and I am willing to wait for the bug to be fixed. I'm use to using open source projects so I've developed a healthy amount of patience
    so I'm good.

    thanks for your help!



  • @Zing

    I forgot to upvote your help.

    Thanks!



Want to support us ?

201
Online

81.9k
Users

22.5k
Topics

162.8k
Posts