USB Keyboard Encoder "Dual Strike" ArcadeForge



  • Hello there, I have used this USB Encoder ever since building my bartop. It was working fine with recalbox 6.
    Now that I've "updated" (clean install) recalbox 7, I cannot figure out, how to configure the keyboard encoder (itself and/or inside recalbox).
    recalbox says "Arduino LLC ArcadeForge Key Strike connected".

    Symptoms:
    When I try to configure the controller, joystick down results in skipping the current mapping line/prompt. Buttons register fine but when navigating joystick up always sends two up events.

    Created the file "usb-Arduino_LLC_ArcadeForge_Key_Strike-if02-event-kbd" inside /recalbox/share/system/configs/xarcade2jstick as per documentation - which I don't know if it's still right or currently outdated?

    Tried the default MAME association as well:

    Label		Key
    ------		------
    COIN 1		5	
    COIN 2		6	
    START 1		1	
    START 2		2
    1 RIGHT		R arrow
    1 LEFT		L arrow
    1 UP		U arrow
    1 DOWN		D arrow
    1 SW 1		L-ctrl
    1 SW 2		L-alt	
    1 SW 3		space	
    1 SW 4		L-shift	
    1 SW 5		Z	
    1 SW 6		X	
    1 SW 7		C	
    1 SW 8		V	
    1 A		P	
    1 B		ENTER	
    START 1		1	
    START 2		2
    2 RIGHT		G	
    2 LEFT		D	
    2 UP		R	
    2 DOWN		F	
    2 SW 1		A	
    2 SW 2		S	
    2 SW 3		Q	
    2 SW 4		W	
    2 SW 5		I	
    2 SW 6		K	
    2 SW 7		J	
    2 SW 8		L	
    2 A		TAB	
    2 B		ESC
    


  • also tried the button mapping mentioned here https://recalbox.gitbook.io/tutorials/usb-encoders/recalbox-for-your-usb-keyboard-encoder under Key mapping v4.0.0 - beta4


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @SmashDde I recommend that you open an isse on Gitlab (on this link: https://gitlab.com/recalbox/recalbox/-/issues), describe your problem as you did here, and add the link to this topic.



  • @Zing Thanks, done that! 👍



  • I have an Arcade Forge Dual Strike encoder, and I can confirm this is a real problem in RB. The joystick movements register twice, unless you tap it really quickly. In my case, the encoder is set up as a standard 8 button gamepad (not as a keyboard), and it's possible, but not easy, to configure the directions correctly. The 8 buttons are working fine.
    Btw, the encoder works perfectly under Windows or Lakka, so it's not a hardware problem. This looks like some timing issue in the 4 directions.


  • Staff
    Global moderator
    Team

    Hello
    version recalbox ?
    please update to 7.1.1



  • @acris I've installed a fresh 7.0.1
    Great that there's a 7.1.1 already, will try that later today and report back.

    @jonas thanks for sharing your experience! Buttons work fine here as well, left/right of the joystick(s) as well, but up/down is always very finicky. Can't get them working properly, they always register nothing at all or double input.
    Used the encoder since Recalbox v4 or something and had every release since then, worked fine with more or less configuration from time to time, but for v7 I'm currently lost.
    Did you manage to get the encoder configured in v7?



  • Ok, thanks to Home Office I quickly flashed the 7.1.1 onto the SD Card and tried assigning the encoder. Same behavior as before, sadly.
    When it comes to assign "down" it just skips that entry and assigns the down press (button 5 in my case) to the next one in the list. I continue to assign all other buttons and re-assign wrong assignments due to the skipping before but I am unable to assign "button 5" or anything other to "down".
    When accepting this "joystick up" fires twice every time and "joystick down" not at all.

    Could you please tell me where the input configuration is written so I can probably fix it manually in there?



  • @SmashDde I've just finished testing the encoder with 7.1.1, paying extra attention to how the inputs behave inside EmulationStation.
    When in gamepad mode, the encoder works, but not as smoothly as it should. For each 10 vertical (up/down) stick movements, there are one/two movements which will register two inputs. It's somewhat random, and very annoying. After launching a game, the controls work quite well... it's somewhat difficult to say if the double input is present or not. Maybe it depends on the game.
    When in keyboard encoder mode, the vertical movements will always register two inputs, and only one of the eight buttons is working. Configuring the encoder manually as per the tutorial instructions has no effect at all. Therefore, completely useless.



  • @jonas Thanks very much for going through the hassle of testing this and writing down your findings. At least I am not the only one and can be somewhat certain that further fiddling around with settings, trying different bindings on the keyboard controller itself and so on wouldn't be successful neither. Don't get me wrong: I did this prior of posting in the forums/github bug tracker. For hours. Things like this, especially when it's a self-made and not too cheap thing, drive me mad. I want the stuff to be working.

    Help from one of the devs would be very much appreciated. Whatever I am able to contribute: just let me (us?) know.

    As a last resort I could always go back to the latest Recalbox v6, I guess ...
    Bartop without the joysticks and buttons working is quite useless after all 😉



Want to support us ?

247
Online

80.5k
Users

21.6k
Topics

158.2k
Posts