Multiple controller issues

  • Hi! I would like to use my Xiaomi Mi Bluetooth Controller and my Logitech Cordless Rumblepad 2 for multiplayer fun. If used with the other gamepad connected, both gamepads work without problems. But as soon as both are used, the Logitech one doesn't work anymore. The button mapping is messed up, not all buttons are mapped and except for the D-pad, nothing seems to match. When using the emulationstation frontend, both work as expected. I had a similar problem with Retropie, which was not solved. However, the Xiaomi worked when setting it to SDL and the Logitech one worked only with udev. Is there a way to remap with using jstest info? Hope someone can help. Thanks!

  • Try this. Configure both controllers Then in controller settings define one as player 1 and the other as player 2 make sure each is defined to its own specific player assignment. Then test.

  • Hi Michael! I tried this and it did not work. Same problem for both possible assignments. When emulation starts, both gamepads are shown as set but "unconfigured" in the yellow overlay text of retroarch. Any other ideas?

  • Staff
    Global moderator

    Does this happens to you with all emulators or only, for instance, with n64?

  • This happens with all emulators I tried. First saw it for SNES. I just had the chance to test it with a different Logitech controller (F710) and the Mi Pad, same problem.

Log in to reply

Want to support us ?