Affichage qui déborde au delà des limites de l'écran



  • Bonjour,

    Mon setup : Recalbox 7 sur Rasp Pi4B dans boitier Nespi4Case connecté en HDMI sur ma TV de salon LG 70UM7100 (mode image : jeu).
    Une partie de l'affichage "déborde" au delà de l'écran. Si je met l'option "overscan" alors j'ai une bordure noire tout autour de l'image. Y a t'il une manière pour avoir l'entre deux, cad une image au plus proche de la "taille" de l'écran, SVP ?
    Je n'ai trouvé aucune option permettant un réglage de l'échelle sur ma TV 😢 (j'ai peut être mal cherché) .

    Merci d'avance pour votre aide.


  • Theme moderator
    Themer

    je me demande en effet si ta TV n est pas en mode Zoom, a voir si elle a un mode overscan ou un truc du genre
    regrde dans parametres et format de l image si tu peux mettre sur original


  • Staff
    Developer
    Global moderator
    Creator
    Team

    @airdream a priori je dirai qu'il faut jouer avec les overscans dans le config.txt

    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1
     
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    overscan_left=16
    overscan_right=16
    overscan_top=16
    overscan_bottom=16
    


  • Merci à vous deux ! Je regarde de nouveau les paramètres de TV comme suggéré par @airdream et si je ne trouve rien, je tenterais la modif de la conf overscan comme suggéré par @ian57 .
    Je vous tiens au courant :



  • Hello @jomofcw
    j'ai le même souci avec les distribution RECALBOX et OSMC sur TV SAMSUNG.
    J'ai trouvé un compromis en ajoutant ceci au fichier /boot/config.txt:

    disable_overscan=0
    overscan_scale=1
    overscan_left=-6
    overscan_right=-6
    overscan_top=-24
    overscan_bottom=-24
    


  • J'ai oublié de précisé que la configuration que j'indique dans mon précédent message permet de bien ajuster l'image à la taille de l'écran de TV sous EmulationStation.
    En revanche, une fois en jeu dans un émulateur sous RetroArch, l'image n'est pas bien ajustée à la taille de l'écran de TV. En effet, une bande noire tout atour de l'écran est visible (mais je n'ai pas trouvé meilleur compromis).



  • N'étant pas tout à fait satisfait de mes réglages (EmulationStation était bien ajusté à l'écran de la TV mais un cadre noir apparaissait dans RetroArch), j'ai trouvé un meilleur réglage (OK dans ES et sous RetroArch):

    • Vérifier les réglages d'image "Ajustement à l'écran" de votre TV (sur ma TV Samsung, j'ai positionné sur "Auto" qui est le réglage par défaut)

    • Votre fichier /boot/config.txt est configuré comme ci-dessous:

    disable_overscan=1
    overscan_scale=1
    overscan_left=16
    overscan_right=16
    overscan_top=16
    overscan_bottom=16
    

    Cette page de chez RetroPie m'a bien aidée: https://retropie.org.uk/docs/Overscan/


  • Theme moderator
    Themer

    Le cadre noir autour des jeux c'était peut être parce que tu avais activé l'option Pixel Perfect.
    Pour moi c'est mieux quand cette option est activé, cela permet aux shaders d'être correct au niveau des scanlines.
    Si tu n'utilisais pas de shader tu pouvais désactiver Pixel Perfect et retrouver un plein écran, enfin je pense ça dépend aussi des TV c'est sur.



Want to support us ?

408
Online

80.4k
Users

21.6k
Topics

157.8k
Posts