N64 buttons not matching up with configured GameSir controller



  • I have a Gamesir T4 Pro BT controller that works fine in ES and all other emulators. this is recalbox 7.0.1

    https://www.amazon.com/gp/product/B07HG51ZYK/ref=ppx_yo_dt_b_asin_title_o03_s00?ie=UTF8&psc=1

    seems i can only get start button to work it "seems" on most games, like 1080 Snowboard or WCW vs nWo: World Tour , on Zelda Ocorina of Time one other button other than start works, and i can move link around with joystick.. in the other 2 games 1080 and WCSvsNWO, i get stuck at the beginning of the game after pressing start waiting on prompts 😐 and i press every damn button on the control pad and nothing works.. except start and select because i can start the game at least, then eventually when nothing else works button work i can select/start to exit the emulator ...

    so here is my input.xml from the n64 emulator

    <inputList>
    <input name="AnalogDeadzone" value="4096,4096" />
    <input name="AnalogPeak" value="32768,32768" />
    <input name="a" value="C Button R" />
    <input name="b" value="A Button" />
    <input name="x" value="C Button U" />
    <input name="y" value="B Button" />
    <input name="start" value="Start" />
    <input name="select" value="" />
    <input name="l1" value="L Trig" />
    <input name="r1" value="R Trig" />
    <input name="l2" value="Z Trig" />
    <input name="r2" value="" />
    <input name="l3" value="Mempak switch" />
    <input name="r3" value="Rumblepak switch" />
    <input name="up" value="DPad U" />
    <input name="down" value="DPad D" />
    <input name="right" value="DPad R" />
    <input name="left" value="DPad L" />
    <input name="joystick1up" value="Y Axis" />
    <input name="joystick1down" value="Y Axis" />
    <input name="joystick1left" value="X Axis" />
    <input name="joystick1right" value="X Axis" />
    <input name="joystick2up" value="C Button U" />
    <input name="joystick2down" value="C Button D" />
    <input name="joystick2left" value="C Button L" />
    <input name="joystick2right" value="C Button R" />
    </inputList>

    Then here is my buttons from ES config for the Gamesir
    IMG_3220.JPG
    IMG_3221.JPG
    IMG_3222.JPG

    I am just looking for help on what i might be doing wrong or misinterpreting for N64 controller mappings, again LOL even when i'm waiting on prompt in one of the games i mentioned i press every damn button πŸ™‚ and nothing happens πŸ™‚ , any help appreciated.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator



  • thanks for the suggestion.. so i added "n64.configfile=dummy" to my recalbox.conf file at the end of the file. rebooted. when i started N64 emulator from ES mupen64plus, tried to start Super Mario 64, pop up said something like "could not configure dummy something" sorry i didn't write it down, BUT nothing worked i even powered controller off/on, i had to cold reboot the pi i could not even exit the game..

    so i remove the "n64.configfile=dummy" rebooted again so it was good to go and back to way it was.. then if i start Super Mario 64 i am able to use the left joystick on the Gamesir and start button only, that has been the case most times.. I don't know why the other buttons aren't working here is my current mupen64plus.cfg for controller inputs

    [Input-SDL-Control1]

    Mupen64Plus SDL Input Plugin config parameter version number. Please don't change this version number.
    version = 2
    Controller configuration mode: 0=Fully Manual, 1=Auto with named SDL Device, 2=Fully automatic
    mode = 0
    Specifies which joystick is bound to this controller: -1=No joystick, 0 or more= SDL Joystick number
    device = 0
    SDL joystick name (or Keyboard)
    name = "PLAYSTATION(R)3 Controller (47:0D:91:86:A9:4A)"
    Specifies whether this controller is 'plugged in' to the simulated N64
    plugged = True
    Specifies which type of expansion pak is in the controller: 1=None, 2=Mem pak, 5=Rumble pak
    plugin = "2"
    If True, then mouse buttons may be used with this controller
    mouse = False
    Scaling factor for mouse movements. For X, Y axes.
    MouseSensitivity = "2.00,2.00"
    The minimum absolute value of the SDL analog joystick axis to move the N64 controller axis value from 0. For X, Y axes.
    AnalogDeadzone = "4096,4096"
    An absolute value of the SDL joystick axis >= AnalogPeak will saturate the N64 controller axis value (at 80). For X, Y axes. For each axis, this must be greater than the corresponding AnalogDeadzone value
    AnalogPeak = "32768,32768"
    Digital button configuration mappings
    DPad R = "hat(0 Right)"
    DPad L = "hat(0 Left)"
    DPad D = "hat(0 Down)
    DPad U = "hat(0 Up)"
    Start = "button(10)"
    Z Trig = "button(9)"
    B Button = "button(1)"
    A Button = "button(0)"
    C Button R = "axis(2+)"
    C Button L = "axis(2-)"
    C Button D = "axis(3+)"
    C Button U = "axis(3-)"
    R Trig = "button(7)"
    L Trig = "button(6)"
    Mempak switch = ""
    Rumblepak switch = ""
    Analog axis configuration mappings
    X Axis = "axis(0-,0+)"
    Y Axis = "axis(1-,1+)"

    THEN here is what i came up with at linux console running "sdl-jstest" to test my buttons. hopefully it's not too confusing πŸ™‚ , but basically i list what my buttons are on my Gamesir, then list what they showed up as in "sdl-jstest" like my A button on Gamesir controller is 0 then i list in equal signs and n64 what it corresponds to or least i think it does to n64 in my mupen64plus.cfg file ...

    Gamesir T4 pro to N64 buttons

    A=0 ====n64 A
    B=1 ====n64 B
    X=3
    Y=4
    select=10
    start=11 =====n64 Start
    L1=6 =====n64 L Trig
    R1=7 ====n64 R Trig
    L2=8
    R2=9 ====n64 Z
    D-up=1 ====n64 U
    D-down=4 ====n64 D
    D-left=8 ======n64 L
    D-right=2 ======n64 R
    axis 0 = stick1 right =====n64 C button R
    axis -0 = stick1 left =====n64 C button L
    axis 1 = stick1 down =====n64 C button D
    axix -1 = stick1 up =====n64 C button U

    axis 2 = stick2 right
    axis -2 = stick2 left
    axis 3 = stick2 down
    axix -3 = stick2 up

    yeah i gotta say this N64 config stuff is a beast compared to all the others, i thought mame was tough and i mastered it πŸ™‚ but N64 is whoop my arse. Also my D-up, down, left ,right in "sdl-jstest" said they were buttons 1,4,8, and 2 i tried that but then left it was you see with hat0.. but still my dang A and B buttons are not even working


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @thanosazlin Sorry, but I don't know how to help, besides the post I quoted, I only know this other one, but it's more outdated:
    https://forum.recalbox.com/topic/9016/a-lire-manettes-n64



  • thanks i tried that.. so i'm pretty technical and i'm following everyone's steps i've tried them all..

    here is my config from sdl2-jstest

    ef598e9d-8ec0-433e-abf8-f0ef70e00d77-image.png joystick name : 'Gamesir-T4pro_8FA5'
    joystick number 0
    A = 0 = 304
    B = 1 = 305
    X = 3 = 307
    Y = 4 = 308
    select = 10 = 314
    start = 11 = 315
    L1 = 6 =310
    R1 = 7 =311
    L2 = 8 = 312
    R2 = 9 = 313
    stick1 pressdown = 13 = 317
    stick2 pressdown = 14 = 318
    hat0 1 Up
    hat0 4 down
    hat0 8 left
    hat0 2 right
    axis 1 U-/D+
    axis 0 L-/R+
    axis 3 U-/D+
    axis 2 L-/R+

    Then here is what i setup in mupen64plus.cfg, i tried mode 0,1, and 2 no differences
    [Input-SDL-Control1]

    Mupen64Plus SDL Input Plugin config parameter version number. Please don't change this version number.
    version = 2
    Controller configuration mode: 0=Fully Manual, 1=Auto with named SDL Device, 2=Fully automatic
    mode = 1
    Specifies which joystick is bound to this controller: -1=No joystick, 0 or more= SDL Joystick number
    device = 0
    SDL joystick name (or Keyboard)
    name = "Gamesir-T4pro_8FA5"
    Specifies whether this controller is 'plugged in' to the simulated N64
    plugged = True
    Specifies which type of expansion pak is in the controller: 1=None, 2=Mem pak, 5=Rumble pak
    plugin = "2"
    If True, then mouse buttons may be used with this controller
    mouse = False
    Scaling factor for mouse movements. For X, Y axes.
    MouseSensitivity = "2.00,2.00"
    The minimum absolute value of the SDL analog joystick axis to move the N64 controller axis value from 0. For X, Y axes.
    AnalogDeadzone = "4096,4096"
    An absolute value of the SDL joystick axis >= AnalogPeak will saturate the N64 controller axis value (at 80). For X, Y axes. For each axis, this must be greater than the corresponding AnalogDeadzone value
    AnalogPeak = "32768,32768"
    Digital button configuration mappings
    DPad R = "hat(0 Right)"
    DPad L = "hat(0 Left)"
    DPad D = "hat(0 Down)
    DPad U = "hat(0 Up)"
    Start = "button(11)"
    Z Trig = "button(8)"
    B Button = "button(1)"
    A Button = "button(0)"
    C Button R = "axis(2+)"
    C Button L = "axis(2-)"
    C Button D = "axis(3+)"
    C Button U = "axis(3-)"
    R Trig = "button(7)"
    L Trig = "button(6)"
    Mempak switch = ""
    Rumblepak switch = ""
    Analog axis configuration mappings
    X Axis = "axis(0-,0+)"
    Y Axis = "axis(1-,1+)"

    i had removed the input.xml saw a post about that. i even created an InputAutoCfg.ini tried that in mupen64plus config dir..

    c5983241-43bf-4f72-bff8-23969534f2cf-image.png InputAutoCfg.ini
    [Gamesir-T4pro_8FA5]
    plugged = True
    plugin = 2
    mouse = False
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    DPad R = hat(0 Right)
    DPad L = hat(0 Left)
    DPad D = hat(0 Down)
    DPad U = hat(0 Up)
    Start = button(11)
    Z Trig = button(8)
    B Button = button(1)
    A Button = button(0)
    C Button R = axis(3+)
    C Button L = axis(3-)
    C Button D = axis(2+)
    C Button U = axis(2-)
    R Trig = button(7)
    L Trig = button(8)
    Mempak switch =
    Rumblepak switch =
    X Axis = axis(0-,0+)
    Y Axis = axis(1-,1+)

    that didn't work.. so i'm at a loss here.. another weird thing is when I add the line for "n64.configfile=dummy" when i start N64 emulator it says something like "error unable to configure dummy file".. and none of my buttons work..

    so i have to remove that line, but when i tried all the different combos of things, one thing remains solid, i can ONLY use start button and the left most joystick on my Gamesir, then also select key i can hit select/start to exit emulator.. another thing when i start the emulator for n64 (and this haps on mame too) i can't use my Gamesir Bt contoller it works fine in ES right before game starts then i have to power it off and back on to get it work 😐 , all other emulators nes, snes, megadrive etc.. all work fine.. i opened an issue for this as well.. i don't know if that has anything to with this or not..

    https://gitlab.com/recalbox/recalbox/-/issues/1378

    i'm just exhausted .



  • so my 8bitdo nes30 and snes30 work perfect i mean well limited buttons πŸ™‚ but yeah , what sucks is my gamesir's worked fine waaay back with recalbox 18.07.14 or something years ago.. i just bought this one off amazon

    https://www.8bitdo.com/sn30-pro-plus/

    seems these 8bitdo's work best with recalbox , sucks i just bought to brand new gamesir t4's 😞 and can't get them to work properly with mame and n64 like i mentioned in my issue i reported in gitlab.



  • ok so my Gamesir's work perfectly fine connected usb. So i guess i have to get 25ft usb cables LOL 😐 , yeah i have a huge theater room that i sit 16ft from the 65 in screen, so i'll have a little bit of slack in the cables.. If anyone from Recalbox team is reading this, please take this post in combo with the gitlab issue

    https://gitlab.com/recalbox/recalbox/-/issues/1378

    it's some BT issue and only with the Gamesirs, my old Gamesir 3GS and the new T4 pro.. same thing that happens with Mame in the gitlab issue happens with N64, if using the Gamesirs BT , once i start a game with N64 or MAME the controller still looks connected BT but doens't work i have to turn it off/on , on Mame that works, but on N64 it causes only 1 stick control on the Gamesir and my select and start buttons to work..

    so while not ideal i would prefer to be able use BT instead of having a cable dragged across my floor πŸ˜‰



Want to support us ?

341
Online

80.5k
Users

21.6k
Topics

158.1k
Posts