Recalbox 7 et 240p



  • Bonjour à tous
    J'utilise depuis toujours le mode 240p sur écran crt et un pi 3b+
    Depuis la version 7 de recalbox cela ne fonctionne plus
    J'ai bien changé le config.txt mais cela reste bloqué sur l'écran aux couleurs arc-en-ciel
    Y a t-il une nouvelle config pour le boot?


  • Staff
    Global moderator
    Team

    Bonjour @normanx9
    quel est la résolution de ton écran ?
    poste ton fichier de config.txt
    sur raspberry pi 3 ça n a pas changé je pense plus pour un problème de configuration de ton coté que tu n'as pas remis en place.


  • Staff
    Developer
    Global moderator
    Creator
    Team

    @normanx9 il va être difficile de te repondre avec si peut d'information. Il faut au moins poster ton config.txt et donenr la méthode utiliée pour du 240p (rgb, composite etc....) et le matos utilisé



  • j'utilise un adaptateur hdmi vers vga
    je viens de réinstaller la version 6.1.1 et la ça fonctionne

    voici mon config.txt

    #Définition de la résolution du mode custom DMT 87 HDMI pour la résolution des jeux
    hdmi_cvt=1920 240 60 1 1 0 0
    #Ignore le EDID de votre TV (le CRT peut envoyer de mauvaises informations)
    hdmi_ignore_edid=0xa5000080
    #Force le mode d'encodage des pixels, 2 correspond à Full RGB
    hdmi_pixel_encoding=2
    #Désactive le safe mode au boot du raspberry pi
    avoid_safe_mode=1
    #Ne pas désactiver l'overscan
    disable_overscan=0
    #Evite les interférences de l'adaptateur en boostant le signal HDMI
    config_hdmi_boost=4
    #Force le son sur HDMI
    hdmi_drive=2
    #Selectionne le groupe HDMI CEA
    hdmi_group=1
    #Résolution CEA 6 = 480 interlaced
    hdmi_mode=6
    
    #Kernel utilisé
    kernel=zImage
    #Utiliser le mode HDMI même si aucun câble n'est connecté
    hdmi_force_hotplug=1
    #paramètres mémoire
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=512
    
    #Paramètre lié à l'audio
    dtparam=audio=on
    #Permet de temporiser le boot
    boot_delay=3
    

  • Staff
    Global moderator
    Team

    tu as posté le config.txt dans la version 7 ou de la version 6.1.1

    faut réinstaller la version 7



  • c'est le même config.txt utiliser pour la version 6.1.1 et 7.0.1


  • Staff
    Global moderator
    Team

    @normanx9 said in Recalbox 7 et 240p:

    c'est le même config.txt utiliser pour la version 6.1.1 et 7.0.1

    mauvaise idée.

    tu dois adapter celui de la verson 7.0.1, et pas utiliser celui de 6.1.1 sur 7.0.1
    y a des modifications
    donc réinstaller 7.0.1 et poste ton config.txt.





  • voici le config.txt de la version 7.0.1 fraichement installé

    #############################################################
    # Boot loader configuration                                 #
    # This file can be modified to your needs                   #
    #############################################################
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1                                                                                                                                                                                                 
    
    disable_overscan=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # Sound output. Set to 0 or comment for autodetect, 1 for DVI, 2 to force HDMI.
    #hdmi_drive=2
    
    config_hdmi_boost=0
    
    # force hdmi while the tv can take time before sending the signal on the hdmi output
    hdmi_force_hotplug=1
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    # uncomment for lirc-rpi
    #dtoverlay=lirc-rpi
    
    # total amount of GPU memory
    gpu_mem_512=256
    gpu_mem_1024=448
    
    ###########################
    # do not remove this line !
    include recalbox-config.txt
    
    # custom config                                                                                                                                                                                              
    [all]
    

  • Staff
    Developer
    Global moderator
    Creator
    Team

    @normanx9 tente celui là
    https://recalbox.gitbook.io/tutorials/v/francais/video/crt/connectez-votre-recalbox-a-un-ecran-cathodique-avec-hdmi-et-scart

    il faut modifier dans la section [all] avec le paramètres donnés dans le lien précédent



  • Faut il effacer le [all] ?



  • merci @ian57 cela foctionne
    voici le bon config.txt

    #############################################################
    # Boot loader configuration                                 #
    # This file can be modified to your needs                   #
    #############################################################
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1                                                                                                                                                                                                 
    
    disable_overscan=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # Sound output. Set to 0 or comment for autodetect, 1 for DVI, 2 to force HDMI.
    #hdmi_drive=2
    
    config_hdmi_boost=0
    
    # force hdmi while the tv can take time before sending the signal on the hdmi output
    hdmi_force_hotplug=1
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    # uncomment for lirc-rpi
    #dtoverlay=lirc-rpi
    
    # total amount of GPU memory
    gpu_mem_512=256
    gpu_mem_1024=448
    
    ###########################
    # do not remove this line !
    include recalbox-config.txt
    
    # custom config                                                                                                                                                                                              
    hdmi_cvt=1920 240 60 1 1 0 0
    hdmi_disable_edid=0xa5000080 #Enables the ignoring of EDID/display data if your display doesn't have an accurate EDID.
    
    hdmi_pixel_encoding=2 #Force the pixel encoding mode. By default it will use the mode requested from edid so shouldn't need changing. 
    avoid_safe_mode=1
    disable_overscan=0 #oversan enabled
    hdmi_drive=2
    hdmi_group=1
    hdmi_mode=6
    hdmi_force=1
    

  • Staff
    Developer
    Global moderator
    Creator
    Team

    @normanx9 nop pas besoin d'effacer le [all] il s'agit d'une directive de selection : https://www.raspberrypi.org/documentation/configuration/config-txt/conditional.md

    super si ça marche


Log in to reply
 

Want to support us ?

280
Online

80.5k
Users

21.7k
Topics

158.4k
Posts