Screenscaper issue

For information, Screenscraper website is currently down. All the Screenscraper staff is aware of this issue. Until it's solved, you won't be able to scrap from Recalbox or Skraper. We apologize for the inconvenience.

Pour information, le site internet de Screenscraper est actuellement en panne. Toute l'équipe de Screenscraper est consciente de ce problème. Tant qu'il ne sera pas résolu, vous ne pourrez pas scraper depuis Recalbox ou Skraper. Veuillez nous excuser pour le dérangement.

The Recalbox Team.

Recalbox 7.0 on RPi4 - N64 not working for me



  • Hello,

    I did a clean install of Recalbox 7 on RPi4 (unmodified).
    I only registered my 8bitdo SF30 Pro Controllers via Bluetooth.
    N64 roms arent launched at all, I see the Recalbox Screen for 1-2 seconds and then get back to the game list. Tried different ROMs (ByteSwapped, BigEndian, all non zipped). Also tried the different video modes in recalbox.conf, as suggested in other topics. I am using a standard 4K TV via HDMI. Log:
    [2020/10/03 10:10:18.359] (INFO ) : Set 8Bitdo SF30 Pro for player 0 (default)
    [2020/10/03 10:10:18.359] (INFO ) : Configure emulators command : -p1index 0 -p1guid 05000000c82d00000061000000010000 -p1name "8Bitdo SF30 Pro" -p1nbaxes 4 -p1nbhats 1 -p1nbbuttons 16 -p1devicepath /dev/input/event0
    [2020/10/03 10:10:18.359] (INFO ) : Controllers config : -p1index 0 -p1guid 05000000c82d00000061000000010000 -p1name "8Bitdo SF30 Pro" -p1nbaxes 4 -p1nbhats 1 -p1nbbuttons 16 -p1devicepath /dev/input/event0
    [2020/10/03 10:10:18.359] (INFO ) : Shutting down SDL AUDIO
    [2020/10/03 10:10:18.942] (INFO ) : python /usr/lib/python2.7/site-packages/configgen/emulatorlauncher.pyc -p1index 0 -p1guid 05000000c82d00000061000000010000 -p1name "8Bitdo SF30 Pro" -p1nbaxes 4 -p1nbhats 1 -p1nbbuttons 16 -p1devicepath /dev/input/event0 -system n64 -rom /recalbox/share/roms/n64/Mario\ Kart\ 64\ (Europe)\ (Rev\ 1).v64 -emulator mupen64plus -core gliden64 -ratio auto
    [2020/10/03 10:10:18.942] (INFO ) : No pad2keyb configuration.
    [2020/10/03 10:10:18.943] (INFO ) : [MQTT] Publishing to tcp://127.0.0.1:1883 from recalbox-emulationstation OK!
    [2020/10/03 10:10:22.276] (WARN!) : ...launch terminated with nonzero exit code 245!
    [2020/10/03 10:10:22.277] (INFO ) : Creating surface...
    [2020/10/03 10:10:22.277] (INFO ) : [MQTT] Publishing to tcp://127.0.0.1:1883 from recalbox-emulationstation OK!
    [2020/10/03 10:10:22.426] (INFO ) : Created window successfully.
    [2020/10/03 10:10:22.446] (INFO ) : Activating vertical sync'
    [2020/10/03 10:10:22.446] (INFO ) : Normal VSync' activated.
    [2020/10/03 10:10:22.446] (INFO ) : Checking available OpenGL extensions...
    [2020/10/03 10:10:22.446] (INFO ) : ARB_texture_non_power_of_two: MISSING
    [2020/10/03 10:10:22.637] (INFO ) : Loaded 21 configuration entries for device 8Bitdo SF30 Pro
    [2020/10/03 10:10:22.637] (WARN!) : Added joystick 8Bitdo SF30 Pro (GUID: 05000000c82d00000061000000010000, Instance ID: 5, Device Index: 0, Axis: 4, Hats: 1, Buttons: 16)
    [2020/10/03 10:10:23.148] (INFO ) : SDL AUDIO Initialized
    [2020/10/03 10:10:23.149] (INFO ) : Loading music /recalbox/share_init/system/.emulationstation/themes/recalbox-next/music/Recalbox Main Theme 06 - SMB - by djpostka.ogg
    [2020/10/03 10:10:23.150] (INFO ) : AudioManager: Theme music found (From theme folder).
    [2020/10/03 10:10:23.150] (INFO ) : Playing Recalbox Main Theme 06 - SMB - by djpostka

    Any suggestions?

    Best Regards
    Andreas


  • Global moderator
    Team

    Hello @acenet
    try another emulator/core.

    Reconfigure your pad in Emulationstation Menu



  • Hi,
    unfortunately reconfiguring the pad didn't help. How to change the emulator? Isn't it a disadvantage in terms of performance etc? I guess the best option is configured out of the box, isn't it?

    Best Regards


  • Global moderator
    Team

    Hello @acenet
    try to find and add 64DD_IPL.bin in /bios/ folder, and play again.


  • Global moderator
    Tester

    @acris @acenet
    This is an known issue, mupen cores are not lauching, libretro ones do.
    We'll check it.



  • I have this problem too, 64DD_IPL.bin didn't help



  • I have this problem as well. Whichever core I use, the screen comes back to EmulationStation without launching. This seems to be a known problem, because in the N64 rom readme file, it says:

    " If you have problems about black screen with return to Emulationstation, please read wiki below :
    https://github.com/recalbox/recalbox-os/wiki/N64-%3A-return-to-ES-(EN) "

    Problem: the linked page does not exist anymore, as the wiki has been moved. It is therefore very difficult to find the necessary help for this issue.

    Does anyone have an updated link for this issue?


  • Global moderator
    Tester

    @ZeBug The link is probably a very old one, that has nothing to do with the current bug. There is no solution avaible for instant on this forum !
    Devs are working on several fixes, this is one of them : wait and look for the upcoming update.
    @suzsuzuki the N64DD bios doesn't solve the problem. N64 doesn't require any bios.



Want to support us ?

225
Online

79.6k
Users

21.0k
Topics

153.6k
Posts