Recalbox 7.0

Set static IP for recalbox 6.1.1



  • Hi.

    Running on 6.1.1 i am having trouble setting a static IP for the recalbox. i want to set a static ip to eth0, as simple as that.

    I tried this : https://github.com/recalbox/recalbox-os/wiki/Manual-IP-settings-(EN)

    but after reboot the IP goes back to dhcp (i do remount as read/write)

    this still remains in /etc/network/interfaces :

    cat /etc/network/interfaces

    Configure Loopback

    auto lo
    iface lo inet loopbac
    auto eth0
    iface eth0 inet static
    allow-hotplug eth0
    address 192.168.1.5
    network 192.168.1.0
    netmask 255.255.255.0
    gateway 192.168.1.1
    broadcast 192.168.1.255

    i tried connmanctl but there is no such command installed

    connmanctl services

    -sh: connmanctl: command not found

    i don't know what to try next.

    thank you for updating the doc at the same time if you lay out the solution here 🙂 thanks.


  • Local Moderator

    @Quardah If I'm not mistaken, since version 6.1.1, it is possible to edit the ip manually in the recalbox.conf file:

    ## Wifi - static IP
    ## if you want a static IP address, you must set all 3 values (ip, gateway, and netmask)
    ## if any value is missing or all lines are commented out, it will fall back to the
    ## default of DHCP
    wifi.ip =
    

    It is much easier now, the tutorial you are following is probably out of date.



  • I have the same issue, the command is not available

    # find . -name connmanctl
    # connmanctl services 
    -sh: connmanctl: command not found
    

    And I'm trying to set static IP for the ethernet port (not the wifi), so the paramater wifi.ip is not for me.


  • Local Moderator
    Tester

    Hi
    Just to undersand.
    Why you did not keep Recalbox with Dynamic IP.
    Then in your DHCP settings, your profide a fixed IP linked to MAC adress of your recalbox ?



Want to support us ?

162
Online

79.1k
Users

20.3k
Topics

149.0k
Posts