Screenscaper issue

For information, Screenscraper website is currently down. All the Screenscraper staff is aware of this issue. Until it's solved, you won't be able to scrap from Recalbox or Skraper. We apologize for the inconvenience.

Pour information, le site internet de Screenscraper est actuellement en panne. Toute l'équipe de Screenscraper est consciente de ce problème. Tant qu'il ne sera pas résolu, vous ne pourrez pas scraper depuis Recalbox ou Skraper. Veuillez nous excuser pour le dérangement.

The Recalbox Team.

Installing drivers for GamePi43 waveshare



  • Hi,

    I just got my GamePi43 from waveshare.

    https://www.waveshare.com/product/mini-pc/gamepi43-acce-us.htm

    I try to install the driver following the description on the waveshare page.

    https://www.waveshare.com/wiki/GamePi43

    They also give the driver.

    https://www.waveshare.com/w/upload/6/6f/GamePi43-190717.tar.gz

    If I try to unpack the archiv or even just move it, the error msg appears that I dont have writing rights. If I try to use "su root" before the order, I get the error msg "connot execute binary file".

    Whats my mistake? How can I get the GamePi43 running.

    0_1579779154432_WhatsApp Image 2020-01-21 at 23.33.02.jpeg


  • Developer
    Global moderator
    Team

    @liankain There is no su command on Recalbox OS, so your script cannot work, it must be adapted.



  • @oyyodams Like I said, I used "su" not "sudo" and it seems to bring a little progress. Its just brought me to the next barrier ("connot execute binary file") but in gerneral the "su" command seemed to work.

    But what ever. The problem is I´m not that experienced in unix, so I need a little more detailed instructions what to do.


  • Developer
    Global moderator
    Team

    @liankain sudo or su are not implemented in Recalbox. These commands are used to execute root commands as a standard user. On Recalbox, you're root all the time. That's why su root means nothing here.



  • @oyyodams OK, thanks for that information. So I know now what not works. ;-D
    Could you give me some clues what to do to solve my problem to install the gamepi43 drivers? 🙂

    That are the instructions of waveshare, but unfortunataly it not works because root only have reading rights.

    tar xzvf /boot/GamePi43-*.tar.gz
    cd GamePi43/
    ./GamePi43

    They say I need to copy the driver-archiv in the root folder, but I also cant move the files there because of the only reading restrictions.


  • Developer
    Global moderator
    Creator
    Team

    From your recalbox via ssh :

    wget https://www.waveshare.com/w/upload/6/6f/GamePi43-190717.tar.gz --no-check-certificate
    tar xzf GamePi43-190717.tar.gz 
    cd GamePi43
    

    and as scripted in the GamePi43 file :

    mount -o remount,rw /       
    mount -o remount,rw /boot   
                                
    mkdir -p /lib/modules/4.14.62/extra/
                                
    cp ./recalbox/mk_arcade_joystick_rpi.ko /lib/modules/4.14.62/extra/
                                
    cp ./recalbox/etc/modules.conf-43 /etc/modules.conf
    cp ./recalbox/boot/config.txt-43 /boot/config.txt
                                
    cp ./recalbox/recalbox/share/system/recalbox.conf-43  /recalbox/share/system/recalbox.conf
                                 
    reboot   
    

    That's all



  • @ian57 @oyyodams It works now. Thank you both a lot.

    I already put the unpacked "GamePi43"-folder in the "share"-folder before. So I followed your scripted steps from that point but it also worked.

    Just for my own information and in case I not bothering you with that question, but:

    What was the problem?
    Why the description from waveshare not worked?
    Why root dont got the rights to move (mv) but copy (cp) works?

    Thanks in advance and thanks again for the help.


  • Developer
    Global moderator
    Creator
    Team

    @liankain the problem was that the Recalbox root (/) filesystem is readonly to prevent to be corrupted by a crash or a hard reboot. So you need to turn it in read-write mode to be able to copy files in it. Only the share partition is in RW. If the filesystem is in Read only mode even root cannot modify it.

    The waveshare wiki is full of errors :)... they mixed the retropie way with the recalbox way. For example they git a login Pi with recalbox, which is not good 🙂



  • @ian57 Ok, I understand. Thanks again. 😉



Want to support us ?

193
Online

79.7k
Users

21.0k
Topics

154.1k
Posts