Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Manette M30 8Bitdo non reconnue sous 6.1.1



  • Bonjour/Bonsoir à tous.

    Voilà, je vais vous remettre dans le contexte.

    Je jouais sur ma Recalbox avec la version 6.1.0, j'avais configuré ma manette M30 8BitDo, mise à jour avec le dernier firmware, et la manette fonctionnait parfaitement, je l'avais configurée pour chaque émulateur, tout fonctionnait nickel.

    Puis, me vint l'envie d'installer la version 6.1.1 de recalbox sur carte SD RPI 3B+.

    Et là, fin de la récré, la manette est reconnue sans problème dans Emulationstation, je peux l'utiliser pour naviguer dans les menus sans problème (la manette est en bluetooth sans dongle pour info).

    Mais une fois dans un jeu, quelque soit l'émulateur, la manette n'est plus reconnue.

    J'arrive à la faire reconnaître en la redémarrant, cependant, les touches sont configurées n'importe comment, bref, injouable, et impossible de se rendre dans le menu de retroarch, car la manette agit comme si j'appuyais toujours vers le bas.

    Bref, je suis un peu dégouté, car il s'agit d'une super manette pour les jeux de baston.

    Pour info, ma manette SF 30 Pro fonctionne parfaitement.

    J'ai essayé de jouer en laissant les deux manettes connectées ou juste la M30... même problème.

    Donc, je fais appel à vous, pour savoir si quelqu'un a déjà rencontré ce problème. Merci Beaucoup.


  • Global moderator
    Team

    Bonjour
    @ashramhtv said in Manette M30 8Bitdo non reconnue sous 6.1.1:

    Et là, fin de la récré, la manette est reconnue sans problème dans Emulationstation, je peux l'utiliser pour naviguer dans les menus sans problème (la manette est en bluetooth sans dongle pour info).

    ce n'est pas parce que la manette fonctionne dans emulationstation, qu'il ne faut pas la reconfigurer dans configurer une manette afin qu'elle soit reconnu par retroarch.
    l'as tu reconfiguré ?
    si non, fais le et reteste



  • Bonjour,

    Oui, après l'avoir faites détecter dans emulationstation, je l'ai de suite configuré et positionnée en première manette.

    Ensuite, je la'ce un jeu (megadrive, fba ou neogeo peu importe...), et là, la manette n'est reconnue du tout, je suis obligé de redémarrer la manette, une fois redémarrée, elle est détectée, mais les touches ne sont plus du tout configurées correctement, du coup, j'essaie tant bien que mal d'accéder au menu de rétro arch pour la configurer, mais une fois dans le menu, impossible de naviguer dans celui ci, retroarch réagit comme si ma manette était bloquée sur la touche bas...

    Je dois redémarrer le raspberry et je reviens au point de départ.

    Entre temps, la manette a perdu sa configuration dans emulationstation.

    Pour info, ça fonctionne parfaitement avec ma SF30 pro et ma manette xbox one.


  • Developer
    Global moderator
    Team

    @ashramhtv est-ce que les boutons L2/R2 ou L3/R3 sont reconnus comme des "axis" et non des "button" ?



  • Voici ce que j'ai dans le fichier de config @OyyoDams :

    <inputConfig type="joystick" deviceName="8BitDo M30 gamepad" deviceGUID="05000000c82d00005106000000010000" deviceNbAxes="6" deviceNbHats="1" deviceNbButtons="16">
    	<input name="a" type="button" id="1" value="1" code="305" />
    	<input name="b" type="button" id="0" value="1" code="304" />
    	<input name="down" type="axis" id="1" value="1" code="1" />
    	<input name="hotkey" type="button" id="2" value="1" code="306" />
    	<input name="l2" type="button" id="6" value="1" code="310" />
    	<input name="left" type="axis" id="0" value="-1" code="0" />
    	<input name="pagedown" type="axis" id="4" value="-1" code="9" />
    	<input name="pageup" type="axis" id="5" value="-1" code="10" />
    	<input name="r2" type="button" id="7" value="1" code="311" />
    	<input name="right" type="axis" id="0" value="1" code="0" />
    	<input name="select" type="button" id="10" value="1" code="314" />
    	<input name="start" type="button" id="11" value="1" code="315" />
    	<input name="up" type="axis" id="1" value="-1" code="1" />
    	<input name="x" type="button" id="4" value="1" code="308" />
    	<input name="y" type="button" id="3" value="1" code="307" />
    </inputConfig>


  • Bonjour,

    J'ai exactement les mêmes problèmes.
    (voir post ici https://forum.recalbox.com/topic/20284/8bitdo-m30-divers-bugs-soundains-et-inexplicables ).

    As-tu trouvé une solution ?


  • Global moderator
    Team



Want to support us ?

122
Online

78.7k
Users

20.2k
Topics

148.0k
Posts