Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Problema compatibilidad Arcade Stick Netway



  • Buenas tardes.

    Quería exponer mi problema. Tengo un "Arcade Stick Netway Gaming Arcade Fighter PS3/PC", tal como el de la foto de debajo:

    alt text

    Siempre me ha ido de maravilla en mi Raspberry Pi 3B, pero la última vez que funcionó fue en la versión 4.1 de Recalbox. Desde que actualicé a la versión 6.0 dejó de funcionar, no lo reconoce. En la versión 6.1 y 6.1.1 ocurre lo mismo, sigue sin reconocerlo. Es como si hubiese dejado de ser compatible con Recalbox.

    ¿Alguna solución para que me lo vuelva a reconocer? ¿Se podrá solucionar en alguna actualización futura?

    Muchas gracias por vuestro tiempo.


  • Staff
    Team
    Moderator
    Translator

    @ark tiene algun switch para cambiar de modo ps3 a modo pc o viceversa? Has probado configurandolo en ambos modos?



  • @paradadf que va, no tiene ningún botón para esa función.

    He probado a pulsar todos los botones de todas maneras y no hay ningún cambio.

    No entiendo por qué dejó de ser compatible a partir de la 6.0, con lo bien que iba en anteriores versiones...


  • Staff
    Team
    Moderator
    Translator

    @ark yo probaria en una instalacion nueva, solo por si acaso.



  • @paradadf ya lo hice, la 6.1 la instalé limpia para ver si se solucionaba, y tampoco funcionó.

    Ya que desde el menú de Recalbox no hay manera, lo único que se me ocurre probar es desde el propio menú de configuración de RetroArch dentro de algún juego. Me interesa que se guarden las opciones para Neo-Geo, que es para lo que uso el mando arcade.



  • desde RetroArch estamos en las mismas, como no detecta el pad no se puede configurar.


  • Staff
    Team
    Moderator
    Translator

    @ark la conexion es por usb? Si es asi, teniendo conectado solo ese mando, crea un archivo de soporte y compartilo aqui por favor.



  • @paradadf al intentar crear el archivo de soporte me pone "Internal Server Error"

    https://i.imgur.com/ERyLRqw.jpg


  • Staff
    Team
    Moderator
    Translator

    @ark intenta generandolo localmente como se indica aqui:

    https://github.com/recalbox/recalbox-os/wiki/Recalbox-support-(EN)

    No recuerdo donde es que se crea el archivo, pero imagino que sera en share/recalbox/system



  • @paradadf he subido el archivo generado aquí:

    http://dl.free.fr/getfile.pl?file=/6dFZIFNZ

    Un saludo.


  • Staff
    Team
    Moderator
    Translator

    @ark en ese archivo no se detecta ningun mando.
    Podrias por favor desconectar absolutamente todos los perifericos innecesarios y crear el archivo nuevamente? Especialmente te pido no usar el hub usb para esta prueba. Has probado tmb configurar el mando sin usar el hub (conectandolo directamente a la rpi)?


  • Staff
    Team
    Moderator
    Translator

    @ark he encontrado esto en el log de dmesg:

    [    2.170507] usb 1-1.2: New USB device found, idVendor=054c, idProduct=0268
    [    2.170516] usb 1-1.2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
    [    2.170521] usb 1-1.2: Product: USB Controller
    [    2.207091] udevd[160]: starting eudev-3.2.5
    [    2.306368] usbcore: registered new interface driver usbhid
    [    2.306376] usbhid: USB HID core driver
    [    2.437398] sony 0003:054C:0268.0001: failed to retrieve feature report 0xf2 with the Sixaxis MAC address
    [    2.437668] sony 0003:054C:0268.0001: hiddev96,hidraw0: USB HID v81.11 Joystick [USB Controller] on usb-3f980000.usb-1.2/input0
    [    2.437673] sony 0003:054C:0268.0001: failed to claim input
    [    2.612562] brcmfmac: F1 signature read @0x18000000=0x1541a9a6
    [    2.616102] snd_bcm2835: module is from the staging directory, the quality is unknown, you have been warned.
    [    2.616664] brcmfmac: brcmf_fw_map_chip_to_name: using brcm/brcmfmac43430-sdio.bin for chip 0x00a9a6(43430) rev 0x000001
    [    2.616815] snd_bcm2835: unknown parameter 'index' ignored
    [    2.616826] usbcore: registered new interface driver brcmfmac
    [    2.617781] bcm2835_alsa bcm2835_alsa: card created with 8 channels
    [    2.627119] usb 1-1.2: USB disconnect, device number 4
    [    2.837846] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Oct 23 2017 03:55:53 version 7.45.98.38 (r674442 CY) FWID 01-e58d219f
    [    2.838498] brcmfmac: brcmf_c_preinit_dcmds: CLM version = API: 12.2 Data: 7.11.15 Compiler: 1.24.2 ClmImport: 1.24.1 Creation: 2014-05-26 10:53:55 Inc Data: 9.10.39 Inc Compiler: 1.29.4 Inc ClmImport: 1.36.3 Creation: 2017-10-23 03:47:14 
    [    3.122599] urandom_read: 4 callbacks suppressed
    [    3.122604] random: dbus-daemon: uninitialized urandom read (12 bytes read)
    [    3.175398] random: dbus-daemon: uninitialized urandom read (12 bytes read)
    [    3.398013] random: crng init done
    [    3.441531] usb 1-1.2: new full-speed USB device number 5 using dwc_otg
    [    3.590381] usb 1-1.2: New USB device found, idVendor=1345, idProduct=3008
    [    3.590389] usb 1-1.2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
    [    3.590393] usb 1-1.2: Product: USB Controller
    [    3.609249] sony 0003:1345:3008.0002: failed to retrieve feature report 0xf2 with the Sixaxis MAC address
    [    3.609564] sony 0003:1345:3008.0002: hiddev97,hidraw1: USB HID v81.10 Gamepad [USB Controller] on usb-3f980000.usb-1.2/input0
    [    3.609568] sony 0003:1345:3008.0002: failed to claim input
    

    Olvida lo de generar otro archivo de soporte por el momento, no habia visto bien. Pero intenta por favor configurar el mando en EmulationStation con tu mando conectado directamente a la rpi y no a traves de un hub.


  • Staff
    Team
    Moderator
    Translator

    @ark en el caso que conectado directamente a la rpi siga sin funcionar, intenta lo siguiente por favor.

    El mando solo funciona por usb, cierto? No tiene funcionalidad bluetooth?

    1. Conectate por SSH y escribi:
    mount -o remount, rw /
    

    Luego

    nano /etc/modprobe.d/usbhid.conf
    

    Ahora añade al final del archivo, creando una nueva linea, lo siguiente:

    # USB HID v81.11 Joystick [USB Controller]
    usbhid.quirks=0x054c:0x0268:0x040
    

    Ahora reinicia e intenta configurar el mando nuevamente:
    reboot

    1. Si con lo anterior sigue sin funcionar intentemos otra cosa.
      Primero, crea un nuevo archivo de soporte y compartilo. Es para ver si el cambio anterior afecto positivamente en algo al mando.
      Despues, elimina el usbhid.quirks que agregaste anteriormente.
      Ahora por SSH escribi:
    mount -o remount, rw /
    

    Luego

    echo 'SUBSYSTEM=="input", ATTRS{name}=="USB Controller", MODE="0666", ENV{ID_INPUT_JOYSTICK}="1"' >> /etc/udev/rules.d/99-joysticks-exotics.rules
    

    y reinicia:

    reboot
    

    Finalmente intenta configurar el mando nuevamente y cruza los dedos!

    PD: Si despues de esto aun sigue sin funcionar, crea un nuevo archivo de soporte y compartilo.

    PD2: Podes intentar tambien la primer parte con este otro quirks en caso de no funcionar lo anterior:

    # USB HID v81.10 Gamepad [USB Controller]
    usbhid.quirks=0x1345:0x3008:0x040
    


  • @paradadf primero, muchas gracias por molestarte y calentarte la cabeza a fondo.

    Dicho esto, te digo. Efectivamente el pad solo funciona por usb, y lo tengo conectado directamente a la rpi, sin ningún hub ni nada.

    Respecto a la solución 1, al intentar "nano /etc/modprobe.d/usbhid.conf", el sistema me devuelve "Error opening terminal: unknown."
    Ya después no puedo añadir ningún tipo de línea "# USB HID" porque no existe en mi sistema ningún archivo que contenga "usbhid", ni "usbhid.conf", ni "usbhid.quirks" (por tanto no puedo eliminar este último).

    Respecto a la solución 2, sigue sin detectar el mando, y el archivo de soporte creado es el siguiente:
    http://dl.free.fr/getfile.pl?file=/CYjvfRNj

    Muchas gracias nuevamente por intentar ayudarme, me trae loco este tema, más cuando en versiones anteriores 4.X me funcionaba perfectamente.



  • @paradadf se me ocurren dos cosas...

    1. En la versión 4.0 y 4.1 iba de maravilla. ¿Hay alguna manera de volverlo a configurar en esas versiones desde otra microsd y copiar algún fichero con la configuración o alguna línea de código para trasladarlo a las versiones posteriores?

    2. Comprar otro stick arcade :|


  • Staff
    Team
    Moderator
    Translator

    @ark no he tenido tiempo aun de mirar el archivo. Una consulta... estas en una rpi3, no?



  • @paradadf juego en una pi3b



Want to support us ?

157
Online

62139
Users

18656
Topics

140127
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.