Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Up & Down not working in FBA / CAPCOM Games (Version 4.1 Dev (18.02.09))



  • Hello everyone,

    First off, I read as many topics as possible trying to find an answer to my problem before posting here.

    A couple of years ago I bought an arcade setup from a guy and it was running Recalbox 3.x or something. It came working perfectly well, but I ran an update after a few months and the box was updated to 4.1 Dev (18.02.09)

    Right after the upgrade, I lost two things:

    1 - The mapping of the GPIO controllers
    2 - The ability to upgrade again

    I put the box aside for a little over a year, but today I tried again and this is where I am so far:

    Issue #1 - I connected a standard keyboard to the Pi and successfully managed to remap the GPIO buttons and joystick. In regards to the Recalbox UI, all directions and buttons work as expected, except that in the games Up and Down are completely ignored by some games (All CAPCOM/FBA_LibRetro Games)

    Issue #2 - It seems to be caused by the fact I'm using a DEV version (4.1 (18.02.09))

    Reading another topic about the upgrade I found this

    # bash -x /recalbox/scripts/upgrade/recalbox-upgrade.sh canupgrade

    Tha returned this:

    • COMMAND=canupgrade
    • [[ -z canupgrade ]]
    • BINDIR=/recalbox/scripts/upgrade/
    • SYSTEMSETTINGS='python /usr/lib/python2.7/site-packages/configgen/settings/recalboxSettings.pyc'
    • RECALBOX_SYSTEM_DIR=/recalbox/share/system
      ++ cat /recalbox/recalbox.version
    • INSTALLED_VERSION=18.02.09
      ++ cat /recalbox/recalbox.arch
    • ARCH=rpi3
      ++ python /usr/lib/python2.7/site-packages/configgen/settings/recalboxSettings.pyc -command load -key updates.type
    • UPGRADETYPE=stable
    • SERVICE_URL=https://recaleur-archive-prod.recalbox.com:9443
      ++ /recalbox/scripts/upgrade//../system/uuid.sh --uuid-file /recalbox/share/system/uuid
    • UUID=4f619829-d3c1-417e-a1d4-980e69d15d88
    • [[ stable == \b\e\t\a ]]
    • [[ stable == \u\n\s\t\a\b\l\e ]]
    • '[' canupgrade == canupgrade ']'
    • [[ stable == \s\t\a\b\l\e ]]
    • /recalbox/scripts/upgrade//recalbox-canupgrade.sh --from-version 18.02.09 --service-url https://recaleur-archive-prod.recalbox.com:9443 --arch rpi3 --uuid 4f619829-d3c1-417e-a1d4-980e69d15d88
      curl: (6) Couldn't resolve host 'recaleur-archive-prod.recalbox.com'
    • exit 6

    My immediate concern is #1 as I cannot play the FBA games. I did not report it as a GPIO issue because the controllers are being mapped properly in the settings and Recalbox UI is responding properly to them, Up, Down, Left, Rigth.... All Good...

    But in the FBA games only, Up and Down commands are not recognized...

    Any advice here for me? I'm completely lost and wanted to make this thing work to play it with my son...

    Thanks in advance
    Daniel


  • Staff
    Team
    Moderator
    Translator

    @millturnbr reinstall everything from scratch making a clean official istallation because of many reason:

    1. You paid for the software we (devs and community) give out for free; development and support
    2. We don’t know what kind of modifications software-wise has been made, making impossible to diagnose it
    3. Whatever version you have is obsolete and can not be upgraded anymore
    4. Three reasons are enough ;)


  • Thanks for the warming welcome!


  • CRT Hero

    @paradadf said in Up & Down not working in FBA / CAPCOM Games (Version 4.1 Dev (18.02.09)):

    You paid for the software we (devs and community) give out for free; development and support

    Furthermore, selling fbalpha is illegal in the first place.


  • Staff
    Team
    Moderator
    Translator

    @barbudreadmon yes... most emulators recalbox delivers have non-comercial licenses, not only fbalpha/fbneo.


Log in to reply
 

Want to support us ?

244
Online

61605
Users

18634
Topics

140018
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.