Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

The XU4 board does not retain the RTC time.



  • I installed recalbox 6.0 on the Odroid XU4 board. I installed the RTC Battery to use the RTC Timer on the XU4 board. Then, I set the Time Zone to Asia/Seoul in the Config file of the Recall Box.
    However, it cannot display the current time unless it is connected to the Internet.
    How can I fix it? Thank you for helping me.



  • @shs2002 Since you have cross-posted exactly this very question at the Odroid forums, have you at least tried the solution suggested by rooted user?

    hwclock -w


  • @nwildner

    Thank you for your response.
    I tried with the advice of the ODROID forum.

    I tried the hwclock command after logging in to the recalbox's Linux system as the root user.
    And, the RTC's clock is set to local time.

    It is not valid when rebooting. The clock in the recall box does not maintain the local time when offline.
    But I found one interesting fact.
    While offline, the RTC clock on the Linux system in recalbox retains its normal value, but the menu on the recalbox does not seem to use the RTC clock.
    It seems to be a problem in the program source of the recalbox.



  • @shs2002 Just for double-checking, have you set system.timezone=Asia/Seoul on your recalbox.conf file?

    Cheers.



  • @nwildner

    @nwildner said in The XU4 board does not retain the RTC time.:

    system.timezone=Asia/Seoul on your recalbox.conf file

    Of course, I set system.timezone = Asia / Seoul on recalbox.conf file.
    So, when the internet is connected, the recalbox menu displays the correct local time.
    However, when I boot it off-line, it displays about 9 hours faster.
    I can then access the recalbox 's root user on the Linux system and modify the time, but the time on the rtc clock keeps the original local time.
    The time on the rtc clock is retained by reboot but the recalbox does not use it. When I boot off-line, the menus in the recalbox display 9 hours faster than the rtc clock.

    This is not my setting mistake, but the program problem of the recall box is obvious.

    Thank you for your kindness.



  • I explain my trick about RTC time.
    Set the RTC time to 9 hours behind local time.
    It then represents the time in the recalbox to match my local time.
    With this I was able to conclude the RTC time issue.
    But I'm not sure if this is the right way.


  • Staff
    Moderator
    Team

    @shs2002 What is obvious is that you don't know how an RTC is supposed to work.

    Your RTC must be set to the UTC time, not your local time.
    It's up to the operating system (or emulationstation in Recalbox) to shift the UTC time to your local time.

    If you set the RTC to your local time, the time used in EmulationStation will be shifted twice, and that's obviously and perfectly normal. Nothing to do with the "recalbox program".

    The "trick" you're using is not a trick. It's just the way it's supposed to be.



  • @bkg2k
    Thank you so much! :-)



Want to support us ?

212
Online

59772
Users

18514
Topics

139291
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.