Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Problème script on/off SuperPi Case



  • Bonjour à tous

    J'ai un petit souci avec la fonctionnalité on/off du boîtier SuperPi Case. Celle-ci ne fonctionne pas dans Recalbox alors que la fonction Reset fonctionne très bien avec ses différentes nuances (reboot du jeu, de la machine, etc.).

    J'ai évidemment bien décommenter la ligne qu'il faut dans recalbox.conf, mais rien à faire.

    Electriquement pourtant, le bouton on/off semble fonctionner. Je l'ai testé au démarrage du pi, lorsque le splashscreen apparaît, et là, ça s'éteint (oui ça abime la carte mais c'était pour tester).

    Par contre, une fois dans ES, j'ai beau monter et descendre le bouton on/off, il ne se passe rien, le pi reste désespérément allumé.

    Du coup, pour éteindre "proprement", je me retrouve à d'abord mettre le bouton du SuperPi Case sur "off" et ensuite appuyer sur Reset.

    Est-ce que quelqu'un aurait idée de la source du problème ?

    Merci pour vos lumières.



  • Salut,
    as tu installé un script externe pour gérer le safe shutdown (genre celui dispo sur le site de Retroflag) ?
    La première fois, j'avais eu ce souci après avoir installé leur script.
    J'avais donc été obligé de repartir de zero (formatage / flashage de la SD avec l'image Recalbox, ne surtout pas installer le script, et juste décommenter la ligne dans le fichier de conf de recalbox après la réinstallation du système), et à présent, ça fonctionne nickel :

    • appui court sur le bouton reset en jeu --> redémarre le jeu,
    • appui long sur le bouton reset en jeu --> retour sur EmulationStation
    • bascule de l'interrupteur ON/OFF en position OFF --> éteint proprement Recalbox puis coupe l'alimentation du PI

    Recalbox gère nativement le safe shutdown, à condition que le boitier l'implémente (ce qui est le cas du Superpi Case)



  • Eh bien non justement, je n'ai installé aucun script en particulier. Après, ce qui est bizarre, c'est que le recalbox.conf affiche 6 fois la ligne "system.power.switch=PIN356ONOFFRESET" tandis que toutes les autres ont disparu. Est-ce qu'il pourrait y avoir un lien ?


  • Staff
    Moderator
    Team



  • @acris C'est le boîtier superpi case que j'utilise, non le gpi. J'utilise Recalbox 6.0.


  • Staff
    Moderator
    Team

    @mrb
    Arf la chaleur me rend bigleuse.
    Effectivement superpi case.



  • Re.
    J'avais eu le même souci sur une première install de Recalbox (les x lignes dans le fichier de conf Recalbox).
    J'avais mis ça sur le dos de l'installation du script de Retroflag car ça s'était produit suite à celle-ci.
    J'avais beau virer les anciennes lignes, celles en doublons, ça les dupliquait systématiquement, et seules certaines actions du boitier fonctionnaient (genre uniquement le bouton reset).

    Du coup, j'étais reparti de zero, (en ayant préalablement sauvegardé mon dossier de roms / themes).
    Après cette réinstallation complète, j'avais ensuite copié uniquement mes roms et thèmes, (et aucun autre dossier, laissant volontairement de côté les dossiers de conf) et ça avait solutionné le problème.



  • @mrb J'ai aussi 6 fois cette ligne et j'avais aussi ces problèmes au début. Mon recalbox.conf en témoigne encore :
    0_1561741474651_Capture d’écran 2019-06-28 à 19.00.03.png
    J'avoue que j'ai bidouillé ma carte microSD dans tous les sens, avec un thème personnalisé des sous-dossiers dans les roms arcades, des textures HD pour N64, etc, etc. J'ai aussi changé mon alimentation pour une Aukru. Je ne sais pas ce que j'ai fait en réalité, mais un jour ça a marché.
    Ça ne t'aide pas beaucoup, mais je n'ai pas fait de réinstallation complète, donc courage, ça va peut-être fonctionner.
    Pour info j'avais modifié le recalbox.conf par navigateur et aussi par éditeur de texte.



  • Bonjour,
    Je ne peux pas trop vous aider pour le boîtier SuperPI, mais il faut savoir que le bug des 6 lignes identiques, une fois que l'une d'entre elles a été décommentée, est présent, au moins chez moi, depuis plusieurs versions de Recalbox, au moins à partir de la version 4.
    Il est sans conséquence sur le fonctionnement des boutons Power et Reset. Étant sous linux, je supprime les lignes en trop avec un éditeur de text mais c'est seulement pour une question de lisibilité. Que la même ligne soit présente une fois ou 6 fois ne change rien, ça marche.



  • oui il semble que ce bug n'ait jamais été enitèrement corrigé, même si il semble se produire beaucoup plus rarement qu'avant... je ne peux que vous encourager à noter précisément TOUT le cheminement qui vous amène à le reproduire si jamais il apparait encore



  • @voljega, de mémoire : une clean install, boot, config du stockage sur Anyexternal, reboot, passage de Recalbox en français, reboot, décommentage de la ligne system.power.switch=PIN356ONOFFRESET par le web manager, reboot et la ligne est là 6 fois.
    Et j'oubliai, association des manettes (PS3) après le premier boot et après le reboot qui suit le changement de support de stockage.

    @mrb je crois qu'il y a un petit interrupteur à manœuvrer dans le boîtier pour activer le Safe Shutdown, es tu sûr qu'il est bien en place ?



  • @loak Oui, l'interrupteur est bien en place.



Want to support us ?

Join us on :

254
Online

49303
Users

17609
Topics

132765
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.