Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Kodi crashes after library scan



  • Hi,

    I've installed latest recalbox to my odroid Xu4.
    Works quite fine on emulation side, but my main suage is media center.
    After a library scan of musics or movies finished, kodi crashes when trying to go back to previous screen. And all other tries to load Kodi will fail (I see splash screen, then back to EmulatorStation).
    So I have to remove .kodi/userdata folder to get it working back, and scan again to get it crashing !

    I tried to enable some debug logs, but don't see anything relavant. Please take a look on them, maybe you will have a better idea : https://pastebin.com/CGdc5tmT

    Whatever I trying to parse result is the same, or whatever support is (network, external HDD).

    If someone has any idea to help me investigating this issue, I'll be glad to hear them ;)

    Alex.



  • Hi I have some new with this library scan issue.
    I talked of this issue on Kodi official forum : https://forum.kodi.tv/showthread.php?tid=343694&pid=2854789

    I found that the crash comes from a kind of corrupted database.
    But this same database works on another system : https://uploadfiles.io/r8gjq3dl

    I'm looking to a distribution/sw version issue.



  • Above database works with 17.6 Kodi on Ubuntu 18 LTS with this version:
    17.6 Debian package version: 2:17.6+dfsg1-1ubuntu1 Media Center Kodi from Debian
    Copyright (C) 2005-2013 Team Kodi from Debian - http://kodi.tv
    *

    Is there someone who can try using embedded RecalBox ?

    @moderators: this issue is probably not related to Kodi, but with distribution. Please move this thread as desired.



  • Hi all,

    I've made a trial of this database on my x86_64 laptop, and database works.
    Is there something wrong with odroid xu4 database parsing ? or lib version ?

    Please someone can give some tips for investigating this issue ?

    BR,
    Alex.



  • Hi,

    No news since almost 20 days.
    Is there anybody that can help me investigating this issue ?
    Should I need to recompile kodi with debug symbols ?

    Any help would be greatly appreciated !

    Alex.



  • I get an "Unrecognised instruction" in libcrypto:
    disInstr(arm): unhandled instruction: 0xEC510F1E
    cond=14(0xE) 27:20=197(0xC5) 4:4=1 3:0=14(0xE)
    ==3424== valgrind: Unrecognised instruction at address 0x7d37088.
    ==3424== at 0x7D37088: _armv7_tick (in /usr/lib/libcrypto.so.1.0.0)

    Probably called by kodi when accessing a pair of strings :
    ==3424== Process terminating with default action of signal 11 (SIGSEGV)
    ==3424== Access not within mapped region at address 0xBDB883C0
    ==3424== at 0x7330D4: std::pair<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > >::pair<char const (&) [5], char const (&) [66], void>(char const (&) [5], char const (&) [66]) (in /usr/lib/kodi/kodi.bin)

    Here is a full log : https://pastebin.com/hs5r43iF

    I'd like to get more clues to investigate but it seems I don't have symbols:
    *arcueid@Arcueid-VM:~/recalbox-odroidxu4/output/host/arm-buildroot-linux-gnueabihf/sysroot$ objdump -t usr/lib/kodi/kodi.bin

    usr/lib/kodi/kodi.bin: file format elf32-little

    SYMBOL TABLE:
    no symbols*

    However, I'm sure I enabled symbols and do not strip options in menuconfig :
    │ │ [] build packages with debugging symbols
    │ │ gcc debug level (debug level 2) --->
    │ │ [ ] strip target binaries
    │ │ gcc optimization level (optimization level 2) --->*
    The full config file : https://pastebin.com/PrLUUfPL

    Please I really need help on this topic, is there any developper comming here ?
    How should I report a bug on this distribution ?

    Alex.



  • Starting program: /usr/lib/kodi/kodi.bin --standalone -fs
    warning: Unable to find libthread_db matching inferior's thread library, thread debugging will not be available.

    Program received signal SIGILL, Illegal instruction.
    _armv7_tick () at armv4cpuid.S:94
    94 armv4cpuid.S: No such file or directory.
    (gdb) bt
    #0 _armv7_tick () at armv4cpuid.S:94
    #1 0xb3b17478 in OPENSSL_cpuid_setup () at armcap.c:157
    #2 0xb6fdd608 in call_init.part () from /lib/ld-linux-armhf.so.3
    Backtrace stopped: previous frame identical to this frame (corrupt stack?)

    Can't go higher ... no dev can give me some tips ?
    That's a shame ...



  • Last step I tried to remove all modules from Kodi (menuconfig), except alsa but even without mysql modules, I get a segfault on Kodi start.

    Since there is no help here, I'm looking for help on recalbox's github and buildroot.



Want to support us ?

Join us on :

212
Online

48504
Users

17585
Topics

132501
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.