Recalbox 7.0

Problème de Netplay sur la RC-3



  • Je rencontre un problème avec le Netplay de la RC-3, qui était absent sur mon ancienne version 18.07.03

    Donc j'ai l'habitude de jouer le soir avec un pote, principalement sur les roms Neo Geo (qui ne lagguent pas).
    Moi et cet ami avons chacun fait l'install de la RC-3, et chacvun mis à jours nos romsets FBA (nous les avons récupérées au même endroit, donc ce sont bien les mêmes roms).

    Sur l'ancienne version, je pouvais rejoindre une partie qu'il créait, et lui pouvait faire de même.
    Maintenant, sur la RC-3, lorsque j'essaie de rejoindre une partie qu'il a lancée, ça reste sur l'écran noir de chargement de jeu.... et c'est tout. Je ne peux même pas quitter avec Hotkey + X, je suis obligé de redémarrer la Recalbox depuis l'interface sur pc. Si j'attends longtemps (du genre 3 minutes) le jeu se lance en solo avec marqué "failed to initialize Netplay".
    En revanche, si je crée une partie, lui arrive à me rejoindre sans problème.

    J'ai l'impression que le souci vient de chez moi car j'avais de même essayé de rejoindre une partie au hasard dans le lobby, et j'avais rencontré le même problème.
    Je précise que je n'ai évidemment rien touché dans les options réseau ou netplay. J'ai juste changé la région du wifi en wifi=FR dans le .conf de la Recalbox (et mon ami a fait de même).

    Nous jouons tous les deux en Ethernet.
    Je suis sur Raspberry Pi3, et mon ami sur Raspberry Pi3B+.

    Voilà. est-ce que quelqu'un a des idées et pourrait éventuellement nous dépanner ? Merci beaucoup.

    Si cela peut servir, voici une archive de support lorsque je suis en plantage quand je tente de rejoindre une partie (prise au pif dans le lobby netplay) :

    https://file.ac/DcQXg3NIwZ4/



  • Personne ? 😞


  • Developer
    Team
    Global moderator
    Netplay

    salut @elgregou
    peut tu vérifier que tes ports réseau sont bien ouvert !!
    les problèmes que tu décrit son pour moi les symptômes d'un port non ouvert
    tu peut regarder ici pour plus de détail
    tu peut aussi tester avec l'option MITM
    qui permet de ne pas ouvrir de ports mais a des conséquence sur la stabilité !



  • @strodown : Merci, je regarderai ça ce soir à la maison. Je vais lire le tuto. Pour ce qui est de l'ouverture de ports... c'est un peu nouveau pour moi (je suis un peu noob en informatique) mais je vais m'atteler à la tâche. S'il y a un truc que je ne comprends pas, je peux revenir vers toi ?

    Par contre, bizarre quand même. Je n'ai rien touché sur l'ancienne version (la 18.07.03), et pourtant cela fonctionnait sans problème. :S


  • Developer
    Team
    Global moderator
    Netplay

    @elgregou
    bien sur si tu a besoin de support plus rapide vient sur le discord de Recalbox
    ce sera plus direct !


  • CRT Hero

    @elgregou @strodown en tout cas çà ne provient pas de fbalpha, à moins que vous soyez sur un mauvais commit dans recalbox, çà fonctionne nikel avec la version actuelle.


  • Developer
    Team
    Global moderator
    Netplay

    @barbudreadmon personnellement j'ai pas de soucis
    la version de libretro_ fbalpha: 951f2f0d831026455d8eb474e14ad28c2a131eff



  • Non effectivement, ça ne vient certainement pas de FBAlpha. Comme je l'ai dit, on arrive quand même à jouer ensemble, mais seulement si c'est moi qui crée la partie. Donc nous avons bien des roms et core compatibles. (et puis, nous les avons choppées au même endroit ^^ )


  • CRT Hero

    @strodown j'ai fait pas mal de correctifs sur la gestion de la résolution ces jours-ci, vous pouvez bump à la version 4eda6f1cf7e2dfe24d30e60a26cbc933cb8f710e (qui corrige notamment un crash sur sfiii2 quand on active le widescreen hack dans le service menu)


  • Developer
    Team
    Global moderator
    Netplay

    @barbudreadmon merci l'info est transmise



  • Alors je n'ai pas pu tester le netplay ce soir avec mon pote, car il est absent. Par contre j'ai fait quelques tests seul, voici mon compte-rendu.

    J'ai donc ouvert les ports correspondants sur ma Freebox (5535). Je pense avoir fait ça bien, cela m'indique bien "Recalbox" sur le statut de redirection.

    A partir de là, j'ai donc essayé de rejoindre une partie en Netplay au hasard. Ca ne "plante" plus comme avant, par contre ça me marque que je n'ai pas pu rejoindre la partie car l'hôte utilise un core différent. Autant je comprends pour FBA, autant pour la Megadrive où j'ai bien pris soin d'utiliser le même core que l'hôte (Picodrive), j'avoue que je me pose des questions.

    Mais les interrogations ne s'arrêtent pas là. J'ai donc testé la Neo Geo, puisque c'est sur ce support que l'on joue beaucoup avec mon ami.
    Alors je crée un Netplay de Neo Turf Masters... et direct ça me ramène au menu Recalbox. Je ne rentre même pas dans le jeu, ça m'éjecte genre une seconde après que j'ai cliqué sur la rom.
    J'essaie un peu les autres jeux : pareil.
    J'essaie sur les roms arcade FBA (puisque c'est le même core qu'utilise la Neo Geo). Pareil ça ne veut pas.

    A partir de là, les choses s'emballent.
    Je teste une rom arcade FBA en solo, pour voir. Ca se lance... mais ça ne charge pas mes paramètres (comme le shader). Pire encore, je ne peux même pas accéder au menu Retroarch via Hotkey + X.
    Je redémarre donc la Recalbox.
    Je reteste l'émulateur Arcade : ça fonctionne à nouveau, avec chargement de mes paramètres et accès au menu Retroarch.
    Je reteste les roms Neo Geo. Neo Turf ne veut toujours pas se lancer en Netplay. J'essaie une autre rom au pif (je ne sais plus laquelle)... et ça passe ! J'en essaie une autre (Metal Slug 4), ça ne passe pas.
    En désespoir de cause, je reviens sur Neo Turf... et ça passe : j'arrive à créer une partie. J'essaie plusieurs fois de suite : ça marche.

    La suite est un peu chaotique. J'essaie plusieurs roms.
    Mutation Nation ne veut pas passer.
    Last Resort passe. Neo Turf passe une fois sur 2.
    Metal Slug 1, 2, 3, X, passent. Pour le 4 et le 5, rien à faire.

    Bref, je ne pige pas. J'ai l'impression que certaines roms semblent se lancer en netplay plus facilement que d'autres qui me sont "interdites". On pourrait croire que cela vient du romset, mais vu que Neo Turf se lance quand même de temps en temps, je ne pense pas.
    Du coup, est-ce que cela vient de ma connexion, ou autre ?
    Et bizarre, aussi, ce bug qui m'a empêché d'accéder à Retroarch lorsque le netplay a foiré la première fois.

    Bref, si on pouvait m'éclairer...
    J'attendrai bien évidemment de pouvoir jouer avec mon pote pour vous dire si j'arrive à rejoindre une partie qu'il crée. Mais tout ça m'a l'air plutôt hasardeux. 😞

    EDIT : J'ai réussi à faire passer Metal Slug 5.
    Donc mes roms passent bien au bon vouloir. Je pense de plus en plus à une mauvaise connexion venant de chez moi...


  • Developer
    Team
    Global moderator
    Netplay

    @elgregou je t'invite a rejoindre le discord de recalbox et de venir dans le salon netplay on verra plus en détail ton problème et tester sur de bonne base !



  • @strodown Il y a juste un "petit" problème. Lorsque j'essaie de m'inscrire sur Discord, on me dit que ma boite mail est déjà utilisée pour un compte... Impossible, dès lors, d'enregistrer mon compte.

    Il m'est arrivé des choses assez bizarres ces dernières semaines dans ma boite mail, et je suspecte un piratage.
    A partir de là, je ne sais pas comment faire, à moins que les admins du Discord de Recalbox aient une idée pour vérifier mon compte si je fournis les infos le concernant... 😞


  • Developer
    Global moderator
    Team

    @elgregou on ne peut rien faire, discord ne nous appartient pas. Inscrit toi avec une autre adresse email...


  • Global moderator
    Team

    Si un compte existe demande la réinitialisation du mot de passe si celui ci existe tu receveras un mail pour le réinitialiser.



  • Je vais essayer de voir ça, merci.

    Et sinon ces soucis de Netplay, vous en pensez quoi à la volée ? Ca viendrait donc sûrement de ma connexion ?



  • C'est bon, j'ai réussi à résoudre mon problème sur Discord.

    Je viendrai donc là-bas parler de mon problème de Nertplay. Avant ça, il faut juste que je fasse quelques tests avec mon pote dès qu'il aura un soir de libre. 😉


  • Netplay

    @elgregou viens tester sur Discord on est la pour ça car si le probleme vien de vous (set ou autre ) ce sera plus facilement détectable avec nous 😉



  • @lionsquall said in Problème de Netplay sur la RC-3:

    @elgregou viens tester sur Discord on est la pour ça car si le probleme vien de vous (set ou autre ) ce sera plus facilement détectable avec nous 😉

    Oui, je viendrai sans doute en discuter, je me suis inscrit.

    ... Mais ça fait plus d'une semaine que mon pote et moi n'avons pas pu jouer et donc tester le netplay comme il faut. Je ne sais donc pas si mes changements ont amélioré la donne.
    s'il ne vient toujours pas jouer les prochains jours, tant pis je viendrai quand même sur Discord avec le peu d'éléments que j'ai.


  • Netplay

    @elgregou Sans soucis 😉 On est là en cas de besoin.


Log in to reply
 

Want to support us ?

197
Online

79.1k
Users

20.4k
Topics

149.2k
Posts