Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

WiFi is not working on Pi 3B or Pi 3B+

  • Hi,
    I posted the same thread at the german forum two days ago. Since there was no response until today I try to reach more people at the international board. Sorry for double posting and for my bad english.

    Here is my problem:
    I can connect to the Internet via LAN but not via Wi-Fi. I've tried several ways on Pi3 and 3+.
    Here is what I've tested already :

    -SSID without special characters, once with spaces, once without spaces.

    -Password without special characters.

    -Registration via UI (SSID is found, connection is not possible).

    -Log in via Manager (saves the settings, but does not connect).

    -Login over the .conf (saves the attitudes, but does not connect) the semicolons before the SSID and the key removed thereby also, the Country code I put on DE, wifi enabled I set to 1.

    -The SSID on the router is visible, the security key is WPA2, the channel I have set to 8 testwise (normal would be auto, but that's not working too)

    So I hope I did not forget anything.
    After each change of settings, I rebooted the Pi, to no avail.

    I tested all settings with both Pi's (3b and 3b +).
    I do not know what else I can test. I hope you can help me.
    Btw, the WLAN chip works on both Pi's, because with other operating system everything works perfectly.

  • Staff

    @darth_joghurt what is your chip ?

  • Sorry I don't understand your question. Is it possible that I have a different chip on my pi3 than on yours?

  • Staff

    @darth_joghurt sorry I thought you were using an external chip.

    In recalbox.conf, try to set wifi.region=DE

  • No I'm using the internal chip.
    As I described in my opening post I already set the country code to DE.

  • Do you need more information?

  • @darth_joghurt Which version of Recalbox are you using?
    Have you set up the system yourself, or are you using a ready-made downloaded image from the internet?
    Are you sure that the wifi did not connect? In my RPi3, sometimes when turning on the wifi shows as disconnected, but I can access the recalbox manager by the smartphone without any problem, you were only based on the information "disconnected" or tested?

  • @darth_joghurt
    Hi, I had problems by configuring my 2,4 GHz WiFi using channel 12 and 13. At least with Pi3 B and latest Recalbox stable. Seems that Pi (or Recalbox?) does not support these channels.
    Maybe this helps...

    See also here at:
    „WLAN-Autokanal inklusive Kanal 12/13“

  • Hi, I used the latest stable version for the 3B and the Christmas-beta for the 3B+. I've set up the systems by myself, no pre-made images from the internet.
    The connection was testet by trying to get access through the manager.
    I've already changed the wifi channel to 8 but that didn't work too.

  • Staff

    @darth_joghurt is the SSID is found, it means wifi works and your router is seen by Recalbox. Besides, for an unkwnown reason yet it cannot connect, and I bet it's password related, or maybe some security on your router side. Just WPA2 ? Not enterprise preshared key or something like that ?

  • Staff

    Special caracter in wifi key ?

  • No there are no special security settings on my router. My password is only numbers. All devices are allowed to connect to the router.

  • @darth_joghurt what is your wifi key encryption ?

  • @Scavy what do you mean with encryption?

  • Hi guys, I have solved the problem. I thought I had the function "only allow known devices in the Wi-Fi" disabled and set to "allow all devices". Unfortunately, my router has not adopted the setting. After I changed it, everything worked

  • Staff

    @darth_joghurt great :)

  • Banned

    This post is deleted!

Want to support us ?





Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.