Screenscaper issue

For information, Screenscraper website is currently down. All the Screenscraper staff is aware of this issue. Until it's solved, you won't be able to scrap from Recalbox or Skraper. We apologize for the inconvenience.

Pour information, le site internet de Screenscraper est actuellement en panne. Toute l'équipe de Screenscraper est consciente de ce problème. Tant qu'il ne sera pas résolu, vous ne pourrez pas scraper depuis Recalbox ou Skraper. Veuillez nous excuser pour le dérangement.

The Recalbox Team.

Status: Not Connected with RealTek wifi dongle

  • I just set up a new Recalbox instance (v18.07.13 - x86_64) on a Dell OptiPlex 3020.

    I am able to connect the device to a network via an ethernet cable, but when I enter wifi settings and unplug the cable, it goes to "Status: Not Connected | IP Address Not Connected".

    The PC does not have a built-in wifi card, but I have a Realtek 802.11n 00E0302D80F8.

    I have confirmed by ssh'ing into the recalbox device and running, which shows me:

     WARNING: Failure to read usb.ids
    (<type 'exceptions.IOError'>, IOError(2, 'No such file or directory'), <traceback object at 0x7fd8eb250830>)
    usb3             1d6b:0002 09  2.00  480MBit/s 0mA 1IF  (Linux 4.8.11 xhci-hcd xHCI Host Controller 0000:00:14.0) hub
     3-4             1a2c:0023 00  1.10  1.5MBit/s 98mA 2IFs (USB USB Keykoard)
     3-2             0781:5576 00  2.00  480MBit/s 200mA 1IF  (SanDisk Cruzer Facet 4C532005720511102073)
     3-9             046d:c216 00  2.00   12MBit/s 100mA 1IF  (Logitech Logitech Dual Action 943B3916)
     3-10            046d:c216 00  2.00   12MBit/s 100mA 1IF  (Logitech Logitech Dual Action 9441ACA9)
     3-3             0bda:f179 00  2.00  480MBit/s 500mA 1IF  (Realtek 802.11n 00E0302D80F8)

    So, the device is detected.

    Further, I can boot the PC in Windows and connect to the wireless network with the same SSID and key, without issue, and no need to install any special drivers.

    And I know that I can connect to my network with recalbox in general, because I have a Raspberry Pi Recalbox that connects to the network without issue.

    So, why is it not able to connect via wifi? Where can I even start to try to debug this issue?

    I did look here:

    And indeed, RealTek is not listed among the compatible wifi dongles, but I would think that it wouldn't show up in that lsusb list if it was not detected, right?

    Before I order a new wifi dongle, is there a more definitive way to determine why it's not connecting? Is there a log file? Or some other way to test the connection?

    I could not find anything in the forums that deals with this specifically.

  • Developer
    Global moderator

    @jp123 please try with the latest beta, as you won’t be able to upgrade from an older version and it should carry new drivers.

  • @paradadf Thanks for the fast response.

    Before I try the beta, I'm wondering how I can even know what the problem might be. Is there a log file that will tell me why the wifi is not connected?

    It looks like realtek drivers already exist on the current version that I am using:

    # ls /lib/modules/4.8.11/kernel/drivers/net/wireless/realtek
    rtl818x   rtl8xxxu  rtlwifi

    So, what would be different about the beta version?

  • Developer
    Global moderator

    @jp123 dsmeg should tell you if the chip is being properly recognized.
    And just try with the latest beta.

  • @paradadf

    The device appears to be recognized:

    # dmesg | grep -i realtek
    [    8.031045] usbcore: registered new interface driver ums-realtek
    [    8.757683] usb 3-3: Manufacturer: Realtek

    I'm not sure what else I might look for here.

    Where could I find the latest beta?

    I tried modifying this hoping that it would find it on restart, but it did not:

    ## Automatically check for updates at start (0,1)
    # Update type : default to stable

    Is there a .img that I can download or do I need to build it manually from the latest in the repo?

  • @paradadf Another thing, which I doubt is related, but just mentioning that when I make config changes in the recalbox.local web ui, I get this message when I save:
    "An error occurred while saving the configuration."

    I think that might have something to do with permissions on the storage device, although I can edit the config file manually (also from the web ui) no problem, so not sure.

    I am just mentioning in case it might somehow be related to the wifi issue.

  • Developer
    Global moderator

    @jp123 I told you, the new beta is an overhaul so you won’t be able to update to it. Everyone need a clean installation:

  • @paradadf Aha, I searched the forum and could not find that link. Thanks.

  • @paradadf OK, I just tried version "2018.12.24.Christmas.Beta" on a different usb stick and it is the exact same problem. (Also, still getting the error when I try to save a config via the web ui, but at least I can update the config file manually.)

    I am starting to wonder if the issue is simply the driver not being there, because I don't get anything listed for wlan0 when I do ifconfig -a.

    But, it does seem to recognize the dongle, since I get all this when I plug it in:

    [    3.916054] usb 3-6: new high-speed USB device number 5 using xhci_hcd
    [    4.064417] usb 3-6: New USB device found, idVendor=0bda, idProduct=f179
    [    4.064418] usb 3-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [    4.064419] usb 3-6: Product: 802.11n
    [    4.064420] usb 3-6: Manufacturer: Realtek
    [    4.064420] usb 3-6: SerialNumber: 00E0302D80F8

    I am just surprised that there is no notification about anything failing when wifi does not connect. Is there any way at all to get the log message when recalbox tries to connect to the wifi and fails?

  • If you think it will be easier to just get a different wifi dongle, I'd happily order one. I just don't want to do that only to find that the problem is not related to the dongle.

    But, if there is a particular wifi dongle that is known to work well, I'd much rather pay the 10 dollars for it then spend a lot of time trying to diagnose this issue.

Want to support us ?