Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

[Non officiel] Recalbox PC x86_64 avec les drivers Nvidia !!



  • @strodown merci pour l astuce 😉 moi j ai qu un pc je pourais pas testé comme ca 😞


  • Developer
    Team
    Global moderator
    Netplay

    @ragga95 tu peut toujours le faire depuis Recalbox

    • F4 pour eteindre emulationstation
    • alt + f2 puis tu te log
    • une fois la manip faite reboot


  • @strodown pour ma part l'installation est en interne sur hdd



  • @strodown J'ai testé le rc3nvidia avec gamecube neogeo mame et parfait pour le moment plus de soucis d'installation génial
    PS tu penses quoi de l'idée de mettre un petit ssd style 120 ou 240 giga pour l'installation , bon gain en terme de temps démarrage pour la recalbox et ou temps accès jeu?



  • @strodown Salut !
    Alors je viens de tester la dernière version et la N64 ne se lance pas (contrairement à d’autres utilisateurs semble-t’il). Pour le reste ça marche toujours aussi bien !


  • Developer
    Team
    Global moderator
    Netplay

    @recaluserof59 tu aura du mieux c'est sur après tu a pas besoin de autant de place si tu ne stock pas de roms cette partition



  • @strodown
    Pour répondre à votre question initiale, j'ai installé Recalbox sur clé USB
    Merci pour la piste Alsamixer 😉

    Le périphérique de sortie HDMI était en effet en Mute !

    Voici ce que j'ai fait pour temporairement* régler le problème :
    Sélectionner la sortie HDMI dans les paramètres audio de Recalbox
    Ouvrir un session SSH et exécuter les commandes suivantes
    amixer (repérer et remplacer 'IEC958' par votre périphérique audio)
    amixer sset 'IEC958',0 unmuted
    reboot

    *temporairement... car après redémarrage la SORTIE AUDIO de Recalbox indique désormais <>
    Je dois de nouveau sélectionner manuellement la sortie HDMI (cette fois-ci Unmuted)
    Toutefois, le réglage du volume est inopérant côté Recalbox ou Alsamixer
    Ci-dessous la mire Alsamixer sur mon périphérique HDMI NVIDIA :

    lqqk
    x00x
    mqqj
    <S/PDIF>

    Pour info, cette problématique se produit quelle que soit la carte NVIDIA utilisée (3 différentes générations comme évoqué)

    Prochaine piste ? Merci.



  • @strodown ahhh ok merci 🙂 je testerais ca voir si ca bloque une fois pour toute mon choix de sortie sonor 🙂

    Je viens de tester l’émulation de la wiimote , alors ca fonctionne tres bien , seulement ils ont oublier du binder un capteur qui sert dans new super mario a déplacer des objets avec le mouvement de la wiimote , donc je dois rebinder ca a chaque jeux , sinon ça fonctionne tres bien ^^

    Pour la N64 , j'ai activé un filtre avec le core retroarch , c est pas hyper jolie mais ca passe 🙂 l'autre reste sur la gauche , je vais retourner voir dans les fichiers conf au cas ou .. 🙂


  • Developer
    Team
    Global moderator
    Netplay

    @continuum peut tu me donner le retour pour cette commande
    aplay -l
    voici le mien :

     carte 0: PCH [HDA Intel PCH], périphérique 0: CX20641 Analog [CX20641 Analog]
      Sous-périphériques: 0/1
      Sous-périphérique #0: subdevice #0
    carte 1: NVidia [HDA NVidia], périphérique 3: HDMI 0 [HDMI 0]
      Sous-périphériques: 1/1
      Sous-périphérique #0: subdevice #0
    carte 1: NVidia [HDA NVidia], périphérique 7: HDMI 1 [HDMI 1]
      Sous-périphériques: 1/1
      Sous-périphérique #0: subdevice #0
    


  • @strodown
    **** List of PLAYBACK Hardware Devices ****
    card 0: Device [USB Audio Device], device 0: USB Audio [USB Audio]
    Subdevices: 0/1
    Subdevice #0: subdevice #0
    card 1: PCH [HDA Intel PCH], device 0: ALC1150 Analog [ALC1150 Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: PCH [HDA Intel PCH], device 1: ALC1150 Digital [ALC1150 Digital]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 2: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 2: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
    Subdevices: 1/1
    Subdevice #0: subdevice #0


  • Developer
    Team
    Global moderator
    Netplay

    @continuum said in Recalbox PC x86_64 avec les drivers Nvidia !!:

    card 2: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]

    tu a bien sélectionner celle-ci dans recalbox?



  • @continuum Pour le son moi perso je passe par kodi et je sélectionne le bon périphérique, ensuite je retourne sous ES et je sélectionne également le bon périphérique et là ça fonctionne.


  • Developer
    Team
    Global moderator
    Netplay

    @reflectedsoul oui mais ça reste pas au reboot ?



  • @strodown
    Seule la sortie HDMI 0 permet la sortie audio
    Bien que HDMI 1 soit 'Unmuted" rien ne sort



  • @strodown si ça reste. Mais si je ne sélectionne pas le périphérique dans kodi impossible d'avoir du son


  • Developer
    Team
    Global moderator
    Netplay

    @reflectedsoul alors je pense que la sotie est mute dans alsamixer

    pour l'audio par hdmi tester cette manipulation svp :

    • changer la sortie l'audio dans le menu de Recalbox
    • dans un terminal ssh connecter a votre Recalbox:
      taper: alsamixer
      une page semblable apparaît sur votre écran
      https://s24255.pcdn.co/wp-content/uploads/2012/03/Selection_0103.png
    • verifier que votre sortie audio ne soit pas sur mute (MM) mais bien sur on (OO) augmenter le son si besoin !!
    • echap pour quitter alsamixer
    • un petit redémarrage pour confirmer les changements

    chez moi ça fonctionne même après un redémarrage et un changement de sources .



  • @reflectedsoul bienvenu au club c est exactement ce que j'avais vu aussi 🙂 sans Kodi pas de son au 1 er boot et ca depuis la RC1 (pour ma part) ^^ .. ou si tu rajoute un périphérique (comme une manette ps4) tu dois rechanger la config dans recalbox

    • **# ------------ C - Audio ------------ #

    Set the audio device (auto, hdmi, jack)

    audio.device=[2:3] HDA-Intel - HDA NVidia + HDMI 0

    Set system volume (0..100)

    audio.volume=60

    Enable or disable system sounds in ES (0,1)

    audio.bgmusic=1**

    J'ai meme mis volume a 60 dans le .conf , et je crois qu'il n utilise meme pas cette config car par defaut s etait a 0 et ca fonctionnait meme sous recalbox le volume change rien ^^



  • @ragga95 alors moi j'ai toujours eu le problème sur mon pc du salon depuis la v4.1 donc j'avais trouvé depuis un moment la solution en passant par kodi.

    dans mon salon je suis sur une barre de son bose en optique sur une tv samsung et pour le gpu vers la tv en hdmi.

    par contre sur mon pc dans la chambre qui est juste en hdmi sur un écran de pc et avec des enceintes via la prise mini jack aucun problème. Ceci dit je suis sur le gpu intégré et non une carte nvidia.


  • Developer
    Team
    Global moderator
    Netplay

    oui j'ai le même résultat que toi a ce sujet :

    J'ai meme mis volume a 60 et je crois qu'il n utilise meme pas cette config car par defaut s etait a 0 et ca fonctionne ^^

    je retourne les forums a la recherche de réponse a ce sujet !!


  • Developer
    Team
    Global moderator
    Netplay

    @reflectedsoul tu a combien de recalbox ??? 🙂



Want to support us ?

224
Online

77.3k
Users

19.5k
Topics

144.2k
Posts