Recalbox, Synology NAS. SMB and/or NFS, I am desperate, how?



  • Hey guys,

    I tried the tutorial: https://github.com/recalbox/recalbox-os/wiki/Load-your-roms-from-a-network-shared-folder-(EN)

    My recalbox version is: 18.04.20. So I did the turoial => 4.1. I have a raspberry PI 3B

    I used following commands:

    sharenetwork_smb1=ROMS@192.168.111.1:recalbox/roms:username=in10se,password=123456
    sharenetwork_nfs1=ROMS@192.168.111.1:volume1/recalbox/roms:username=in10se,password=123456
    sharenetwork_smb1=ROMS@192.168.111.1:volume1/00-Games/recalbox/roms:username=in10se,password=123456

    and man, many commands more. It doesnt work. I am pretty sure the problem is somewhere in front of the PC or in the configuration of the NAS.

    My Vero4k and my Raspberry Pi3 are using kodi (normal Kodi) and they are accessing and getting the videos, music etc via NFS. There it is easier, because I can navigate to the destination. If I check a movie the filepath is:

    nfs://192.168.111.1/volume1/00-Video/TVShows/.../.../......

    And it is working perfectly. On my Windows PC, if I type \192.168.111.1\00-Games\Recalbox\roms I can acess with the user and password the folder.

    Also if I type \192.168.111.1\recalbox\roms (I copied it to a base shared folder), it accesses it perfectly.

    What am I missing?

    Thanks and greetings



  • @in10se hi
    You're on an unmaintained version of recalbox. Could you make a support archive with all you network setup so that i can check errors ?
    As for me, it works fine using DS216play with the passwordless guest account.



  • @Substring Thanks for your quick response. How Do I do a support archive?



  • @in10se http://recalbox/help then click on the right link, and paste the generated url



  • @Substring

    thx. Its weird. If I run it, it says: connect ENETUNREACH 209.43.40.67:443 - Local (0.0.0.0:0)

    marked with red background



  • @Substring

    now it worked. Here is the file: https://file.ac/yeTsPUhct5c/

    tried it with another sd card too: https://file.ac/QNM25wgudgc/



  • @Substring and here is it with an actual version of recalbox (reinstalled on another SD Card): https://file.ac/o8LTpXR12eU/



  • @in10se it seems to me you were using wifi. If so, look at the changelog here. One says :

    Wifi: options were not saved with nfs cifs or configurations - fixed
    

    So, i'd recommend you switch to the last version, and properly fill the recalbox-boot.conf (the in the last support archive is not set the right way)



  • @Substring
    thanks for your reply. Only in the first I were accidentaly using WiFi. Somehow the Cable was not recognized. As I restarted, I plugged in the cable and the actual one have cable.

    The config is filled with network. I can see it in the cfg when writing the comment.

    But I type above commands for nfs or smb and nothing is showing, no reaction and still my games are not loaded from the nas.

    https://file.ac/HIRBEoHHSb0/

    here is an actual one...

    Would u mind using teamviewer with me? I know, it sounds like a date, but maybe this is easier figured out when u see it live?

    The post 2 hours earlier was already with newest version. I donwloaded it from the HP and installed it. This log is from newest version too.



Want to support us ?

Join us on :

229
Online

31072
Users

15117
Topics

113741
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.