PSX roms won't work after upgrade to 18.07.13



  • Hi all,

    I have been having issues with PSX after upgrading to the latest release. I have not used it for a while, so the issue may not be specific to this release.

    The ROMs I already had in place for PSX don't show up. Playstation 1 doesn't show up as an option, and from the web interface it tells me there are no ROMs available. When I upload one through the web interface, it displays the "ROM deleted!" message and nothing displays.

    Not sure what's going on here, but I have a valid BIOS file, and these were working until I upgraded (was last used very early 2018, or late 2017).

    Any help much appreciated :)

    Regards,

    Tom


  • Moderator
    Moderator
    Team

    @floore Hi, can you make a support archive ?



  • @OyyoDams I tried to put in the URL that I was told to put in by Recalbox, but it won't work. Perhaps if I put it here:

    https://file.ac/yp-LmxVDy4A/

    edit: worked


  • Moderator
    Moderator
    Team

    @floore thank you. I see your roms are on a network storage, so instead of using the web interface, you should use another way to put your PSX roms which are huge on this storage.

    Besides, what is the format (extension) of your PSX roms ?



  • Hi,

    They are .bin files. I didn't have them on network storage initially. I tried to set that up afterwards, but haven't tested it yet. I originally had it set to local, and transferred the files over manually to the SD card. They didn't show up. I then tried it over the network via the web interface and it didn't work either.

    Regards,

    Tom


  • Moderator
    Moderator
    Team



  • @Floore The easiest method is to convert the games to EBOOT-format (.pbp) with program PSX2PSP. You save on space and everything runs smoothly :-)

    PS: Tested on Recalbox (18.07.13)



  • @Quemandoacromo The converter works, and I transfer the file, then try to run it on the PSP in Recalbox, but then when I go to play them it says EBOOT roms are not supported. I then extract the ISO and it tells me it's in MODE2 or something, and tells me it won't play PS1 games...not sure how you're doing that.

    If anyone can help me play the PSX games the way they should be played then that'd be a great help!



  • @floore Wrong! Files converted to .pbp (XYZgame.pbp) goes to folder PSX... will give error if you pass them to the folder PSP



  • @Quemandoacromo Yeah alright no need to be like that. I'll give it a go later, you didn't say to play them under PSX and not PSP



  • @Quemandoacromo You were right. They don't save much space but they do now play. Strange that Recalbox has stopped supporting .bin files for PSX games (or so it seems, could be wrong). I've now got several other issues with games not playing, console icons not showing up and controllers not connecting so going to rebuild onto a new card. Oh well, thanks for the help! :)



  • @floore we stopped supporting bin only files since most people don't understand formats and how .bin/.cue files work, and would complain that soundtracks were missing



Want to support us ?

Join us on :

342
Online

31269
Users

15145
Topics

113912
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.