Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Cant boot recalbox

  • @guiddqd

    The NUC shows the "F2" option on Startup? (If not, bios has enabled fast boot)
    If you can, try with another TV. (maybe resolution problem)
    Try another graphic port (Mini-DP)
    Look for the latest BIOS and update your BIOS.

  • @abunille Thanks for your answers guys.

    I can see the F2 option, fast boot isnt enabled.
    It seems its a nuc related issue, sd cards cant boot on it. Not 100% sure about that though.
    I flashed an usb stick instead and...surprise another error:
    Giving up
    Cannot connect to x server or something.

    Pretty frustrating :(

  • @guiddqd

    Dont give up :)

    My answers above were only for your BIOS problem.
    On an old test nuc5 the problem was solved after bios update.
    Another test NUC BIOS showed up after plug on DP Port and not in HDMI.

  • @abunille no I meant the error message was 'giving up etc.' :p

    Thats when I boot recalbox verbose, should have pointed that out sorry!
    I gave up with the sd card but the usb looks like it will work if I get around that error!

  • @abunille

    Maybe this picture can help identify the problem?

  • @guiddqd it says segmentation fault :/ now that's annoying

  • @substring @guiddqd

    looks like Radeon™ RX Vega M GH graphics on your NUC is only supported on kernel 4.15+ :( Beast of a box though...

  • @gnubit
    Oh...Im sorry but what does that mean?:(
    Anything I can do?

  • @guiddqd

    That`s OK mate. Basically what it means that is that your new hardware namely the GPU (graphics card) is not currently supported as the kernel in Recalbox is version 4.8 (the kernel is the lowest level of software that interfaces with the hardware in your computer). I hear that Recalbox is getting a kernel/OS upgrade soon that will hopefully support your hardware. @Substring may be able to shed some light on this.

  • @gnubit well, we're on 4.15 on the next major system upgrade, so it should work. The beta should open during august

  • @gnubit
    Thanks a lot for your help guys. I guess Ill wait or try batocera in the meantime! Id rather use recalbox though.

  • Hello, I tried again today with the new version. Still the same error...

  • Nobody?
    It feels amazing to buy a sophisticated machine like this and not being able to do simple things like gaming on it...

  • @guiddqd Hello!
    When you say you tried with the new version, did you try with the open beta version? If so, you should post your issues on the open beta topic, only then developers can help. It's impossible for developers to see and respond to all threads, so it takes patience and understanding, but if you really want them to solve your problem, it's much better if you take part in the tests and give your feedback, after all it's not just your problem that needs to be solved, and it's not everyone who has the same problem as yours.

  • I cant find the beta version. I'll try that and give feedback as soon as I can.

Log in to reply

Want to support us ?

Join us on :





Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.