Problème compiler amk_arcade_joystick



  • Bonjour,

    J'ai installé la dernière version de recalbox.
    Pour mon projet (pi dans une atari lynx) j'utilise un écran 3,2 pouces et je souhaite utiliser les ports gpio sur les boutons de la lynx.
    Malheureusement l'écran utilise le même port gpio que ceux utilisé dans mk_arcade_joystick

    J'ai essayé de configurer pour utiliser la configuration 3
    J'ai essayé de configurer manuellement les ports gpio sur le Map=4
    Mais à chaque démarrage recalbox affiche des erreurs.

    J'ai essayé de compiler mk_arcade_joystick maisbjbai cette erreur :
    Your kernel headers for kernel 4.14.33-v7+ cannot be found at
    /lib/modules/4.14.33-v7+/build or /lib/modules/4.14.33-v7+/source.

    Que faire pour arriver à compiler ?

    Merci


  • Team

    il me semble qu'il est possible de configurer les gpio désiré sur la ligne de commande je crois que cela a été intégré dans les dernière version de mkarcade

    If you don't want to use all pins or wants a custom gpio map use:

    sudo modprobe mk_arcade_joystick_rpi map=5 gpio=pin1,pin2,pin3,.....,pin12
    Where pinx is the number of the gpio you want. There are 12 posible gpio with button order: Y-,Y+,X-,X+,start,select,a,b,tr,y,x,tl. Use -1 for unused pins. For example gpio=21,13,26,19,-1,-1,22,24,-1,-1,-1,-1 uses gpios 21,13,26,19 for axis and gpios 22 and 24 for A and B buttons, the rest of buttons are unused.
    

    Ajout du module dans le fichier /etc/module.conf

    snd_bcm2835
    uinput
    usbhid
    mk_arcade_joystick_rpi
    

    création du fichier /etc/modprobe.d/mk_arcade_joystick.conf avec les paramètres suivants :

    #options mk_arcade_joystick_rpi map=1,2
    # gpio with button order: Y-,Y+,X-,X+,start,select,a,b,tr,y,x,tl
    options mk_arcade_joystick_rpi map=5 gpio=2,3,4,14,15,25,5,6,12,19,16,26
    

    cela indique la liste des GPIO a utiliser pour le module. Cela permet de choisir ceux qui restent en fonction du matériel installé.

    Au pire je peux te fournir un module modifié pour ça.


  • Moderator
    Team

    @darksouljedi tu as compilé sur une raspbian à jour ? Recalbox n'est pas en 4.14 mais 4.4 encore



  • @ian57 je suis partant car j ai suivi tes indications mais çà ne fait rien même en désactivant le module dans recalbox.conf



  • @Substring j ai fait un downgrade puis récupéré les headers. Cette fois le répertoire contient des fichiers mais toujours la même erreur lors de la compilation


  • Moderator
    Team

    @darksouljedi mmhhhh ... Le plus simple.serait de le.compiler en partant du code source de recalbox. Tu as un linux sur un pc ?


  • Team

    @darksouljedi ok mais il me faut ta version du pi? Pi1 2 ou 3?



  • @ian57 pi 3


  • Team

    @darksouljedi ok je regarde ça


  • Team

    @darksouljedi https://we.tl/GMdETDSpb1 il faut faire une sauvegarde de ton ancien module et remplacer par celui ci. Ensuite tu configures comme je t'ai décris plus haut
    Par contre pas de HK d'après @Substring , du coup il te faut un bouton supplémentaire pour le combo de sortie je crois (à tester, car je sais plus trop c'est vieux et il faut que je me remette dedans)



  • @ian57 merci je test et je te dis si çà fonctionne 😁



  • @ian57 j ai remplacé le fichier dans recalbox puis j'ai suivi tes instructions mais le nouveau maping n est pas pris en compte.
    J'ai essayé aussi :

    • d utiliser Map=3
    • aussi bien en passant par mk_arcade_joystick.conf ou par recalbox.conf
      Mais chaque fois soit aucun bouton ne fonctionne soit ca fonctionne comme si j'avais défini sur Map=1
      N ayant pas de.linux sous la main j'utilise puty et winscp sous windows

    Quelle partie je fais mal ? J'ai bien envie de réinitialiser tous les fichiers de configuration et de définir dans recalbox.conf

    D'avance merci de votre aide



  • @ian57 j'ai trouvé jsi j'utilise ton fichier et si dans le fichier recalbox.conf j'indique map=4
    j'ai bien sur le gpio 13 la flèche bas et sur 20 start
    as tu le mapping des autres boutons ?

    un tout grand merci


  • Team

    @darksouljedi je sais pas si la config map=4 et les param qui suive sont parsés @Substring ? De souvenir je ne crois pas du coup il vaut mieux bypasser le config via le recalbox.conf par la config du module directement sans /etc/module.conf et /etc/modprobe.d/mk_arcade_joystick.conf comme décrit plus haut.

    C'est toi qui fixe le mapping des boutons c'est plus simple avec l'option map=5


  • Moderator
    Team

    @ian57 je n'en sais rien moi, jamais touché à ça


  • Team

    @substring ah désolé @Substring je pensais à la lecture et le parssage du recalbox.conf pour l'acrivation du module mk_arcade. lors de mes dernoiers tests je crois me souvenir que les options de map ne passaient pas


  • Moderator
    Team

    @ian57 pas exclu que ca marche mieux une fois que la branche hotkey aura été mergee avec master



  • Salut super çà fonctionne j ai trouvé mon erreur j'avais créé le fichier module.conf alors que c est modules.conf

    Encore merci @ian57 et @Substring


  • Moderator
    Team

    WTF les options peuvent etre spécifiées dans le recalbox.conf normalement, pas besoin d'editer le modules.conf


  • Team

    @substring super nouvelles, je me souvenant plus si les options étaient parsées


Log in to reply
 

Want to support us ?

Join us on :

328
Online

28196
Users

14434
Topics

109211
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.