Virtual gamepad/keyboard (still) does not work properly



  • I've tryed a bit virtual gamepad on recalbox 18.03. 30 adn it still - at least to me - gives trouble: in ES it works fine, all Kìkeys are functional, but once i launched a game with it it worked flawlessy only once, exiting and launching other games did not work anymore :,( I've tryed also to reload the web page, turning on and off the phone but nothing. Im on an android Samsung s6. peraphs it is a web program bug?

    Gave a shot also to the virtual keyboard, wit amiberry and VICE emulators and seems to be enough fnctional, but not with all games especially on c64 i was not able to launch "007: diamonds are foerever" game", actually neither with c64 virtual keyboard.

    Anyone had same issues or it is just me?



  • @niculinux i consider any virtualthing as emergency case, nit for erveryday playtime. Now i haven't tried using the vkb inside games



  • @substring said in Virtual gamepad/keyboard (still) does not work properly:

    @niculinux i consider any virtualthing as emergency case, nit for erveryday playtime. Now i haven't tried using the vkb inside games

    me too actually, but it is a great commodity indeed! As soon as i will have some time gonna try againg: maybe it is irrilevant but it may depend also by the browser used? Tested on retal Samsung web browser that come with the phone. Do you advice some browser in particular?

    Edit: i've not try to configure it in the emulation station as real physical ones, gonna try that too asap ! Dont' know if is possible, meanwhile the most updated wiki (2017 currently) tells to use chrome:
    https://github.com/RetroPie/RetroPie-Setup/wiki/Virtual-Gamepad
    i installed it but cannot see "add to home screen" menu entry. Some specific verison is needed ?



  • @niculinux that's in chrome options



  • @substring said in Virtual gamepad/keyboard (still) does not work properly:

    @niculinux that's in chrome options

    sorry, got it it was my oversight! Actually i am not able to define the left trigger, so i left it along the right because touching the left one nothing happens, or better the pad detects the up on the d-pad being pressed so there it is kinda a "dead zone" but at touch the right one responds and even vibrates not sat it. But still it works flawlessy only on emulation station but nope in games. Also tryed samsung iternet browser, chrome for android and firefox but nothing happens .(



  • @niculinux the vgp is already configured, no need to remap it :o



  • @substring tryed in first place out of the box, (see above) but nothing. Gonna try virtual keyboard with dosbox and see what happens next :)

    edit: tryed "commander keen: keen dreams" the keyboard is OK but goin in the calibrate joystick section both virtual and real ones (i got 2 usb plugged in in 2 of 4 ports on my raspberry pi 3) work, pressing, nothing happens so i have to use the virtual keyboard to quit! A real mini usb keyboard i have is ok too instead.

    Edit 2: sorry forgot to mention: actually in keen dreams gamepad works without even calibration, but onli in-game :( But then again i guess it depends from game to game since i tryed some time ago descent and though i was able to complete the calibration procedure, only firing buttons (lasers and missile) worked

    So we're have to wait for next version to see virtual hardware improvement i guess :)



  • Very ending note for today, i promise! Actually the only way the virtual pad works for me is to set as player 1 input in the controller config options screen. Suppose on 2 player game it would work as input player 2 but that'all for today!

    Ive also used bluetooth virtual gamepad app from the play store and both phone and raspberry 3 (im using a mod b) see each other but are not able no enstabilish a connection, because these apps - provided bluetooth or not - nedd a server to be installed on the receiving machine the raspi in my case, but since it is too much for me gonna not even try :(



Want to support us ?

Join us on :

201
Online

28966
Users

14703
Topics

111013
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.