Abe's Oddworld odd under Dosbox



  • I was having this game running years ago under Dos and it was not having screen problems. I tried to install it in the last days on my bartop, in general I want no games on PC. But this horrible stripes make the game unplayable. I was really looking everywhere to find solution, with no success.
    It is a pure dosbox problem. It seems that other had this problem with emulation, but it was told, switching from the 64 bit version to the 32 bit version resolved the problem. It is just in the game itself, the videos run without any failure. This is the first game on dosbox where I will likely give up.
    Ok, there is always the PSX version, but not very beautiful in the Sony resolution.alt text



  • Today, as I have dosbox 0.74 installed under windows XP (always a boot option that I keep) so I also tried to start exactly the same game files for PI3, also with virtual cd drive in d, and here I have no screen problem. So, may be the arm version of 0.74 has the vga driver problem, or even recalbox by itself.
    alt text


  • Themer

    @dragu I do have this issue on some dos games on Recalbox, I would say between 20 and 30 of them



  • @voljega
    Interesting for somebody who has the possibility to test the same under retropie, or Lakka, or .. if the stripes goes away, or stay, would show us the responsability. ;)


  • Team
    Moderator
    Translator

    @dragu

    I'm curious about this test.
    I'm interested too, but it will probably be the same, when i see an over 10 Years old comment on DosBox Page:
    https://www.dosbox.com/comp_list.php?showID=3605&letter=O

    Wish you nevertheless much success



  • The dosbox Pi version is SVN, the working on XP 0.74.
    I also read this, but it was 0.72.



  • @lmerckx
    I am just asking me if it could help to give dispmanx sdl a try ? Could it be a lag in display drivers inside recalbox to provoke this error ?



  • @Dragu Same problem for me. But this game is not playable on my PI2.
    It can be a SDL2/OpenGles problem, but I'm not sure that downgrading to SDL1/dispmanx will be a solution.



  • @lmerckx
    Thanks, I will survive ;)
    Do you know if there was a dosbox version compiled with sdl 1 and from what day or release it was sdl 2 ? If I find an older version (up to march 2017) I can still try. And just personal, if you know, why there are different versions for Pi2 and PI3. Can it be because recalbox is functioning different from debian ? Because a debian version of dosbox dont work together with recalbox.



  • @Dragu The last SDL1 revision of DosBox seems to be on March 2016 (Revision 72d26437).
    I compared the defconfig of Buildroot for RPI2 and 3. Ad far as I remember, the Linux kernel is not the same.



  • It's odd?
    Well, what did you expect, it's called Oddworld for a reason. :D



  • @Bloodsurfer
    But there is enough meat chopping in the game, not really wish for chopped screens.
    Now you have a remake named "New n Tasty" but runs on such machines as Wii U, but CEMU not yet part of recalbox, and sure not under PIx. ;)



  • Honestly, I dont really miss it, after making the same experience again as some years ago. You must rescue your fellow citizen, you can save at every moment. But..., if you dont save at a checkpoint and die, you must resave them again. This "frustrating feature" was taken away in Exodus, because no reason to go back 10 miles in an adventure game just for save.
    So another such brain disease from game designers from the time that close the door for further money income by themselves.
    I now installed "New n Tasty", the remade HD version under windows.


  • Moderator
    Team

    topic mode in english category



Want to support us ?

Join us on :

239
Online

28779
Users

14634
Topics

110627
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.