New FBCP instructions



  • Hi all

    I tried running through the instructions today to get an adafruit 2.8" TFT going.

    I found a lot of detailed instructions but found that some steps i.e. etc/init.d wasn't needed as there was already a script there.

    The FBCP executable was already in /use/bin/

    I ended up making the suggested changes to the boot and recalbox config files.

    Given all this I still couldn't get the screen to work properly.

    I does show the initial recalbox splash image but after that the screen goes white.

    Are the instructions being updated or is someone able to provide me with some guidance?

    Cheers

    Gerard


  • Moderator
    Team

    @bigbear let's try to summon @ian57 ...



  • @bigbear @Substring Yes I need to rewrite the howto, because lots of things are now embedded in Recalbox. Need time to do that

    but briefly :

    1. modify the /boot/config.txt to fit to the resolution of your screen and the right overlay
    2. in recalbox.conf juste activate the fbcp support and restart
    ## fbcp FrameBuffer Copy Program
    ## For small TFT screen on GPIO and SPI
    ## See https://github.com/recalbox/recalbox-os/wiki/Utility---Use-of-fbcp-for-small-TFT-screen-%28EN%29 for details
    ## Needed for Waveshare 3.2" 3.5" TFT screen, 2.8" Adafruit screen
    ## See https://github.com/recalbox/recalbox-os/wiki/TFT-Screen-SPI-Bus-%28EN%29
    ## for support and configuration details needed by /boot/config.txt
    system.fbcp.enabled=1
    

    Hope this helps



  • Hi @ian57 - thanks for getting back to me.

    I modified system.fbcp.enabled=1 as suggested.

    I also made the following changes to recalbox.conf:

    #global.videomode=DMT 87 HDMI
    global.videomode=default
    
    #global.ratio=auto
    global.ratio=4/3
    

    I also added the following to the end of /boot/config.txt:

    dtparam=spi=on
    dtparam=i2c1=on
    dtparam=i2c_arm=on
    #forcing HDMI output at TFT screen resolution to be able to make the FB copy
    #resolution configuration
    hdmi_force_hotplug=1
    hdmi_cvt=320 240 60 1 0 0 0
    hdmi_group=2
    hdmi_mode=87
    # working config for speed
    # 900 Mhz -> 48000000
    # 1Ghz -> 35000000
    #modification of the speed   
    dtoverlay=pitft28-resistive,rotate=90,speed=22000000,fps=60
    

    This pretty much matched what I had done before and I'm getting the same results.

    The new xmas boot vid starts but just at the point where the xmas tree is expected to show the screen goes white and doesn't change.

    I've tried a RetroPie install and it worked so I know that the screen is working ok.

    Do you have any suggestions on what I might try next?

    Cheers

    Gerard



  • Hi @ian57 - I figured out what the problem was.

    It probably helps if I provide a bit more background info. I'm working on a PiGRRL 2.0 kit and didn't want to use RetroPie.

    Part of the kit uses a PiGRRL gamepad which effectively piggy backs on the GPIO pins that the AdaFruit TFT uses.

    In the recalbox.conf file I had set controllers.gpio.enabled=1 assuming that this was needed to allow the PiGRRL gamepad to work properly.

    Changing it back to 0 allowed the screen to work as expected.

    # ------------ D2 - GPIO Controllers ------------ #
    ## GPIO Controllers
    ## enable controllers on GPIO with mk_arcarde_joystick_rpi (0,1)
    controllers.gpio.enabled=0
    

    Now I just need to figure out how to make the Gamepad work.

    Gerard



  • @bigbear thanks for your feedback. Yes some GPIO are use by the screen and the the mk_arcade kernel module. SO if both are activated... the screen driver craches.


Log in to reply
 

Want to support us ?

Join us on :

221
Online

25466
Users

13346
Topics

101123
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.