Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

DVD device is not working



  • Hello,

    I bought an external DVD Device and want to connect it per USB to my recalbox on raspberry pi 3.
    It seems to be regognized (dmesg output):
    [ 1133.157280] scsi host136: usb-storage 1-1.4:1.0
    [ 1134.155843] scsi 136:0:0:0: CD-ROM Optiarc DVD RW AD-7700S 1.B0 PQ: 0 ANSI: 0
    [ 1134.160049] sr 136:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
    [ 1134.160680] sr 136:0:0:0: Attached scsi CD-ROM sr0

    But I cannot access its contents. (I cannot mount it etc.) It everytime tells me that there is no medium inserted (I tried several CDs and DVDs)

    I think there are two possible error causes:

    • the device gets not enough power from the usb ports on raspberry
    • there is no (correct) driver for that DVD drive installed

    How can I check which cause is correct? I tried to connect it to my WIN 7 box and it works (so the device is not broken). I noticed that on windows it "spins up" but on recalbox it does not spin at all. Does this mean that there is not enough power? I think it can also mean that the os is not controlling it properly

    Can anyone help me?



  • @heiner I'm not sure we enabled anything that is DVD related ...



  • @Substring I am also not sure. 🙂
    I was thinking about Kodi and DVD playback...



  • Can anyone shed more light into this? How can I check if the "driver" is missing?



  • @heiner regarding Recalbox itself, no idea to be honnest. This might be easier to check in Buildroot, the Linux From scratch we're based on. But unless you work in IT, it will be pretty difficult



  • I work in IT 😉
    (but not on linux)
    But meanwhile I did some further tests with openELEC and there the DVD device seems to be recognized but the power supply seems to be too low because it lags and the display turns of and on etc.


Log in to reply
 

Want to support us ?

142
Online

79.1k
Users

20.3k
Topics

149.0k
Posts