RPI 3 / Recalbox/ Mayflash Adapter / Gamecube Controller

  • Hello community,

    I have a problem with my RaspberryPi 3 and a Mayflash Gamecube Wii USB Adapter. This one.

    It only works as one Controller. So I can use all Controllers, but Recalbox just add new Buttons and detect every Controller as #0 Mayflash Adapter...
    I found out, that its maybe a problem of my usbhid.conf

    My question is, how to fix this problem? Can I solve it, by just doing this?

    #Mayflash Wii Controller Adapter //is this name important?
    options usbhid quirks=0x0079:0x1843:0x040

    to this file recalbox/fsoverlay/etc/modprobe.d/usbhid.conf via ssh?
    is the quirks line correct? I adapt it from her.

    And her is the link for my support file.

    Thanks for your help and sorry for my poor english.

  • @jeypy as I said in your german post, please make a support archive so that I cab check if the qurik is right 🙂 If yes, i'll add it to Recalbox for later updates

    The line's syntax is correct, the one starting with a # is just a comment, not important at all, just for us to know which quirk is for which device

  • @substring thanks for your quick response, but I have add my supportfile under the link above. Or is it not correct the way I've done?


  • @jeypy Ok, the quirk looks fine to me. In your german post you said that eh quirk worked. Can you make a new support archive with the quirk enabled ?

  • @jeypy Great news : it did recognize the 4 inputs of your mayflash 🙂

  • @Substring was the fix included in Recalbox 4.1 ? otherwise the only thing to do is to add the line in recalbox/fsoverlay/etc/modprobe.d/usbhid.conf so that the Gamecube will be working (still have to configure buttons I guess) ?

  • @jeypy what did you do to make it work even as one controller ? I have the same adapter with only one gamecube controller plugged on it. I could successfully bind the buttons in the recalbox menu. It works now in the menu, I’ve configured it as player #1. But during game (just tried Super Mario World) it is not working. By the way I’ve set the adapter in PC mode (nothing is working in Wii U mode)

  • To let people know :

    I finally got the Gamecube controller working, don't know exactly how. I had to reconfigure the controller a couple of times with the help of another controller (Wii Classic Controller with Wiimote) : sometimes buttons were "skipped" during configuration (I had to use the other controller to navigate in the controller configuration menu) and sometimes the recalbox crashed when the configuration was done.
    I've mapped both hotkey and select to Z button. The hotkey button It is not working in N64 games though, could be related to the fact that there is no 'select' in N64.
    In the end, I could even add another Gamecube controller on the Mayflash adapter. Nothing to be done then to configure that second controller. They are now configured as player #1 and #2 in games. I have not tried yet to use my Wii Classic controller to get 3 players.

    I'm using Recalbox 4.1 with Recalbox 17.12.02.

Want to support us ?