Comment faire "passer" son Rasberry Pi pour un autre périphérique?



  • Bonjour,
    Tout d'abord un énorme bravo pour votre version 4.1, c'est franchement le top de chez top niveau configuration et features ! Je n'ai jamais testé la version unstable donc je découvre tout d'une seule fois...

    Bon voilà, je vous explique mon problème, c'est par rapport à la compatibilité de ma TV et du Raspberry ou peut-être de Recalbox (je n'ai jamais utilisé un autre OS)

    Sur ma TV Philips Full HD, j'y branche ma framboise. Recalbox démarre, sans aucun souçi... Mais voilà, l'image déborde de l'écran, et je pense même qu'il y a une légère déformation dans la TV.

    J'ai déjà évoqué le sujet et trouvé 2 solutions au niveau image in-game mais aucune ne me convient et vous comprendrez pourquoi >
    -Solution 1: Overscan off ( car ça fout en l'air l'alignement des scanlines du moins sur ma tv), Pixel Perfect que je met sur ON.
    -Solution 2: Sur ma TV, j'ai un "mode ordinateur".
    Là du coup l'image est en plein écran sans débordement, c'est très bien, du moins rien que pour ça...
    Seulement, la principe du "mode ordinateur", c'est que l'image est "lockée" concernant par exemple tout ce qui est couleur/contraste/gamma etc (le rendu est très terne et moche du coup), car sur toutes les PC actuels, on peut modifier tout ça sans encombre via les paramètres d'image...
    Ainsi, le but serait d'éviter le conflits de config d'image...

    Alors voilà, mon Raspberry est reconnu comme un PC, et j'aimerais savoir comment faire pour qu'il soit reconnu comme je ne sais pas moi, un autre périphérique qu'un PC (lecteur DVD ou blu-ray, console... peut importe, je cite quelques trucs que je peux modifier sur les sources HDMI de ma tv)

    Y'a-t-il moyen, via une commande dans le boot, une ligne à modifier, ou je ne sais quoi, de pouvoir modifier le signal de sortie du périphérique?

    Sur une autre tv j'ai essayé y'a aucun problème (Une LG qui fait pas de chichis avec tout ça, Pc ou pas c'est pareil)
    Ayant tout essayé, je suis sûr et certain que le problème vienne de la "compréhension" du signal via ma TV qui prend la framboise pour un pc (en même temps... Un peu logique) seulement je ne m'y connais pas des masses en config, en ligne à rajouter etc.

    Mais je suis pas non plus hyper largué, genre utiliser Winscp et tester différentes choses ne me pose aucun souci.

    Merci d'avance, et si je n'ai pas été assez clair n'hésitez pas!



  • Deux choses :

    • il y a t'il dans les réglages quelque part le choix pour un support HDMI complet ou limité ? Full ou limited. Si ca existe et que c'est pas sur full, alors mettre sur full.

    • tout simplement les traitements d'images sont probablement tous désactivés en mode pc. Et comme c'est une Philips, ça devient tout vilain :p

    Pas d'autres idées pour ma part !


  • Themer

    @hokuto_sensei j'ai eu le même problème sur ma télé sony d'avant (pas ave un pi mais un autre truc) et malheureusement y'avait pas de solution.
    ce que j'avais lu qui pouvait marcher :

    • changer de port HDMI, sur certaines télés un des ports HDMI est réservé au PC et donc c'est toujours le mode ordinateur qui est activé dessus, mais si c'est le cas il devrait y avoir une icone à côté
    • ne pas renommer l'entrée 'pc' sur la tv
    • su ma télé sony, le périph était reconnu automatiquement comme un pc car il n'envoyait pas du 720p ou du 1080p, mais une résolution entre les deux que je ne pouvais pas changer


  • Ca va paraitre basique mais on ne sait jamais, parfois on passe à côté de trucs simples :

    • il n'y aurait pas un réglage d'affichage sur la télé, genre zoom1, zoom2, 16/9, auto etc...qui serait sur zoom1 ou autre ?

    Je dis ça parce que j'ai une TV Full HD Philips justement, et que ça fait partie des options disponibles sur chaque entrée Hdmi...



  • @kjbstar :

    Non il n'y a rien de tout ça sur la tv, j'ai fait la configuration de font en comble...

    @voljega

    J'ai tenté de changer de port. Sur la Philips (quand même 750 boules) j'ai la possibilité de mettre le type de périphérique: quand je met "PC" ou "Console" par exemple, ça ne fait qu'ajouter l'option "jeux/tv" dans la configuration d'image. Mais rien de plus...
    Pourtant, le Raspberry pi 3b et Recalbox envoie un signal de 1080p pour Emulation Station, et Passe en 720p pour les jeux, si je suis dans le bon... Après c'est peut-être un problème de fréquence, dans recalboxconfig je lis "74hz" à côté du 1080p (là où on peut changer le type de sortie)... Pourquoi?

    @NeeeeB
    Justement, j'ai oublié de le mentionner ce que tu dis à propos des réglages d'image (mon post étant déjà suffisamment long lol), attendant quelques réponses:
    Effectivement, j'ai toutes ces options pour le format d'image (4/3, super zoom, remplissage auto, écran large etc
    Et une seule rempli l'image parfaitement, ce que je ne comprends pas > le mode "Non proportionnel".
    Ca, je l'ai découvert dès le début. Le problème, c'est qu'avec ce mode de format, une fois que je passe en jeu et donc en 720p... Bah l'image se retrouve recadrée au centre en tout petit.

    Et passer la sortie de retroarch en 1920x1080, même avec mon kit ventilo/dissipateurs, ça va ramer...
    C'est peut-être une piste: est-ce possible via l'éditeur d'augmenter la résolution de sortie en 1080p, mais qu'en réalité Retroarch tournerait en performance d'une 720p?
    Sérieux @NeeeeB, je comprends pas comment tu es parvenu sur ta philips à avoir un rendu qui déborde pas...

    Je vais vous filer le lien de ma tv, peut-être que vous serez aiguillé sur "ce qui cloche" par rapport à ce qu'elle pourrait avoir comme conflit:

    https://www.philips.fr/c-p/46PFL3208K_12/3000-series-televiseur-led-smart-tv-plat-avec-digital-crystal-clear/spécifications

    http://www.lcd-compare.com/televiseur-PHI46PFL3208K-PHILIPS-46PFL3208K.htm

    Ps: ne me parlez pas d'Overscan, ça bousille les scanlines que j'adore (je fais un mix Crt: Hyllian + 2xHQ, testez le rendu c'est quasi parfait)

    "Petite parenthèse HS>>"

    Je suis un mordu d'émulation et j'ai tous les émulateurs possible sur mon pc, j'adore tester tous les rendus. Niveau image, les filtres vidéo qui sont inclus dans les émulateurs sont bien plus beau que les shaders, c'est plus naturel à mes yeux, ou plutôt "adapté".
    Sur snes9x, on peut combiner en bidouillant pour avoir les scanlines bien alignées + un super filtre qui rend le jeu quasi neuf:
    -Mettre en 3xbrz
    -Un shader CRT ou Scanlines
    -Et évidemment, vu qu'on combine un filtre et des scanlines, ça peut créer conflit: pour avoir les scanlines en fonction de la "vraie" résolution de la snes, en comptant que le filtre augmente 3x la résolution d'image: j'ai ajouté une config spéciale en 1600x896 :D )

    Enfin pour moi le meilleur rendu que j'ai en émulateur Kega Fusion et avec scanlines 25% + filtre 2xbr3.4.rpi... Ce qui est bien avec Fusion, c'est d'une qu'on peut ajouter des filtres en .rpi qui sont diablement beaux et efficaces et pas "lourds" pour le pc, que l'option scanlines n'est pas un shader mais un filtre. Donc aucun souci de déformation de ces dernières.
    "Fin de la parenthèse"

    Et un grand merci pour vos réponses et de m'avoir lu. J'espère pouvoir résoudre le problème d'une façon ou d'une autre...


  • Themer

    @hokuto_sensei ah oui le 74Hz c'est bizarre !!!



  • @hokuto_sensei

    Je vais tenter de regarder ce soir chez moi, le souci étant que mon Pi n'est plus branché à ma télé maintenant puisque j'ai construit une borne d'arcade...
    Ceci dit quand il était branché sur la télé, je n'avais effectivement pas de souci de débordement d'image.
    Utilises tu le bon mode Hdmi dans le recalbox.conf ?
    Si tu veux du 16/9 1920*1080 partout il faut configurer comme ça :

    ------------ H - HERE IT IS - GLOBAL EMULATOR CONFIGURATION ------------
    The global value will be used for all emulators, except if the value
    is redefined in the emulator

    Set game resolution for emulators
    select your mode from the command : tvservice -m [MODE]
    CEA 5 HDMI : 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced
    CEA 4 HDMI : 1280x720 @ 60Hz 16:9, clock:74MHz progressive
    use 'default' for using the default resolution
    (string)
    global.videomode=CEA 5 HDMI

    Ensuite remplissage auto sur la télé et ça devrait en toute logique fonctionner...



  • Merci @NeeeeB
    Mais justement, passer la résolution pour tous les émulateurs en 1080p, ça bouffe trop de ressource

    Mais là j'ai ENFIN trouvé une solution mais alors vraiment par hasard, il m'a fallu du temps pour comprendre d'où venait le problème que j'avais avant:

    -J'ai switché d'HDMI, la recalbox a été reconnue, aucun problème pour changer l'image et le mode ordinateur était activé!
    -Du coup, j'ai enlevé le mode "ordinateur" pour tester si ça allait changer quelque chose... Et du coup l'image à débordé comme précedemment...
    -Je remet le mode ordinateur du coup, et bam > l'image redevient à chier, et je ne peux plus modifier les paramètres...

    Du coup, j'ai remis la tv en paramètres d'usine, et j'ai refait la même chose que tout ce qui est cité au dessus sur l'autre prise HDMI, et obtenu le même résultat.

    Solution pour ceux qui ont le problème

    1. Paramètres d'usine
    2. Configuration de la tv, en mettant le mode "ordinateur"
    3. Allumer Recalbox ensuite... Et hop image impeccable et centrée.

    (J'oublie peut-être une étape, je ne sais plus si il faut switcher d'hdmi après la configuration de la tv puis seulement après allumer le raspberry

    Vraiment bizarre comme système, vu que c'est une smart tv, elle assigne directement le périphérique lié à la tv.
    A la base je ne jure que par Samsung, mais là c'est une télé dont j'ai hérité on va dire...

    En tout cas merci pour votre aide, au cas où quelqu'un aurait un problème similaire, je pense qu'il y a toujours une solution. Là c'était un conflit de signal qui s'opérait une fois que j'activais le mode ordinateur quand Recalbox était allumé.



  • @hokuto_sensei

    Euh...global.videomode=CEA 5 HDMI ça ne passe pas les émulateurs en FullHD, ça dit à ta télé de faire un upscale vers du FullHD, donc ça ne bouffe pas de ressources en plus sur le Pi.



  • C'est bon à savoir, j'ai cru lire le contraire (tous les émulateurs tournant à une réso FHD)
    Mais quand bien même, Emulation station démarre en CEA 5, et ça n'aurait pas modifié le problème de débordement.
    Comme je le disais, c'est un problème de reconnaissance de la SmartTV quant à Recalbox qu'il considérait comme un ordinateur, soit on a résolu le problème sans vos idées je pense que je serais resté dans le flou.
    Un grand merci, et on se reverra probablement pour parler d'autres choses quand j'aurai un peu plus de temps et pas toujours que des problèmes rencontrés :)



Want to support us ?

Join us on :

213
Online

31033
Users

15111
Topics

113715
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.