version x64 bug son



  • Bonjour,

    Comme vous pouvez le voir sur la vidéo si dessous, j'ai un problème de son sur la version x64 qui m'oblige à désactiver totalement le son par le raccourcis clavier.
    https://www.youtube.com/watch?v=9TtDR2aa1tQ&feature=youtu.be

    Je précise que j'ai testé sur mes 2 PC ainsi que sur le PC d'un pote, j'ai aussi essayé avec 2 clef USB différentes ainsi qu'une carte SD en téléchargeant l'image à chaque fois et cela fait la même chose dans tout les cas de figure.

    Auriez vous une solution pour mon problème ?



  • @razenco Alors pour info, quand tu changes de carte son, il faut que tu reboot pour que ce soit pris en compte par ES (par contre les émulateurs c'est bon)

    Ton larsen est étonnant, tu peux tenter de réajuster les volumes en te connectant en SSH (ou avec un terminal) puis en tapant TERM=xterm alsamixer, tripoter les volumes et me dire celui qui influe sur le biiiiiiiiiiiiiiiiiiiiiiiiiiiiiiip



  • @Substring , pour le changement de carte son j'ai oublié de préciser que j'ai aussi essayer en rebootant, je ne l'ai juste pas fait dans la vidéo pour ne pas qu'elle dur trop longtemps et montrer le gros du problème.

    Je vais essayer la méthode par SSH et je te tiens au courant ;)



  • @Substring , Alors après test, j'ai beau faire n'importe quel réglages, le biiipppppp est toujours présent et ne diminue ni n'augmente pas du tout :/
    ![text alternatif](0_1507971278726_sound.png url de l'image)
    (Tout est en bas sur la photo mais j'ai aussi essayé et les montant tous et aussi 1 par 1)



  • @razenco appuie sur F6 pour faire la meme chose sur toutes les cartes son



  • @Substring je l'ai fait aussi avec F6, par contre je n'avais pas vu que l'on pouvais aller sur la droite pour avoir d'autre options et au final j'ai bien trouvé d'ou cela vient.

    L'option "<Loopback> Enabled" me fait le biiiiip. Une fois enlevé je n'ai plus le problème :)



  • @razenco excellente trouvaille :) Normalement si tu sauves et reboote, plus de problème. Tu confirmes ?



  • @substring je peux te demander une archive de support stp ? http://recalbox/help et tu me donnes le lien généré, en mp si tu es frileux



  • @Substring , après reboot cela ne le fait que 1 fraction de seconde maintenant au moment du chargement de recalbox puis sa s’arrête . Cela fait donc sursauter mais ne dérange plus.

    Biensur, je t'envoi sa en MP



  • @razenco said in version x64 bug son:

    après reboot cela ne le fait que 1 fraction de seconde maintenant au moment du chargement de recalbox puis sa s’arrête

    oui c'est le temps qu'ALSA lis tes paramètres de volume :) en tout cas ton retour a été d'une très grande utilité, merci :) On va embarquer ca dès qu'on peut. J'ai moyen de faire appel a toi le jour où il faut faire tester le correctif ?



  • @Substring Oui pas de soucis, fait moi signe des qui à besoin :)



  • Bonjour,
    J'ai aussi rencontré le problème de larsen avec recalbox 4.1 (32 et 64 bit) sur un laptop.

    Problème : Le microphone est allumé et donc ça larsen en permanence.

    Solution : éditer le fichier asound.state dans /recalbox/share/system/configs/ et mettre 'Loopback Mixing' en Disabled

     control.8 {
                    iface MIXER
                    name 'Loopback Mixing'
                    value Disabled
    

    Cdlt



  • @al3x52 Super, merci beaucoup pour l'astuce ! on a trop peu de recul encore sur le x86 pour le maitriser.

    j'imagine que le 8 dans control.8 correspond à nu id de carte ?



  • @Substring à mon avis les valeurs du fichier de reglage d'alsamixer (asound.state) sont specifiques au materiel.

    Comme @RazenCo avait trouvé que c’était l'option 'LoopBack' qui posait problème j'ai juste cherché dans le fichier de config.

    Avec la commande 'alsamixer', si je réduis ou mute le 'Internal Mic' ou 'Internal Mic Boost' ça supprime aussi le problème, mais le mieux et encore de mettre 'Loopback' en 'disabled'.

    0_1508406249419_f2c81a50-8c4c-4d75-a4ca-83caba38e09c-image.png

    Je ne sais pas comment est détecté puis reglé le matériel audio dans recalbox, mais il faudrait désactiver le loopback ou 'muter' le microphone interne.

    La distro Batocera n'a pas ce problème car le loopback est disabled par defaut.
    Le fichier 'asound.state' (/media/usb0/var/lib/alsa/) contient aussi le bloc avec 'control.8'.



  • @al3x52 Je vais regarder ca,je sais où est (éventuellement) le problème



  • @substring salut comment connecte t,'on son pc en ssh stp jai ce probleme de bip recurent au demarrage



  • @marco1374 tout est expliqué sur le wiki de recalbox. Tu télécharges putty, tu le lances. Dans la zone adresse ip tu mets recalbpx et zou. Il y a aussi un tuto video sur youtube, sur notre xhaine recalbox.com


Log in to reply
 

Want to support us ?

Join us on :

257
Online

31244
Users

15142
Topics

113892
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.