4.1 XU4 bug intro et contrôleurs



  • Bonsoir,

    Je rencontre actuellement 2 bug plutot genant sur la 4.1 et mon XU4.
    Le premier est au démarage, la vidéo d'intro se lance, jusque la tout va bien mais lorsque le fondu de transition commence j'ai un effet strobo avec des glitches très désagréables.
    Une fois sur le menu de sélection des systèmes plus de problème.

    Le 2eme probleme que je rencontre est plus gênant, impossible d’appairer les contrôleurs sfc30 (j'en ai 4), n64 (1) de 8bitdo et PS4 (2). au depart il m'était même impossible d’appairer les manettes PS3 jusqu’à ce que je bascule sur le driver officiel via l'interface web.
    J'ai essayé avec 2 dongle de marque différente et sur tout les port usb du XU4 mais rien a faire. seul les manettes PS3 et Xbox 360 avec son dongle spécifique fonctionnent.

    Les manettes de PS3 fonctionnant, j'en déduit que ce n'est pas un problème de bluetooth désactivé ou non pris en charge.

    J'ai réinstallé sur 2 carte SD différentes (une de 8 et une de 16Go) et testé avec le stockage interne et externe (je suis en externe en temps normal sur un hdd de 320Go) rien n'y fait.

    J'ai un pi3 que j'ai mis également en 4.1 et je ne rencontre aucun problème sur celui la.

    Egalement mais je ne sais pas si celui si est censé fonctionner sur la 4.1 actuelle, mon mayflash pour controleur dreamcast n'est pas reconnu.

    L'url du script obtenu sur l'interface si besoin : https://file.ac/-8Ti0BKl2Ik/

    Merci a vous pour tous ce que vous faites ! ;)



  • Personne dans les parages qui tourne sous XU4 pour savoir comment ça se passe chez vous ?
    Rien a faire je ne trouve pas de mon coté.



  • @jul-s said in 4.1 XU4 bug intro et contrôleurs:

    Bonsoir,

    Je rencontre actuellement 2 bug plutot genant sur la 4.1 et mon XU4.
    Le premier est au démarage, la vidéo d'intro se lance, jusque la tout va bien mais lorsque le fondu de transition commence j'ai un effet strobo avec des glitches très désagréables.
    Une fois sur le menu de sélection des systèmes plus de problème.

    Oui, difficile de faire mieux sinon couper la video plus tot puisque le fondu ne peut pas exister sur xu4

    Le 2eme probleme que je rencontre est plus gênant, impossible d’appairer les contrôleurs sfc30 (j'en ai 4), n64 (1) de 8bitdo et PS4 (2). au depart il m'était même impossible d’appairer les manettes PS3 jusqu’à ce que je bascule sur le driver officiel via l'interface web.
    J'ai essayé avec 2 dongle de marque différente et sur tout les port usb du XU4 mais rien a faire. seul les manettes PS3 et Xbox 360 avec son dongle spécifique fonctionnent.

    Les manettes de PS3 fonctionnant, j'en déduit que ce n'est pas un problème de bluetooth désactivé ou non pris en charge.

    J'ai réinstallé sur 2 carte SD différentes (une de 8 et une de 16Go) et testé avec le stockage interne et externe (je suis en externe en temps normal sur un hdd de 320Go) rien n'y fait.

    PS4 en bt : c'est mort sur XU4 pour le moment, kernel trop vieux, on ne va pas jouer a récupérer des patchs de versions récentes sur le kernel pour les remettre dans un truc qui date.
    Pour les autre,s par contre tu m'étonnes

    J'ai un pi3 que j'ai mis également en 4.1 et je ne rencontre aucun problème sur celui la.

    Egalement mais je ne sais pas si celui si est censé fonctionner sur la 4.1 actuelle, mon mayflash pour controleur dreamcast n'est pas reconnu.

    Lui, ca reste a voir si on a les quirks pour le faire marcher, je regarde dans ton archive

    L'url du script obtenu sur l'interface si besoin : https://file.ac/-8Ti0BKl2Ik/

    Merci a vous pour tous ce que vous faites ! ;)

    Et merci pour la relance de ton sujet, les demandes de support explosent de partout depuis hier, on fait ce qu'on peut pour répondre à tout le monde :)



  • merci pour la réponse ;) j'imagine que ça ne doit pas être simple pour vous !

    Pour les manettes PS4 pas grave du tout je ne les utilise pas. en revanche ça me gêne plus pour les 8bitdo.

    Surtout que ça marche niquel sur pi3 en 4.1 (sans dongle) et en 4.02 avec mes 2 dongles.
    c'est ceux la pour info :
    Avantree USB Bluetooth 4.0 et celui la : ASUS USB-BT400

    Merci encore, vous êtes au top !



  • @jul-s tu dans le wiki anglais, section controllers, bluetooth, il y a la procédure manuelle si ca déconne. Cela dit, faire oublier les pads connus, rebooter, ca aide aussi parfois



  • Ca marche !!! Merci !!!
    Dans un terminal en ssh sous linux j'ai lancé :
    hcitool scan Il me trouvait bien mon bluetooth mais rien d'autre.
    Ensuite j'ai fait bluetoothctl puis :
    agent on
    default-agent
    power on
    scan on

    et magique ! j'ai pu appairer tout mes contrôleurs depuis l'interface ES sans passer par le terminal. Il semblerai que le scan ne se lance pas lorsque dans ES je lance "associer une manette bluetooth" je ne vois que ça car avec cette manip il a détecté ma TV comme sur mon Pi3 mais au redémarrage de recalbox ma TV n’apparaît plus lors du scan. En tout cas tout mes contrôleurs restent appairé donc c'est l'essentiel !

    Concernant la vidéo d'intro ne m'en voulez pas mais avec le fondu qui déconnait je l'ai retiré.

    Et sinon sans vouloir pousser mémé dans les orties ^^ une piste pour faire reconnaître mon mayflash dreamcast ?

    En tout cas une fois de plus merci ! ;)



  • @jul-s said in 4.1 XU4 bug intro et contrôleurs:

    une piste pour faire reconnaître mon mayflash dreamcast ?

    oui, faut regarder ton archive de support si tu en as fait une (désolé je ne suis pas remonté dans le topic) et @acris la reine des quriks vérifiera :)



  • This post is deleted!


  • J'en ai fait une effectivement dans le premier poste.
    Mais au cas ou je remet celle que je viens de faire a l'instant : archive du support
    Super et merci !



  • je le bascule en résolu même si mon mayflash est toujours dans les choux.
    Si ça peut aider quelqu'un avec des problèmes de bluetooth similaire au mien la solution est plus haut ;)



  • @jul-s said in 4.1 XU4 bug intro et contrôleurs:

    Ca marche !!! Merci !!!
    Dans un terminal en ssh sous linux j'ai lancé :
    hcitool scan Il me trouvait bien mon bluetooth mais rien d'autre.
    Ensuite j'ai fait bluetoothctl puis :
    agent on
    default-agent
    power on
    scan on

    et magique ! j'ai pu appairer tout mes contrôleurs depuis l'interface ES sans passer par le terminal. Il semblerai que le scan ne se lance pas lorsque dans ES je lance "associer une manette bluetooth" je ne vois que ça car avec cette manip il a détecté ma TV comme sur mon Pi3 mais au redémarrage de recalbox ma TV n’apparaît plus lors du scan. En tout cas tout mes contrôleurs restent appairé donc c'est l'essentiel !

    Concernant la vidéo d'intro ne m'en voulez pas mais avec le fondu qui déconnait je l'ai retiré.

    Et sinon sans vouloir pousser mémé dans les orties ^^ une piste pour faire reconnaître mon mayflash dreamcast ?

    En tout cas une fois de plus merci ! ;)

    Bonjour à tous,

    Pour faire avancer les choses j'avais le même soucis. Impossible de détecter mes manettes 8BitDo avec un dongle Asus BT400.
    Les commandes annoncé" ci-dessus on fait le job :), le problème est réglé en motivant via SSH.

    Merci pour tout ce que vous faites même si chaque mise à jour me donner une occasion de plus de me ruiner!



  • @francois-p
    J'ai le même dongle que toi. Mais même avec un autre qui marche pourtant tres bien sur Pi3 j'avais le même problème.
    Tu es François de PCSHM ?



  • @jul-s
    Je ne suis pas le François de PCSHM je crois :p
    la dernière mise à jour m'a fait sauté les 8BitDo j'ai pas eu le courage de les associer une nouvelle fois pour l'instant


Log in to reply
 

Want to support us ?

Join us on :

276
Online

30868
Users

15087
Topics

113599
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.