Latence dans les jeux



  • Hello, Il y a quelque chose de très ennuyeux lorsque je joue sur recalbox. Je trouve que le délai entre l'appuie sur un bouton de manette, et l'action en reaction est bcp trop long. Ca casse completement le jeux, et rends le jeu quasiment injouable. Avez vous aussi ce problème ? J'ai mis une vidéo sur youtube pour illustrer le pb : Pour info, j'ai un Raspi 1 (peutetre il n'y a pas ce problème avec le 2 ?) en mode EXTREM. J'ai l'impression que le problèeme est moins présent sur les jeux NES



  • 😕 le lien passe pas C'est sur youtube /watch?v=Fpe5boektp8



  • Peut-être en overclockant ça réglerai le problème ? Je sais que sur RetroPie en overclock 950mhz j'arrive à faire tourner des jeux ps1 presque parfaitement (avec le rpi 1) et sans aucune latence.



  • Salut. C'est pas ça justement le mode "EXTREM" ? Et puis la j'ai le problème avec les jeux SNES...



  • Bah le mode extrem c'est bien sur l'overclock il me semble donc ça doit être ça ^^ Le seul jeu snes qui me posait problème c'était star fox, mais là je peux pas essayer sur recalbox car je ne suis pas chez moi, et je ne peux pas encore me connecter sur ma wifi avec.


  • Staff
    Developer
    Global moderator
    Team

    Salut, je pense que c'est un problème de dongle bluetooth. J'avais des dongle chinois de mauvaise qualité c'etait exactement pareil. J'ai remarqué que la regle qui s'applique pour les dongle bluetooth c'est de mette au moins 8 euros a l'achat. Pas de dongle a 4 ou 5 euros ca ne passe pas.



  • J'ai payé 17 euro mon dongle Belkin a la Fnac. Et c'est la même latence au clavier filaire. Tu as vu la video ? C'est pareil chez toi ?



  • En tous cas je te confirme que ce n'est pas comme ça chez moi! Utilises-tu un moniteur ou une télé? si tu es sur une télé, certaines ont un retard d'affichage très élevé, vérifie si tu as un mode "jeu" dans les options de ta télé, ce mode désactive tous les traitements d'image (et pour afficher des jeux snes ils sont parfaitement inutiles) et permet de réduire au minimum ce délai. Comme le dit retroboy, le bluetooth peut aussi être responsable, j'ai essayé de me faire une petite config avec 2 manettes bluetooth mais je me suis rendu compte qu'il y avait trop d'input lag (moins que dans ta vidéo cependant) et que pour les jeux d'action c'était limite injouable...je retenterai avec un Pi2 mais pour le 1 j'ai fait une croix sur le bluetooth, sauf pour jouer à des puzzle games ou a des rpg. Une autre piste que tu peux explorer, dans les options de retroarch, tu as une ligne nommé "hard gpu sync", mets la sur ON et mets Hard GPU Sync Frames sur 0, ça te permet de réduire encore l'input lag



  • salut, la distribution est géniale mais il faut avouer que j'ai de la latence également dans les jeux avec une manette xbox 360 officielle et un adaptateur wireless officiel microsoft et rpi2. je suis assez sensible à ça et je vois la différence avec d'autres systèmes (coinops, emulation pc etc ...) il y a til une solution pour y remédier car ça gache un peu la fête. bonne journée


  • Staff
    Developer
    Global moderator
    Team

    Ok c'est vraiment bizzare je n'ai pas du tout de latence au niveau des jeux. Quelqu'un d'autre ?



  • Je rejoins Bazola, comme ca à vu d'oeil je pense que c'est un problème d'input lag du à la télé. Essaye d'activer le mode jeu ou bien essaye sur une autre télé voir ce que ca peut donner



  • J'ai exactement le même problème que matt. N'ayant pas de dongle Bluetooth je me suis orienté vers ma tv. je n'ai pas de mode "Jeux" alors j'ai désactivé les paramètres de traitement d'images (j'avais une options pour les scènes d'actions rapides) et ça va déjà un peu mieux. A mon humble avis recalbox n'a rien a voir la dedans, je vais tester sur mon écran de pc pour voir la différence.



  • Idem chez moi je n'ai aucun soucis avec mon pad x360 sans fil autant sur tv lcd que sur videoproj. Je pense aussi à de l'inputlag dû à la tv.



  • J'abonde dans le sens d'un problème venant de la TV. J'avais le même souci avec ma Snes : gros delay en mode standard, mais impeccable en Mode Jeu. Et c'était la bonne vieille Snes avec manette filaire d'origine, donc ça évacue les hypothèses concernant le bluetooth.



  • Bonjour, je me permets de me caler dans ce topic pour éviter d'en créer un nouveau... Tout d'abord bravo pour votre boulot ! L'instal est claire, l'interface d'emulation station est nickel, de même que le nombre d'émulateur. Ca a du être un sacré boulot ! Mais, et oui il y a un gros mais pour moi B-). J'ai aussi ce problème de latence... Il est léger, mais clairement présent et franchement handicapant en ce qui concerne les shmups. Et c'est justement mon péché mignon... Dans certains jeux, il se ressent peu, mais en testant avec Thunderforce 3 (MD), ou Alzadick (PCE-CD) à vitesse max du vaisseau, on sent clairement l'effet "gelée" dans les mouvements du vaisseau. Pour faire simple, j'ai essayé tout ce qui est présent plus haut, à savoir : - manette filaire (une logitech tout ce qu'il y a de plus simple, sans pad analogique) - sortie sur écran en HDMI (écran d'ordi Samsung 2232BW) et en composite (sur Sony PVM 2730) - tentative de config de Retroarch sur les jeux Super Nintendo (GPU sync) - activation/désactivation du lissage En ce qui concerne l'overclock, je n'ai pas testé. Je n'ai pas de dissipateur thermique pour l'instant. Mais le problème se retrouve sur tous les émulateurs, même la NES alors je ne pense pas que la fréquence du processeur soit en cause B-)... J'ai failli oublié : je suis équipé d'un Raspberry 2 B 1Go . Je l'ai acheté dans ce pack sur Kubii : http://www.kubii.fr/509-kit-demarrage-raspberry-pi2-module-wifi-3272496002074.html Voila, vous savez tout ! En espérant que je ne sois pas le seul maniaque de l'input lag B-)...


  • Staff
    Developer
    Global moderator
    Team

    Salut, Green Alex. Avec le clavier, as tu le même problème. Tu peux tout a fait overclocker ton RPI sans dissipateur, tous les miens (rpi1 et 2) sont overclockés. Tu as bien reglé le mode jeux sur la tv LCD ?



  • Yep, même problème avec le clavier... Et pour l'écran, je fais les tests en ce moment sur mon écran d'ordi (entrée DVI, par un adaptateur HDMI/DVI passif), qui ne dispose pas de mode particulier. Mais le problème se posait aussi en sortie composite sur mon tube cathodique, qui n'a bien sûr aucun traitement d'image numérique B-) ... Et tu l'overclock à traver le fichier config.txt, c'est ça ? Et tu entres quelles valeurs sur les tiens ? Et merci pour la rapidité de la réponse, on peut guère faire mieux !



  • Pour l'overclock, tu peux le faire directement dans les paramètres système d' EmulationStation. Ton probleme ne pourrait pas venir de carte SD ? Ou alors de ta clé wifi  (essaie sans) ? ++



  • Pour l'overclock, je l'ai déjà fait ! A travers le fichier de config.txt. Mais pas de réel différence... Tu peux le faire dans les paramètres d'emulation station ? Jamais vu de tel choix dans les settings... C'est un menu particulier ou celui accessible par entrée/start ? Et la carte, c'est une Sandisk class 10 de 8 Go, je l'ai acheté en pack avec la framboise : http://www.sandisk.fr/products/memory-cards/microsd/ultra-class10-for-android/ Normalement, niveau débit ça devrait suffire... J'avais lu quelque part que quasiment tous les émulateurs basés sur Android avait un très léger input lag, ça ne peut pas être simplement ça ? Même si j'espère que non...



  • Quelques pistes intéressantes : http://libretro.com/forums/showthread.php?t=1605 https://www.reddit.com/r/emulation/comments/2up5s0/why_does_vsync_increase_input_lag_in_emulations/ Je vais essayer deux ou trois choses et je vous tiens au jus !


Log in to reply
 

Want to support us ?

415
Online

81.3k
Users

22.2k
Topics

161.1k
Posts