Bug hdmi to vga crash en boucle



  • Bonjour,

    J'ai un problème pour connecter ma raspberry pi 3 a mon bartop... En effet en hdmi tout fonctionne parfaitement mais lorsque je veux brancher mon écran 17 pouces (1440*900 60hz) En Vga to hdmi l'écran s'allume avec plein de pixels bugé et ensuite redémarre en boucle et fini par s'arrêter...

    J'ai essayé plein de réglages mais rien n'y fait ...
    Voila ma config :

    code block

    uncomment if you get no picture on HDMI for a default "safe" mode

    #hdmi_safe=1

    disable_overscan=1

    uncomment to force a specific HDMI mode (this will force VGA)

    hdmi_group=2
    hdmi_mode=47

    comment to get jack audio

    #hdmi_drive=2

    config_hdmi_boost=0

    force hdmi while the tv can take time before sending the signal on the h$hdmi_force_hotplug=1

    uncomment for composite PAL

    sdtv_mode=2

    uncomment for lirc-rpi

    #dtoverlay=lirc-rpi

    if you plug your tv at the same time as your rpi and that the rpi switch$boot_delay=3

    uncomment if you don't want the rainbow at startup

    disable_splash=1

    Overclock

    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=512

    Si quelqu'un a une solution ce serait super !
    Merci d'avance

    Mustanguy



  • @mustanguy Salut

    Quel est ton HDMI2VGA ? Normalement, il doit questionner tno moniteur pour obtenir son EDID et le renvoyer au pi. Là, si tu as de la bouillie de pixels, j'ai tendance à l'incriminer lui.

    Tu peux en attendant forcer le safe mode pour t'assurer qu'il boote en enlevant le # pour avoir la ligne hdmi_safe=1 et t'assurer que ca marche. Une fois sous recalbox, passe la commande /recalbox/scripts/recalbox-support.sh en envoie-moi l'archive que tu trouveras par réseau dans saves



  • @substring
    Mon hdmi to vga :

    https://www.amazon.fr/dp/B01L3CMIHQ/ref=cm_sw_r_cp_apa_xGtNzbZM9XXTN

    Je vais tester ça au plus vite je te tiens au courant

    Merci beaucoup pour ta réponse rapide !

    Mustanguy



  • @mustanguy Je ne sais pas ce qu'il vaut celui-là. On en suggère un dans le recalstore qui marche très bien, au pire.



  • @substring

    J'ai vu 2-3 commentaires sur la fiche produit qui disait qu'il marchais sur raspberry pi. Si jamais impossible de le faire marcher je prendrais celui du recal store

    Merci du conseil !



  • @mustanguy on va déjà diagnostiquer celui-là ...

    Au fait, l'arc-en-ciel au boot, c'est normal hein ;)



  • @substring

    Voila le rapport : https://www.catupload.com/download/2fb9686190c632c4fed39ee06758ff9c.html

    Par contre avec hdmi_safe : même problème de crash en boucle

    Merci encore

    Mustanguy



  • @mustanguy 2 choses ... sous putty, tu peux me donner le résultat de tvservice -n et me dire si ca a l'air d'avoir le nom de ton moniteur ?

    Ensuite, reboote ... peut etre le dongle hdmi qui n'a pas assé de puissance et tue le pi ? tu peux augmenter la valeur de config_hdmi_boost à 7, voire 11 dans /boot/config.txt ? (si tu ne sais pas comment faire, dis-moi)



  • @substring
    Avec le boost a 11 l'écran s'allume avec les pixels bugé mais dès que jappuie sur un bouton il crash et redemarre

    Voila le tvservice : device_name=CMO CMC_19AW

    Mustanguy



  • @mustanguy tu as testé ton pi avec ce hdmi2vga avec un autre écran ? le nom du moniteur te dit qqc ?



  • @substring je l'ai testé avec une télé meme problème (en adaptant les réglages a l'écran)
    Et le nom de l'écran ne me dit, c'est de la recup je ne m'en suis jamais servi avant



  • @mustanguy ta tv marche-t-elle en HDMI natif? quelle alimentation as-tu mise au pi ?



  • @substring la télé marche nickel en HDMI

    L'alim : 5v 2500mah



  • @mustanguy et la meme tv plante avec le hdmi2vga ?



  • @substring oui même problème sur la télé que sur l'ordi. ..


  • Banned

    Salut,

    Vraiment bizarre ton problème, j'ai un HDMI2VGA de chez eBay à même pas 2€ et aucun soucis.

    C'est un 17" 4/3 ?



  • @genetik57 oui en hdmi pas de soucis ...



  • @mustanguy mmhhhh .... j'ai tendance à incriminer le hdmi2vga ... entre la bouillie de pixels et le plantage, rien de tres normal. L'arc-en-ciel du boot est normal quand tu mets ta tv en hdmi direct ?



  • @substring yes en hdmi c'est impeccable pour tous les écrans. Avec le hdmi2vga il y'a des bug de pixels dès l'arc en ciel

    Le convertisseur fonctionne, j'ai essayé de brancher l'écran a mon ordinateur et ça marche niquel...



  • @mustanguy et ton pc sur l'ecran du bartop ? (j esens que tu vas me dire "non là c'est trop pénible")


Log in to reply
 

Want to support us ?

Join us on :

212
Online

29859
Users

14897
Topics

112173
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.