Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

SZMY-POWER CO.,LTD. DS3 Clone | Connection issues



  • Hi everyone, I'm using 2 clone DS3 controls with PS3 driver set to official in recalbox.conf. I don't have problems with them while using emulation through retroarch, but whenever I try to play a n64 game they randomly disconnect (lights turn off) at emulation start OR stop, and need to be re-paired.

    When they disconnect at emulation stop (so I'm back in ES) I have to re-pair them pressing PS equivalent button and that make both work again, which is very annoying but is something I can live with. The real problem is when they disconnect at emulation start because, despite both being able to re-pair, emulator doesn't recognize them anymore, so I can't stop emulation and go back to ES.

    Recalbox setup:

    • Raspberry Pi 3 no overclock
    • Recalbox Stable 4.0.2 (can't try unstable now due to infrastructure migration).
    • 2 DS3 clone controllers.
    • PS3 "official" driver.
    • USB bluetooth dongle CSR 4.0 (link)

    DMESG output:
    [ 178.398035] usb 1-1.5: new full-speed USB device number 5 using dwc_otg
    [ 178.501045] usb 1-1.5: New USB device found, idVendor=054c, idProduct=0268
    [ 178.501058] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [ 178.501064] usb 1-1.5: Product: PLAYSTATION(R)3 Controller
    [ 178.501071] usb 1-1.5: Manufacturer: SZMY-POWER CO.,LTD.

    Apparently, my controllers are not GASIA/SHANWAN, so I tried all PS3 drivers.

    PS3 driver test:

    • "official": Almost perfect operation except as mentioned above.
    • "shanwan": Controllers are recognized and manage to pair, but is impossible to configure them as no button gets recognized, so in practice they are useless.
    • "gasia": They just don't work.

    Finally, I attach a support file that somebody might find useful.
    "recalbox-support sh" output file

    Sorry for my terrible english! Any help is much appreciated.



  • Update: Tried my controllers on a clean Retropie 4.2 install (I'm not trying to promote anything) and they work perfectly there using "Gasia only" driver, which is strange because in Recalbox the gasia drivers didn't work for me...
    Is there much difference between the gasia drivers of both systems?



  • @pulsar Hi,

    Something is weird : they don't show any disconnection. I see you connected twice both your pads ... Would Wifi intefere with your BT ?



  • Mmm I don't think wifi is the cause of the problem, because the disconnection happens only when opening n64 games.
    Maybe I'm not using the right words. What I see is that when starting any n64 game, the led that indicates the player number in the control turns off, in the same way as when I turn off recalbox.



  • Update: The problem is still there after update to Recalbox 4.1 :(



  • @pulsar I have the same problem, tell us if you know how to fix it please



  • I have the same N64 issue with 17.12.02 using the Pi3 (no overclock) and the internal Bluetooth controller.

    FYI, it took me a while to get my SZMY-POWER clone controllers to work.

    I had the driver initially set to Official and they would pair, but no buttons would work. So reset the controllers and cleared the Bluetooth controllers from Recalbox. I then tried the Bluez driver and again they would pair, but no buttons world work. I then changed the driver back to Official, rebooted my Pi3, turned the controller on, it connected, but no buttons working again. I then connected the controller(s) via usb again, waited 20 seconds, disconnected (like I was pairing them again, but I had not reset them or cleared the Bluetooth controllers from Recalbox) and they are now working over Bluetooth (with a little bit of lag, but still playable ).

    For piece of mind, I created a new SD Card with clean Recalbox 17.12.02, and went through the process again. Same issue. Official would not work initially, neither would any of the other drivers. I had to set to Bluez, pair via usb, change to official, pair again and everything works.



Want to support us ?

184
Online

55769
Users

18212
Topics

137085
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.