Problème de config joystick arcade



  • Salut à tous

    Je suis en train de monter une borne arcade, j'ai branché tous les boutons et joystick comme indiqué. Mais au moment de configurer chaque joueur dans le menu recalbox, j'ai un soucis avec le joueur 1 (le joueur 2 fonctionne nickel).
    Tous les bontons fonctionnent bien, le haut et le bas du joystick aussi. Par contre pour le droite et gauche ça ne marche pas bien :
    La gauche est configuré mais lorsqu'on l'utilise le menu défile constamment à gauche.
    La droite ne fonctionne pas du tout.

    Voilà ce que j'ai fait :

    • j'ai inversé le cablage (J1 -> J2) : même constat toujours le J1 qui ne fonctionne pas (donc ça ne vient pas du joystick)
    • J'ai refait tous les branchements avec une nouvelle nappe ide : même résultat (donc ça ne vient pas de la nappe, ni des branchement)

    Donc dernier recours, ça doit venir soit du raspberry (il s'agit d'un RPI3) soit du soft (recalbox 4.0.1)

    Est-ce que vous avez une idée d'où peut venir mon problème et comment le résoudre (sachant que n'ai pas de 2ème RPI pour tester si ça bien de lui)

    Merci pour votre aide


  • Moderator
    Team

    Bonjour
    il faut mettre à jour vers la derniere version recalbox 4.0.2 stable

    ensuite je pense que tu utilises les gpio ?
    si oui est ce bien activé dans recalbox.conf

    Mais au moment de configurer chaque joueur dans le menu recalbox,
    tu dois respecter le cable et conseille de cette page
    https://github.com/recalbox/recalbox-os/wiki/GPIO-controllers-(FR)

    des questions des questions qui auraient gagné en rapidité si tu avais rempli le forumulaire indiqué dans le post it de cette section....



  • Merci pour ta réponse rapide.

    Mais j'ai pratiquement répondu à tout dans mon post :p

    Puis il y a des réponses qui vont de soit, je pense que rien ne marcherais si je n'avais pas activé le gpio dans le recalbox.conf. Là je n'ai que les 2 directions qui ne marchent pas dans le J1 tout le reste fonctionne nickel.

    En fait je me suis planté sur la version (n'ayant pas la borne sous les yeux) j'ai regardé sur github/release pour connaitre la dernière version stable. mais maintenant que tu parles de la V4.0.2 je pense que je suis sur celle-ci car j'ai fait une mise à jour auto il n'y a pas longtemps.

    Par contre j'ai un truc bizarre qui arrive lorsque je veux paramétrer les commandes du J1, Si je commence par les boutons ils sont bien reconnu, par contre si je commence à paramétrer le joystick, après avoir configurer la gauche, tous les boutons ne sont pas reconnus. Comme si ça faisait planté le gpio.

    A noter aussi, que j'ai utilisé 1 seul GND du gpio pour tous les boutons (en utilisant un pont) et 2 autres pour les joysticks. Je ne pense pas que ça pose problème, mais c'est une différence par rapport au tuto que j'ai suivi.


  • Moderator
    Team

    Bonjour
    l'erreur très courante et de vouloir configurer le joystick sur le mode joystick dans emulationstation alors qu'il faut configurer sur le D-PAD.
    la fonction joystick dans la configuration est uniquement pour les sticks analogiques de manettes psx ou xbox360

    ensuite je ne suis pas une familaire des gpio, peut etre que @ian57 pourra t'aider.



  • Ok c'est quoi la différence mode joystick et D-PAD ?

    Moi j'ai configuré les positions UP, DOWN, LEFT et RIGHT et seulement celle là, c'est pas bon ?


  • Moderator
    Team

    j ai donné la différence.

    si tu as mis sur haut, gauche , droit, bas c est ok



  • Ok merci.

    Donc j'ai tout fait comme il faut mais ça ne fonctionne pas correctement.

    La dernière chose que j'ai pas encore testé c'est de tester un autre connecteur 5 points. Mais après ça je suis complètement démuni...



  • @olorin salut olorin

    Tes joysticks sont neuf ? les as tu déjà utilisé beaucoup lors de tes config ou autres ?
    Je te pose cette question car j'ai pratiquement le même souçis que toi après 4 mois d'utilisation avec mes joystick zippy ....
    Aucun souçi niveau config mais lorsque je suis dans les menus, et que j' appuye trop brusquement sur une des directions du joystick il "bug" et va dans une seule directions très vite , pour paré a ce phénomène je donne un coup inverse et tout redevient normal.
    Je n'ai que ce problème qu'avec le J1 ....mon joystick est devenus vraiment "mou" comparativement au J2 qui n'est pratiquement jamais utilisé.
    Perso j'essayerais d'inversé mon joystick puisque tu as deja changer ton cablage et que le probleme persiste, c'est ptet con mais cela pourrait provenir du joystick non ?



  • @Dimitri-Dewals
    Salut dimitri
    J'ai déjà inversé les 2 joystick et ça le fait toujours sur le joueur 1 donc pour moi ça ne vient pas du joystick.



Want to support us ?

Join us on :

343
Online

29924
Users

14913
Topics

112252
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.