Xin-Mo Dual Arcade lässt sich nicht komplett konfigurieren



  • Hallo,
    ich bin soeben mit meinem Bartop-Arcade Projekt fertig geworden und soweit funktioniert auch alles.
    Allerdings wollte ich dann die Controllerbelegung einrichten und stehe hier vor folgendem Problem:
    Richtungen oben, unten, links, rechts lassen sich problemlos einrichten
    Knöpfe A, B, X, Y lassen sich problemlos einrichten
    Start Knopf lässt sich problemlos einrichten
    Das funktioniert auch alles in Spielen (zumindest beim SNES).
    Aber ab dem Select Knopf geht nichts mehr. Ich kann weder ihn einrichten, noch L1 und R1 oder den Hotkey.

    Ich habe pro Spieler (2 sinds) 1 Joystick, 6 Knöpfe, 1x Start, 1x Select und insgesamt einen Hotkey. Angeschlossen habe ich alles wie hier beschrieben.

    Ich habe schon das halbe Internet abgesucht, aber bisher keine Lösung gefunden.
    Vielleicht könnt ihr mir ja weiter helfen.

    LG hansi



  • @h.hansi122 Hi

    Would you mind translating it to english ? I'm not sure anyone will help you in german with a xarcade ;)



  • @Substring
    Of course. Sorry, I thought I wrote it on the German forum.
    I just finished my bartop-arcade project- everything is working fine so far. However i wanted to install the controls and following problem came up: the directions up, down, left and right as well as buttons A,B,XY work without any problems. Even the start button is fine and they all function in the games (SNES). After pressing the select button though, nothing works. I can't set it up or use the L1, R1 or the hotkey.

    There are 1 joystick, 6 buttons, 1 start key and 1 select key per Player (2) and 1 hotkey in total. I've connected everything as said in this instruction manual.

    I've searched the internet far and wide but haven't found the solution.
    Maybe i'm lucky in this forum and someone here can help me!

    Many thanks!



  • @h.hansi122 i read xarcade instead of xinmo haha

    so, which xinmo do you have ? the 18 pins or the 20 pins one ?



  • @Substring
    the 18 pin version



  • @h.hansi122 ok. So all buttons work until you press select ?



  • @Substring
    When I try to configure the controls within the Emulationstation menu, I can configure the arrow-buttons, abxy and start, but then, when it comes to the select button and the following ones, they are just not recognized. Not on player one, or on player two.
    The outcome is, that i can't use the select button, L1 and R1 aswell as the hotkey.
    When I use a wired Xbox 360 controller, everything works fine.



  • @h.hansi122 Are you sure you followed the wiring schematics ? this rather looks like a hardware problem.

    Other way : can you run evtest and say if it's the same behaviour with your faulty buttons ?



  • I already proofed the wiring two times and couldn't find anything.
    Unfortunately I'm not home til Sunday to run evtest, but I will do this as soon as I am back.

    Many thanks in advance!



  • @Substring
    Now I'm back home and firstly detached and reattached all the wiring, again, following the instruction in the link above.
    Same problem as bevor.

    I'd like tu run evtest, but unfortunately I couldn't find a useful tutorial, how to do this. I think I have to use Putty or something else, but I don't know the commands I have to use.


  • Translator
    Translation Master

    @h-hansi122
    Yes, just use PuTTY. Log in with

    • username: root
    • password: recalboxroot

    Then type cat /proc/bus/input/devices. This shows you a list of all available connected devices.

    This could look like this:

     I: Bus=0011 Vendor=0002 Product=0007 Version=01b1
     N: Name="SynPS/2 Synaptics TouchPad"
     P: Phys=isa0060/serio2/input0
     S: Sysfs=/devices/platform/i8042/serio2/input/input8
     U: Uniq=
     H: Handlers=mouse2 event8
     B: EV=b   B: KEY=420 0 70000 0 0 0 0 0 0 0 0
     B: ABS=11000003 
    

    Take note of X in eventX. In this case its event8 (H)

    Now type the following command:
    evtest /dev/input/event8
    (or whatever event your control is)

    Now you should see an event of every button or axis you press / move in the terminal window.

    I hope it works like this. It's been a while since I did it the last time. Otherwise just google for evtest :)



  • @lackyluuk
    It worked. Great.
    Thank you!

    This are the mapped buttons:
    btn_base - Hotkey
    btn_base3 - select
    btn_base4 - start
    btn_Pinkie - L1
    btn_Top2 - R1
    btn_Thumb2 - A
    btn_ Thumb - B
    btn_Top - X
    btn_Trigger - Y

    The Joystick worked as well.

    This is what I've got.



  • @h.hansi122 when you ran lackyluuk's very first command, how many xin-mo pads showed up ? I'm wondering if the usb quirks is set up. Looks like yes seeing the number of available buttons ...

    When you tried evtest, which player inputs did you try ?



  • @Substring
    2 Xin-mo pads are showed up, event 0 and event 1.

    I tried with the inputs for player one.



  • @h.hansi122 which recalbox version are you running ?



  • @Substring
    4.0.1, the newest one.


  • Translator
    Translation Master

    @h-hansi122 The latest stable version is 4.0.2 :)
    The current unstable is 4.1



  • @lackyluuk
    Your're right, sorry. Checked again, installed version is 4.0.2



  • @h.hansi122 xinmo is supposed to work out of the box, you shouldn't even have to reconfigure it O_o



  • @Substring
    Well, then the problem might be that i did reconfigure it?
    As there seems no solution for the problem, i will try to reinstall Recalbox.



Want to support us ?

Join us on :

236
Online

28962
Users

14702
Topics

111007
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.