[4.1] Slow Game Launch (any game/emulator)



  • My Recalbox was fine a couple of weeks ago. But now when I select a game and launch it, it takes some time in a black screen for the game to start. Before it was super fast to start the game;

    Only that problem, the recalbox itself start, turn off speed is fine, the same as always. The games are playing well no lagg.

    This problem happens when I start the game of any emulator.

    • I´ve already tried to clear my gamelists.xml
    • Tried to delete many emulator games, leaving 5 emulators with a few roms

    Anyone had this problem? I couldnt find an answer anywhere.

    Thank you!



  • @Raphael-Bueno-Hatencia Hi !

    can you go to http://recalbox/help and generate a support archive so that we may check a few things around ?



  • Hi @Substring
    Im trying but like last time someone here asked me to run support script, the help screen the icon keeps rotating, them after some minutes it says "Failed to fetch".

    Going to Share>Saves, I´ve got this zip: https://www.sendspace.com/file/h9e5xn
    Hope it helps. The last time it was generating a zip of 2gb, now all zips are 220mb.

    Thanks =D



  • @Raphael-Bueno-Hatencia I don't know if it has a link but seems like your gamelist.xml has references for many roms you don't have anymore.

    the only tests i could ask you is to manually launch a rom with ES shutdown :

    /etc/init.d/S31emulationstation stop
    python /usr/lib/python2.7/site-packages/configgen/emulatorlauncher.pyc -p1index 0 -p1guid 03000000100800000100000010010000 -p1name "Twin USB Joystick" -p1nbaxes 4 -p1devicepath /dev/input/event2 -p2index 1 -p2guid 03000000100800000100000010010000 -p2name "Twin USB Joystick" -p2nbaxes 4 -p2devicepath /dev/input/event3  -system snes -rom /recalbox/share/roms/snes/Illusion\ of\ Gaia\ \(USA\).smc -emulator default -core default
    

    If this ones starts "fast" then your ES is faulty. If it's slow too, then i'll have to dig further



  • @Substring Yes! I´ve downloaded a image and deleted many many games. Is there an automatic way to clean only game that don´t exist on my list? An keep the ones I have with the scrapping data?

    It worked! Well the screen was already black, but it started the game fast. How to fix this faulty ES?

    Thanks @ Substring!



  • @Raphael-Bueno-Hatencia said in [4.1] Slow Game Launch (any game/emulator):

    @Substring Yes! I´ve downloaded a image and deleted many many games. Is there an automatic way to clean only game that don´t exist on my list? An keep the ones I have with the scrapping data?

    except manually editing the XML, nope

    It worked! Well the screen was already black, but it started the game fast. How to fix this faulty ES?

    could be linked to your messy scraping, but I can't tell for sure. @rockaddicted any idea on this one ?


  • Moderator
    Team
    Moderator
    Translator

    I'd recommend a clean installation instead of using a image from unknown sources! You could make a backup of your roms.



  • @paradadf @ Substring Thank you both!

    I´ll try a clean installation as sugested. But first I´ll clean ALL gamelist, soo the new image don´t get trashed with all useless scrapping.


  • Moderator
    Team
    Moderator
    Translator

    @Raphael-Bueno-Hatencia backup ONLY your roms and bioses. You can easily scrape everything new!



  • And saves !!!



  • I´ve backuped and did a clean install. Strange, it looks even slower to open the games that came with recalbox. I´m updating to 4.1 to see if it gets better.

    Im sure im using an original SD card 64gb, even checked via software.



  • @Substring @paradadf I´ve used the support script to see if something is wrong: https://file.ac/kVSH5Qbbg-I/

    I only updated to 4.1 and changed system language.


  • Moderator
    Team
    Moderator
    Translator

    @Raphael-Bueno-Hatencia you can download 4.1 directly from here:

    https://archive.recalbox.com/updates/v1.0/unstable/

    If after a clean install launching the stock roms is slow, the problem might be with your tv/monitor an the video configuration.



  • @paradadf I downloaded 4.1 img from the link. But as my clean updated img, it is taking more time to startup games them before clean install.

    What video config I need to change? I use a TV Samgun FullHD.

    https://file.ac/ZFPfCfz1xrQ/


  • Moderator
    Team
    Moderator
    Translator

    @Raphael-Bueno-Hatencia I'm on my phone right now so I can't see your file. But there is plenty of info in the forum and the wiki.

    https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN)

    At the bottom of the page, there is info about tvservice commands. Use them to find out your tv prefered resolution to change it in recalbox.conf.

    PS. Your tv image mode might be the problem as well. Try using the GAME mode of your tv (if it exists)!



  • @paradadf I´ve tryed:

    hdmi_group=1
    hdmi_mode=4

    Because of the link I found my TV and the specs. Using hdmi_mode=4 everything should be 720p all the time, including the general emulation(default).

    I can sense a little speed up, but the screen stills goes black and i can see on top of tv saying its now 720p, as it was already them game starts.


  • Moderator
    Team
    Moderator
    Translator

    @Raphael-Bueno-Hatencia what's the output of tvservice wirh CEA?



  • @paradadf said in [4.1] Slow Game Launch (any game/emulator):

    ervice wirh CEA

    I don´t know if understanded. But my tv output is 1080p.

    I did change global videomode to default, so my recalbox is always on 720p and there is no change on resolution. I thought this whould fast things up but no, still slow to startup.


  • Moderator
    Team
    Moderator
    Translator

    @Raphael-Bueno-Hatencia if you read the link I gave you thoroughly you will understand that setting video.globalmode to default isn't the best option (always). It defaults to the tv standard resolution wich might be very high, this the slowdowns!

    So please, give me the output of the command tvservice explained at the bottom of the same page.



  • @paradadf said in [4.1] Slow Game Launch (any game/emulator):

    So please, give me the output of the command tvservice explained at the bottom of the same page

    hmm I thought that by using only 720, that was going to be so CPU intensive. Thank you =D

    tvservice -s

    state 0x12000a [HDMI CEA (4) RGB lim 16:9], 1280x720 @ 60.00Hz, progressive

    tvservice -m CEA

    Group CEA has 14 modes:
    mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive
    mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive
    mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive
    (prefer) mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive
    mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced
    (native) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive
    mode 17: 720x576 @ 50Hz 4:3, clock:27MHz progressive
    mode 18: 720x576 @ 50Hz 16:9, clock:27MHz progressive
    mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz progressive
    mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz interlaced
    mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz progressive
    mode 32: 1920x1080 @ 24Hz 16:9, clock:74MHz progressive
    mode 33: 1920x1080 @ 25Hz 16:9, clock:74MHz progressive
    mode 34: 1920x1080 @ 30Hz 16:9, clock:74MHz progressive



Want to support us ?

Join us on :

287
Online

30983
Users

15105
Topics

113672
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.