Twin Ps2 USB Adapter Problem with PS1 games



  • Hi, i have this adapter with 2 original ps2 controllers: 0_1496502151117_adaptor-product.jpg

    It works fine, all buttons in all emulators, including moonlight playing with another 2 ps3 controllers. Using 4.1 recalbox.

    But I have a problem playing PS1 games, when using this adapter, no command input is detected, many games won´t even pass by the start screen. (I´ve tried games like Marvel vs Capcom, Bloody Roar I -II)

    I can even use hotkey + B to enter retroarch menu and everything is working fine.

    Can someone help me please?


  • Moderator
    Team



  • @acris Thx Acris. I´ve tried using /recalbox/scripts/recalbox-support.sh
    and via manager, but both give a message like "no space left". I have only 40% of the SD card filled. I think that support scrip have a bug, I already talked to Substring in the 4.1 bugs, but no solution yet.

    Back into the controllers problem, i´ve realized even my ps3 controllers inputs won´t work anymore on those games (PS1), but only one worked with ps3 and ps2 controllers, Crash Bash. There is something to do with multitap option or something?



  • @acris Wait! after some tries, it worked via manager! https://file.ac/7lSl4HsOewI/


  • Moderator
    Team

    Hello
    all files are empty
    very strange...



  • @acris I don´t know why but that script never worked on my pi3.
    In the beggining it was creating 4gb files, with the message "no space left", even with a lot of space free.

    I was testing the controllers config at rgui menu, there is Default, Standard and some others options. Whats the difference between these two?
    I´ve managed to make everything working again by changing that, exiting game and entering again. but the crash bash stopped working, but the others works again. Maybe I just need to change these when I need to play.


  • Moderator
    Team

    Hi, in psx emulator you can set your gamepad on normal/analog mod (retoarch menu - quick menu - options). Some games works only in normal mod, other in analog mod and others both.
    Your gamepads have too a physical switch on normal/analog mod, and the mapping in es is not the same in these 2 mods.
    So I'm pretty sure that is an issue betweens these mods gamepads + core. Last time I tried this adapter I had this kind of issue too.
    I let you play with the different mods/options, and give us a feedback.



  • @rockaddicted Yes both my PS2 controllers have that analog button, but the controllers dosen´t work without it.

    I´ve done a little research and discovered that even with original ps1, some games won´t work with multitap ON.

    There is 2 not so pratical solutions:
    1- Let Multitap option always on AUTO. And controllers on Default.
    This will work in most games up to 2 players.
    When playing games with 4 players, change the controllers to Standard.
    (remember to exit game for the changes do effect)

    2- Use configuration per game. But I don´t like to have this ON, because it will create configs for all games you play. Well this is usefull, but things can get messy really fast.

    I wanted to know the difference between controller on standard and default, by the word seem to be the same thing. Or if it is a way to leave it on automatic or something.



Want to support us ?

Join us on :

475
Online

28112
Users

14404
Topics

109038
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.