Serious problems when running some PC Engine CD games

  • Themer

    I'm having serious issues with Ginga Fukei Densetsu - Sapphire (NTSC-J), and Super Daisenryaku (NTSC-J) and they just do not work.

    alt text
    I do not have a head as hard as Bonks

    I found it to be a problem with the ISO file, I checked the CUE files, I downloaded these games on several sites, I opened an issue in github and in the end @acris helped me and sent me the ISO that I had and it's the same as I have and anyway did not work.
    Since she suspects the BIOS now, since all other games work except these two.

    Ginga_Fukei_Densetsu_-_Sapphire_(NTSC-J)_[HCD5080].iso renamed Saphire.iso


    FILE "Sapphire.iso" BINARY
      TRACK 01 AUDIO
        INDEX 01 00:00:00
      TRACK 02 MODE1/2352
        PREGAP 00:03:00
        INDEX 01 00:44:65
      TRACK 03 AUDIO
        PREGAP 00:02:00
        INDEX 01 02:26:14
      TRACK 04 AUDIO
        INDEX 00 06:27:70
        INDEX 01 06:27:73
      TRACK 05 AUDIO
        INDEX 00 10:30:42
        INDEX 01 10:30:45
      TRACK 06 AUDIO
        INDEX 00 14:32:26
        INDEX 01 14:32:29
      TRACK 07 AUDIO
        INDEX 00 18:34:45
        INDEX 01 18:34:48
      TRACK 08 AUDIO
        INDEX 00 22:37:23
        INDEX 01 22:37:26
      TRACK 09 AUDIO
        INDEX 00 24:38:72
        INDEX 01 24:39:00
      TRACK 10 AUDIO
        INDEX 00 26:41:71
        INDEX 01 26:41:74
      TRACK 11 AUDIO
        INDEX 00 28:43:34
        INDEX 01 28:43:37
      TRACK 12 AUDIO
        INDEX 00 29:16:61
        INDEX 01 29:16:64
      TRACK 13 AUDIO
        INDEX 00 29:49:46
        INDEX 01 29:49:49
      TRACK 14 AUDIO
        INDEX 00 30:51:23
        INDEX 01 30:51:26
      TRACK 15 AUDIO
        INDEX 00 32:03:30
        INDEX 01 32:03:33
      TRACK 16 AUDIO
        INDEX 00 33:33:04
        INDEX 01 33:33:07
      TRACK 17 MODE1/2352
        PREGAP 00:03:00
        INDEX 01 36:45:31

    I checked the md5 of the syscard3.pce BIOS file its MD5 is ff1a674273fe3540ccef576376407d1d and is OK. (You can do the test here:

    Even if I changed the BIOS for the ones I downloaded and the games were still not working, I decided to test the 2.0 and 1.0 versions of the BIOS.

    Version 1.0
    BIOS screen
    alt text

    And loading the game appears NOW LOADING IN THE GAME and returns to the ES.

    Version 2.1
    BIOS screen
    alt text

    and loading the game appears this image I believe it is to put the supercard, or something like (I do not understand anything Japanese)
    alt text

    Version 3.0
    Which is the indicated BIOS version displays your BIOS screen
    And loading the game appears NOW NOW LOADING and returns to the ES.

    REFERENCE <-- This had the same problem that I am having being with other games and did not see how it was solved.

    Who can help me, see if these games run on their recalbox and report the following:

    Recalbox Version: (4.0 or 4.1 unstable)
    Hardware: (rpi2, rpi3, odroid or pc)
    Core Emulator:
    MD5 Bios:
    The game to be tested is: Ginga Fukei Densetsu - Sapphire (NTSC-J), do not forget!

    Thank you all and thank you @acris, for the patience once again.

  • Moderator

    Hello @azvarel

    emulator : default ?
    Core : default ?

    you said

    Ginga_Fukei_Densetsu_-Sapphire(NTSC-J)_[HCD5080].iso renamed Saphire.iso

    FILE "Sapphire.iso" BINARY

    Not same name, missing p : Sapphire.iso

    Do you have delete your gamelist.xml ?
    Do you use mode gamelist_only ? If yes, disabled.

    Do you have fresh install on new microsd ?
    directly with recalbox 4.1 unstable image ?

  • Themer

    @acris typing error, while doing the topic

    see the "loading" for 1/2 a second and then goes back to ES

    emulator: defaul
    core: default

    I'm suspecting a problem with the core or the pcenginecd emulator folder.
    Because it does not make sense, I used your bios, your iso and it still did not work.
    Other games that use supercard like Akumajou Dracula - Chi no Rondo, it works, Sylphia also works, but this blessed Sapphire does not work


  • Themer


    Do you have delete your gamelist.xml ?


    Do you use mode gamelist_only ? If yes, disabled.


    Do you have fresh install on new microsd ?

    Last install was from 4.0 beta 5, upgraded to 4.0.1 and then to unstable 4.1

    directly with recalbox 4.1 unstable image ?

    I have not tried with direct image

  • Moderator

    Try with another microsd and download img recalbox
    And transfert only this game and bios.

  • Themer

    @acris I tried with another microsd the img, copied its iso and its bios and it did not work. :(

  • Themer


    I discard BIOS problem because I used several BIOS, such as version 3.0
    A hack version of 3.0 that already opens the game directly, without the need to appear the bios screen, and version 4.1 derp also made by a hack that includes support for extended memory and supports Medanfen, all games work except Ginga Fukei Densetsu - Sapphire (NTSC-J), that I can see the "loading" for 1/2 second and then back to ES.

    A great friend who lives in Japan was able to generate a pro clonecd image and sent me Super Daisenryaku (NTSC-J) and when testing here on the recalbox it worked, then we verified that it is a .iso file problem

    In search of other alternatives with Sapphire.

  • Themer

  • Themer

  • Themer


    To my sadness, it's all ACD (Arcade CD) games that are not working,

    Battlefield '94 in Tokyo Dome [FCCD4001]
    Fire Pro Jyoshi - Dome Chojyo Taisen [HMCD 4008]
    Garou Densetsu II - Aratanaru Tatakai [HCD4060]
    Garou Densetsu Special [HCD4067]
    Ginga Fukei Densetsu Sapphire [HCD5080]
    Janshin Densetsu - Quest of Jongmaster [HECD5016]
    Mad Stalker - Full Metal Force [HECD4009]
    Madou Monogatari I - Honou no Sotsuenji [NAPR-1047]
    Ryuuko no Ken [HCD4061]
    Strider Hiryuu [NAPR-1041]
    Tengai Makyo - Kabuki Itouryodan [HCD5070]
    World Heroes II [HCD4063]

    I'm not sleeping, downloading iso in every possible way, my last attempt was to convert to OGG, WAVE files and edit the .cue and without success.

    I do not even know what else to do.

    The strangest thing is that in the log it appears normal, we loaded the ARCADE CARD

    RetroArch [libretro INFO] :: MDFN_MakeFName: /recalbox/share/bios/syscard3.pce
    RetroArch [libretro INFO] :: Arcade Card Emulation:  Enabled

  • Moderator

    I Have no problem with all theses games, it's work on my raspberry pi 3

    Please post your support file :

  • Themer


    It will not be necessary.

    after a user in the forum of the libretro said that my isos were corrupted, which was not true, I decided to redo the cue files, that for some reason the cue files were with some synchronization problem, then I followed the cue available in and with the isobuster, I managed to let it work.

    Thank you again for your help and for your willingness.


  • @azvarel Pls could you share the cue with me? I'm having same issue.... THX

  • Any, insight on this? I have new cue file and new iso and it's still failing... is it needed any special bios?


  • @azvarel THX SO MUCH. The issue was because of the rewind setting.... AFter disabling it, it worked. I can't believe it.

Log in to reply

Want to support us ?





Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.