x32 and genesis roms dont work



  • I installed a working x32 rom (or it says its ok) and put x32 roms and in the megadrive folder genesis games. However it goes to black and then back to the list when trying to load. Other roms like NES seem to work just fine, just the sega ones dont work. Did anyone get them to work?



  • I tested roms using k fusion on the pc and there the roms are working fine so it's in my raspberry pi 3 somewhere


  • Themer

    it Works very well!
    Make sure you have sega 32x bios and try for the games inside roms\sega32x
    Rom files must have a ".32x / .smd / .bin / .zip" extension



  • I did place them in the roms\sega32x directory and i can see them when refresh the games and i did install the sega32x bios which were 3 files. I just can't start any sega genesis/megadrive games and x32 games.. the screen goes black asif it's loading but then goes back to the gamelist. Is there somewhere a log i can view what the error is?

    They were 32X format so i did change the capital X to a lowercase x as otherwise they would not show up. N64, SNES, NES, colorswan and some other consoles are working just fine though, just the sega ones that are not working. Like i said i tested it on a pc emulator and there the roms work just fine.

    any ideas?


  • Themer

    @kalebam What version of your recalbox?



  • @azvarel I downloaded recalboxOS 4.0.1 and then i when i start it up it asks to update which i also did. So i guess the latest version.

    I did get virtual fighter now running on 32x by just uploading the .zip file instead of .x32. I would imagine this will work for all games but i have not tested it yet. I cannot upload .zip files here recalbox/systems/roms/sega32x/ through my browser so i use the network transfer.

    Maybe it's because i renamed them from X32 to x32 but at least this "fix" seems to work. Will test other games and genesis games later today or tomorrow and report here if that also works. Also going to try to zip and existing x32 game and see if that also works.


  • Staff
    Global moderator
    Team

    You need to upgrade to recalbox 4.0.2



  • @acris Since Recalbox Manager does not allow me to look up the version of Recalbox, or i can't find it, i looked in recalbox but it says i already have 4.0.2 installed.. can the problem be that i renamed .X32 to .x32? It can't read X32 however, or Recalbox Manager v1.1.4.1 can't


  • Themer

    @kalebam

    @azvarel said in Problem when leaving a game and entering another game after upgrade:

    @Nachtgarm look this https://github.com/recalbox/recalbox-os/issues/1196

    but, rockaddicted solved the problem

    @rockaddicted said in Bug Emulateur NES:

    recalbox.conf -> global.videomode=CEA 4 HDMI à remplacer par global.videomode=default

    Le temps d'un fix via une update.



  • @azvarel Replacing it with global.videomode=default i already tried as i seen that before. That makes no difference.

    I did however find how to fix the problem (for x32 at least, did not try megadrive), i can simply place the existing files in a zip file as then they do start up. I don't get whats the difference but it seems to work for all x32 games i tested so far. I would assume this fix works for megadrive/genesis also.



  • I also tested it out with a random megadrive game to use it zipped and that also did the trick.



Want to support us ?

293
Online

80.5k
Users

21.6k
Topics

158.2k
Posts