Recalbox 7.0

[Info][Tuto]Configuration Mupen64plus - black screen + No sound


  • Global moderator
    Team

    Bonjour J'essaie de configurer ma manette snakebyte avec l'émulateur mupen64plus Sous putty : jstest /dev/input/js0 renvoie :

    Joystick (Broadcom Bluetooth Wireless  Joystick                        ) has 6 axes (X, Y, Z, Rz, Hat0X, Hat0Y)
    and 12 buttons (Trigger, ThumbBtn, ThumbBtn2, TopBtn, TopBtn2, PinkieBtn, BaseBtn, BaseBtn2, BaseBtn3, BaseBtn4, BaseBtn5, BaseBtn6).
    

    J'ai édité mon fichier /usr/share/mupen64plus/InputAutoCfg.ini J'ai ajouté mon contrôleur : [Broadcom Bluetooth Wireless Joystick ] provient du nom trouvé par emulationstation et la création du fichier cfg pour retroarch /recalbox/configs/retroarch/inputs

    [Broadcom Bluetooth Wireless  Joystick                        ]
    plugged = True
    plugin = 2
    mouse = False
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    DPad R = hat(0 Right)
    DPad L = hat(0 Left)
    DPad D = hat(0 Down)
    DPad U = hat(0 Up)
    Start = button(9)
    Z Trig = button(7)
    B Button = button(2)
    A Button = button(1)
    C Button R = axis(3+)
    C Button L = axis(3-)
    C Button D = axis(2+)
    C Button U = axis(2-)
    R Trig = button(5)
    L Trig = button(4)
    Mempak switch = button(6)
    Rumblepak switch = 
    X Axis = axis(0-,0+)
    Y Axis = axis(1-,1+)
    

    Lorsque je suis sous Mario Kart 64 J'ai le D-Pad qui ne fonctionne pas, je voudrai savoir si c'est normal car dans le menu du jeu le d-pad fonctionne


  • Global moderator
    Team

    Bonjour J'avais un ecran noir et des bugs audio jeux testés : Mario Kart 64 - Nickel Star Fox 64 - Noir + bug audio -> corrigé Super Mario 64 - Noir + bug audio -> corrigé J'ai résolu mon problème avec cette modification : editer le fichier /recalbox/scripts/emulatorlauncher.sh Remplacer cette ligne

    if [[ "$emulator" == "n64" ]]; then
            /recalbox/scripts/runcommand.sh 3 "SDL_VIDEO_GL_DRIVER=/usr/lib/libGLESv2.so  mupen64plus --corelib /usr/lib/libmupen64plus.so.2.0.0 --gfx /usr/lib/mupen64plus/mupen64plus-video-n64.so --configdir /recalbox/configs/mupen64/ --datadir /recalbox/configs/mupen64/ \"$1\""
    fi
    

    Par

    if [[ "$emulator" == "n64" ]]; then
            /recalbox/scripts/runcommand.sh 2 "SDL_VIDEO_GL_DRIVER=/usr/lib/libGLESv2.so  mupen64plus --corelib /usr/lib/libmupen64plus.so.2.0.0 --gfx /usr/lib/mupen64plus/mupen64plus-video-n64.so --audio /usr/lib/mupen64plus/mupen64plus-audio-omx.so --configdir /recalbox/configs/mupen64/ --datadir /recalbox/configs/mupen64/ \"$1\""
    fi

  • Tester

    Merci pour la modif pour le son Acris. Je vais tester mais pour ma part Super Mario 64 fonctionne très bien sans avoir rien modifié (pas essayé Star Fox).   EDIT: il est possible que le D-pad ne serve pas dans Mario Kart 64, faudrait chercher sur google voir quels boutons sont utilisés dans ce jeu.



  • Je suis désolé mais je ne trouve pas le répertoire <span style="font-family: Courier New;">/recalbox/scripts/emulatorlauncher.sh</span> PS : Je ne suis past très doué  ^^


  • Global moderator
    Team



  • Bonjour, j'ai les jeux n64 qui marche aussi avec le si son mais sans l'image (toute les roms) et je viens de modifier le fichier emulatorlauncher.sh .il y a 3 ligne que je pouvais modifier (d'origine 4/3/4 dans l'ordre) et j'ai vu qu'il fallait mettre à la place des 4 des 2.j'ai donc fait 2/3/2,tjrs Blackscreen,puis sur un autre tuto de changer on y'a le 3,donc 4/2/4 si je dis pas n'importe quoi,et la meme.bref y'a t'il une config présise à connaître que je ne sais pas.je joins mon screen.merci d'avance


  • Global moderator
    Team

    Bonjour ce bug n est plus présent normalement avec la version 3.3.0beta, si tu as rencontré ce bug c est que tu es surement en 3.2.11 Aux membres qui posteront dans ce sujet, merci de mettre la version que vous utilisez


  • Global moderator
    Team

    Bonjour ce bug n est plus présent normalement avec la version 3.3.0beta, si tu as rencontré ce bug c est que tu es surement en 3.2.11 Aux membres qui posteront dans ce sujet, merci de mettre la version que vous utilisez



  • Bonjour, Je viens d'installer mes jeux N64 mais aucun ne fonctionne, quand je lance j'ai juste un écran noir sans rien qui se passe. J'ai la version 3.3.0 bêta.


  • Global moderator
    Team

    Bonjour Aymeric il faut absolument que les roms soient dézippés



  • en effet soit un problème de rom ou de résolution d'écran : https://github.com/recalbox/recalbox-os/wiki/N64-retour-sous-ES-(FR)



  • Les roms étaient bien dézippé, il s'agissait d'un problème de résolution d'écran j'ai essayé de passer en 720*576 (16:9) une catastrophe : son et image saccadé, plus qu'à trouver la bonne résolution !


Log in to reply
 

Want to support us ?

125
Online

79.1k
Users

20.4k
Topics

149.2k
Posts