Crash maj 4.0.2 en 4.1



  • Salut

    J'ai fait la mise à jour 4.0.1 à 4.0.2. Aucun soucis, avec le petit message changelog ("black screen...")
    J'ai voulu passer à la 4.1. J'ai mis à jour le fichier recalbox.conf en unstable et redemarré.
    Au redemarrage petit message pour m'indiquer qu'une maj est dispo. Je lance, le systeme redemarre et au moment ou la mise a jour va se faire, le changelog de la 4.0.2 vient se planter au milieu de l'ecran !
    rien à faire, j'ai du redemarrer, mais la maj ne demarre plus, blocage sur le changelog qui vient toujours...
    Je pense que je suis bon pour une reinstall from scratch... 😢
    non ?

    je suis sur pi3, avec sd 128 et disque-dur 1to en usb et manette 360.

    a+
    Myjosito



  • salut avant de faire les mise a jour vers la 4.1 il faut se remettre en INTERNAL au niveau du stockage en suite tu fais ta MAJ et pour finir tu te remet en Extern. Normalement ca fonctionne. bonne journée



  • @myjosito aurais-tu une clé usb à tout hasard ?



  • @Substring non, juste le DD où se trouvent les roms, etc...



  • @teuhteuh0 tu penses que ce serait ca le pb ? J'ai peut-etre raté l'info dans un wiki.

    Si c'est bien ça la raison du crash il faudrait peut-etre le rajouter en instruction dans le message du blog pour la 4.1, en + de la modif en "unstable". Je pense qu'on doit etre un certain nombre en stockage externe.

    De toutes facons je pense que pour moi, ce sera une reinstall... pas trop le choix.

    merci.



  • @myjosito clé usb ou dd externe, meme probleme : la maj plante avec. Je ne vais pas rentrer dans les détails du pourquoi, mais il faut effectviement repasser en internal pour reussir la maj. Par contre, là, tu ne dois plus avoir grand chose qui marche en usb ...

    on doit publier un fix, j'ai pu en faire un hier soir, il est a validation de l'équipe ce matin, donc on verra

    Je rappelle juste que quand on dit que c'est une branche "unstable" ce n'est pas pour rien 😉 et qu'il faut y aller à ses risques et périls parce que c'est avant tout une chasse aux bugs



  • @Substring OK merci pour ton retour.

    Je te confirme, plus rien ne marche en effet.

    Effectivement, unstable, ça veut dire ce que ça veut dire.
    Pour moi ça faisait plus référence à la version... qu'à la procedure non ! 😉

    En attendant le fix vous devriez l'indiquer qqpart, ça evitera à d'autres de se retrouver avec un systeme planté.

    Bon courage et merci.

    M'en vais reinstaller un systeme moi... 🙂



  • Je confirme, j'avais le meme souci que toi a cause de ma clé USB et j'ai pu le resoudre comme ca.



  • Bon, je suis reparti d'une 4.0.1, updaté en 4.0.2. Pas de soucis.
    là j'essaye de mettre à jour en 4.1, et ça m'indique "en cours" depuis 1/2h. Je pense à un gros plantage... J'ai la fibre, d'habitude ça booste. Ou un pb sur le serveur peut-etre. (j'avais essayé de telecharger l'image de la 4.1, mais à 30k/s j'en avais pour 10h 🙂 )
    je précise que je suis toujours en "internal" là.

    Je suis maudit je pense, cette version n'est decidement pas pour moi ! 😄



  • @myjosito il y a énormément d'update en ce moment, on a du tripler/quadrupler les serveurs de download ... Tu es sûr que ce n'est pas l'écran de veille ?

    Sinon la 4.0.2 ne résout pas le pb de clé USB. Par contre, pour les valeureux, je dois pouvoir mettre a dispo une version de test qui corrige le bug



  • @Substring Je te confirme, ça tourne toujours... Bon ben je patiente 🙂
    Tu aurais un miroir pour l'image de la 4.1 sinon stp ?

    sinon j'attends, wait & see 🙂
    merci



  • @myjosito il y a un .img de la 4.1 de dispo seulement. Si ca ne progresse pas, moi je vérifierais manuellement la taille du fichier téléchargé, et s'assurer qu'elle augmente



  • @Substring Je te remercie.
    a+



  • Comme quoi il faut parfois insister... apres 2 echecs la 3e tentative fut la bonne.
    Je vais poster la suite dans le bug report.
    merci.



  • Hello, même problème de plantage après la mise à jour en 4.1
    Résultat, on repart de zéro... Bios, roms, émulateurs, images scrappées, tout le travail réduit a néant...
    Et comme un gros goret pas pensé de sauvegarder sur une usb...
    Good luck !!



  • @HellrazOr si ca s'appelle UNSTABLE, on peut difficilement faire plus clair comme message ...
    Et non rien n'est perdu, tu dois pouvoir tout recuperer soit par reseau soit avec un linux



  • @Substring J'en doute, le cas contraire comment procéder?



  • @HellrazOr vois-tu ton pi sur le reseau ? moi quand j'ai eu ce bug (et ej suis en train de tester sa resolution là) j'avais tjrs acces en SSH à mon pi. C'est ton cas ? On est bien d'accord que tu avais une cle USB en fat32 ? parce que si tu as une clé usb, rien n'est perdu, c'est sur la clé tes données, passur ta SD 😉



  • @Substring Je n'ai rien sauvegarder sur usb, j'ai du reformater ma sd plusieurs fois et repartir de zéro pour une réinstallation propre.



  • @HellrazOr on teste toujours avec une SD qui n'a rien a perdre voyons ...



Want to support us ?

316
Online

81.5k
Users

22.3k
Topics

161.6k
Posts