Atari ST ne fonctionne pas



  • Bonjour
    Je n'arrive pas à émuler l'Atari ST avec le recalbox 4.0 et 4.1.
    (J'émule sans problème la nes, snes, master system, megadrive, megadrive cd, pc engine, pc engine cd, neo geo, ps one , les game boys, n64. )

    Pour l'atari ST j'ai le bon bios
    b2a8570de2e850c5acf81cb80512d9f6 tos.img .
    Dans le répertoir bios : /recalbox/share/bios il est nommé tos, car si j ecris tos.img alors il est reconnu en tos.img.img par l'interface recalbox.

    Mes roms sont non zipé ...

    Une idée ? on est 7 dans le même cas ...


  • Banned

    @chrisis nomme le tos.img ça risque as de marcher sinon.

    Et essaye différents jeux



  • Merci, j'ai fait des essaies.
    J'ai fait apparaitre sous windows l extension.
    Maintenant je vois bien un tos.img.

    J'ai essayé 10 jeux comme Arkanoid en *.st.
    Rien n'a changé. J'ai un écran noir pendant 10 secondes puis un retour vers la liste des jeux.

    J'ai eu le meme symptome avec les jeux pc engine lorsque le cue et bin étaient écrit avec des noms différents (l'un en majuscule l autre en minuscule).

    Les noms doivent avoir une casse particulière ? Il faut masquer le bios ? comment ?

    Merci


  • Banned

    @chrisis masquer le bios ? tu l'as mis où ton bios ? si c'est dans le répertoire des roms c'est pas là qu'il faut le mettre

    non pas de casse particulière à avoir enfin il vaut mieux que ton extension st soit en minuscule mais c'est tout



  • Dans le répertoire bios oui.
    Si mon bios est le bon le problème est peut être au niveau des roms ?

    Par contre on est pas les seuls à avoir le pb :
    https://forum.recalbox.com/topic/2474/résolu-emulateur-atari-st/7

    la dernière réponse de cyril6377 25 Mar 2016, 20:08, d'après sa réponse il est comme moi, écran noir, ...
    ça n'a jamais marché pour lui ... où alors par message privé ...


  • Banned

    @chrisis en même temps il est jamais repassé et perso j'ai environ mille jeux st qui tournent sans problème... as tu essayé plusieurs roms différentes pour le même jeu ?


  • Staff
    Global moderator
    Team

    @chrisis
    aurais tu modifié la résolution video de recalbox ?



  • Bonsoir acris et voljega,

    Non je n'ai pas touché à la résolution de recalbox 4.1.
    La résolution de l'interface est par contre modifiée (l'interface s'affiche en 640 par 400) si j utilise un switch hdmi.

    J'ai testé 2 jeux sur 5 roms différentes ; j'ai pris le bios Tos102.img sur un autre site que j'ai renommé en tos.img et son md5 est b2a8570de2e850c5acf81cb80512d9f6 pour 196608 bytes.

    Je rappelle que je ne suis pas le seul dans mon cas.
    Ce que je peux encore faire :
    Tester recalbox 4.0 ?
    Reinstaller recalbox 4.1
    (ayant commencé avec le mauvais bios et j'ai mis à bmanc le fichier xml) ?

    Merci
    Er bravo pour ce grand projet.


  • Banned

    @chrisis tu as essayé sans le switch HDMI ?


  • Staff
    Global moderator
    Team

    En plus on ne fait pas de support 4.1 pour le moment.... y a trop de modification en cours et ta version est sans doute obsolète...

    Essaie en 4.0.0 final avec un accès par défaut au niveau résolution et dans un 1er temps sans adaptateur directement sur la tv.

    tu as scappé tes roms atari st?



  • Merci

    J'ai récupéré une version 4.0 :

    • que j'ai installé sans dual boot

    • en mettant directement le bon bios

    • sans switch HDMI

    • 1ere version de rick dangerous : je ne passe pas l ecran de présentation

    • 2 eme rom, bingo ça fonctionne

    Merci

    Je vais réinstaller ma 4.1, (j ai une version de toute fin de décembre) et voir si je peux le faire fonctionner ...

    Par contre trop dur de ne pas avoir le bluetooth 😉

    Encore une fois super projet, mais je peux pas vraiment vous aider.
    Mais je ne pourrais pas vous aider, mon job c est de pondre des algo, de faire des specs, de tester des applications. Par contre je ne connais pas le monde open ...



  • hier j'ai testé l'atari ST sur une 4.1, il y a un probleme avec libpcapimage.so.4, un truc dans le genre. On va regarder pour corriger ca

    Et le BT du pi3 marche sur la 4.1 😉



  • Oui Solved pour la 4.0.
    Oui le bluetooth fonctionne sur 4.1; c'est top.

    Avant de résoudre , une question au forum.

    Ok pour les roms Atari ST qui fonctionnent.
    Mais pour la plupart des roms en plusieurs disquettes , je tombe sur un bureau (un écran vert). Je peux visualiser le contenu des disquettes mais par les lancer.

    J'avais envie d'essayer Le manoir de Mortevielle, j'ai essayé 4 roms, et c'est le même résultat. (Et la souris est très lente sur le clavier virtuel, presque inutilisable).

    Pour finir si vous avez besoin de qq pour faire des tests, il se trouve que c'est une partie de mon métier.


  • Banned

    @chrisis ben faut cliquer sur le programme avec la bonne extension pour lancer le jeu.

    Pas de problème chez moi pour la souris virtuelle avec pad 360 bon ça ne remplace clairement pas une vraie souris mais pour l'os st ça fait le taf


  • Staff
    Global moderator
    Team



  • Oui ça fonctionne.
    Je faisais un double click à la windows, là il faut faire le méga double click rapide de la mort qui tue, sinon il n'est pas reconnu ;-).

    Dernière question, ça fonctionne quand les 2 disquettes sont inclus dans le même fichier. Mais quand les 2 disquettes sont 2 fichiers différents physiquement dans le répertoire des roms on fait comment pour lire la disquette 2 ?

    Pour la disquette 2 je retombe sur le menu vert, et pour la lecture de cette 2me disquette il n'y arrive pas.


  • Banned

    @chrisis tu lis le lien d'acris et tu cherches environ 20s... Si ça marche pas essaye une autre rom



  • @voljega Bonjour,

    Le lien je le connais déjà.
    Je demande juste si une rom sur 2 disquettes sur 2 fichiers séparés ça peut fonctionner ou pas pour ATARI ST.

    sinon c'est solved, ça fonctionne merci.



  • Via le gui de l'émulateur tu as possibilité de charger/switcher de disquette.


Log in to reply
 

Want to support us ?

210
Online

82.0k
Users

22.5k
Topics

162.9k
Posts