Recalbox 7.0

Can't get Composite to work (Raspberry Pi Zero)



  • Hi,

    I'm trying to run recalbox on my 3.5'' tft screen (the NTSC/PAL from Adafruit). The screen itself is working correctly (with raspian I get output). However, I dont get any output when using recalbox, the screen stays black.

    I used this guide I found in the wiki: https://github.com/recalbox/recalbox-os/wiki/Connect-your-recalbox-to-a-CRT-with-composite-(EN)

    According to this guide I removed all hdmi_ entries from /boot/config.txt and added:
    sdtv_mode=2
    hdmi_ignore_hotplug=1

    Further I changed the recalbox.conf to global.videomode=default

    After this changes there is only HDMI output during the boot phase, but unfortunately no output on composite 😞

    Has anyone advice or suggestions how to proceed?

    My current config.txt settings are:

    disable_overscan=0
    sdtv_mode=2
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=512
    temp_limit=65
    kernel=zImage
    disable_overscan=0
    overscan_scale=1
    arm_freq=1000
    core_freq=250
    sdram_freq=450
    force_turbo=0
    over_voltage=6
    over_voltage_sdram=0
    gpu_freq=250
    sdtv_mode=2
    hdmi_ignore_hotplug=1

    --

    Best regards,
    Michael



  • @mima2856 this is my config.txt, work with my bw 3.5'' composite screen

    #hdmi_safe=1
    
    disable_overscan=0
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # comment to get jack audio
    #hdmi_drive=2
    
    #config_hdmi_boost=0
    
    # force hdmi while the tv can take time before sending the signal on the hdmi output
    #hdmi_force_hotplug=0
    
    # uncomment for composite PAL
    sdtv_mode=2
    
    # uncomment for lirc-rpi
    #dtoverlay=lirc-rpi
    
    # if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it
    boot_delay=3
    
    # uncomment if you don't want the rainbow at startup
    disable_splash=1
    
    # Overclock
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=512
    
    avoid_safe_mode=1
    
    kernel=zImage
    
    # NOOBS Auto-generated Settings:
    arm_freq=1100
    core_freq=550
    sdram_freq=600
    force_turbo=1
    over_voltage=8
    over_voltage_sdram=6
    gpu_freq=250
    
    hdmi_ignore_hotplug=1
    framebuffer_width=320
    framebuffer_height=240
    overscan_left=0
    overscan_right=0
    overscan_top=0
    overscan_bottom=0```
    
    ( je ne sais toujours pas mettre du texte dans une balise) :)

  • Developer
    Global moderator
    Creator
    Team

    mon code
    

    les balise ouvrantes et fermantes sont "```"



  • @tikiandskull Hi,

    thanks for your config.txt. I tried it - but still no success 😞
    Behavior is still the same. Problem seems to be something else.

    I plan on reinstalling recalbox, maybe I misconfigured something else.

    Wiring should be OK if it works with raspian, am I right?

    Best regards,
    Michael

    I quote some code :-)



  • @ian57 merci! 😉



  • @mima2856 sorry...



  • Hi,

    for the record: I got it working.

    I did setup recalbox on the RPi Zero, then I modified the config.txt and recalbox.cfg and now my TFT is working.

    What i probably did wrong: I have a RPi3 and a RPI Zero. At first, my recalbox setup was simply taken from the RPi3 and put into the RPI Zero. Maybe that was the problem, I dont know for sure. I thought that the RPi3 and RPi zero are essentially the same hardware, so it wouldnt matter.

    Best regards,
    Michael


  • Developer
    Global moderator
    Creator
    Team

    No they are not!!! That's why there are 3 Pi versions of recalbox! P0/1 Pi2 and P3 with different emulators activated. Making a Sd on a Pi3 will not work on a Pi2 or Pi0/1. So, do not suppose... be sure 😉



  • @ian57 yes, you are right of course. It did boot though, that's what got me confused 🙂
    Next time I will read my hardware manuals properly, lol



  • @ian57 is there a list or a files that shows what emulators are active on P0/1 vs Pi2 vs Pi3?


  • Developer
    Global moderator
    Team

    @danno Hi,

    1. Please don't post in such an old topic, open a new one
    2. Read the wiki... https://github.com/recalbox/recalbox-os/wiki/Board-Compatibility-(EN)
    3. I'm closing this topic.


Want to support us ?

139
Online

79.1k
Users

20.4k
Topics

149.3k
Posts