Affichage qui déborde de l'écran en jeu.



  • Salut à tous !

    Je viens d'installer et configurer RecalBox v4.0.0 sur mon Raspberry Pi 3, et pour le moment, tout fonctionne à merveille, si ce n'est l'affichage...

    En effet, dans le menu principal (EmulationStation) tout est parfait, mais c'est en jeu, l'image déborde de l'affichage de ma télé (une télé 720P).

    Jongler avec l'option "Overscan" ne change rien du tout à l'affichage des jeux, et le mode de résolution dans recalbox.conf semble correct (c'est bien 720P)...

    Quelqu'un aurait une idée ?

    Merci d'avance !


  • Staff
    Developer
    Team
    Creator
    Global moderator

    @claiiire

    Moi je pencherais pour un problème de TV.

    Règle le ratio de ta TV sur "signal original" ou quelque chose du genre.



  • Je ne pense pas. Avec une autre distribution (je ne sais plus si c'était Happi/Lakka/Retropie), j'avais réussi à "inverser le problème" : les jeux épousaient bien le contour de l'écran de ma télé, mais EmulationStation débordait (ce qui était moins gênant).

    Je suppose donc qu'il s'agit d'un problème de configuration d'overscan (ou équivalent) ?


  • Staff
    Developer
    Team
    Creator
    Global moderator

    @claiiire

    Tu sors du Pi en HDMI?

    TV 16/9 Full HD?



  • Le Raspberry Pi 3 est branché en HDMI, oui, sur une télé HD Ready, donc 720P.


  • Staff
    Developer
    Team
    Creator
    Global moderator

    @claiiire

    Ah HD ready!!!

    Alors essaie ceci:

    Modifiez le fichier /boot/config.txt
    (en utilisant putty par exemple, ne pas oublier de passer la partition en écriture avant)

    dedans tu rajoutes:

    hdmi_group=1
    hdmi_mode=4



  • J'ai essayé de modifier le fichier /boot/config.txt, mais au moment de sauvegarder, j'obtiens le message d'erreur :

    [ Error writing /boot/config.txt: Read-only file system ]

    Pourtant, avant d'effectuer les modifications, j'ai entré la commande :

    mount -o remount,rw /


  • Staff
    Developer
    Global moderator
    Creator
    Team

    sauf que c'est /boot 😉


  • Staff
    Developer
    Team
    Creator
    Global moderator

    je valide 🙂

    tape:
    mount -o remount,rw /boot



  • @ian57 / supernature2k
    Autant pour moi... Je pensais qu'en mettant "/", ça rendait l'ensemble des fichiers accessibles en lecture/écriture, puisque ça pointe la racine...

    Bref, je teste, et ça fonctionne ! J'ai simplement l'écran du jeu un peu réduit (petites bandes noires en haut et en bas), mais je suppose qu'en jonglant avec la valeur de "hdmi_mode", je vais bien finir par tomber sur la valeur parfaite 🙂

    Merci à vous !


  • Staff
    Developer
    Team
    Creator
    Global moderator

    @claiiire

    Non non après vérifie tes options dans recalbox.conf et aussi dans EmulationStation, mets en full screen ou 16/9

    Le hdmi_mode=4 c'est 720p 60Hz



  • En fait, je ne comprends rien...

    Dans mon fichier "/boot/config.txt", j'ai bien mis :
    hdmi_group=1
    hdmi_mode=4

    Sous EmulationStation, l'overscan est sur "ON".

    Voici le rendu que j'obtiens :
    alt text
    alt text

    L'affichage déborde sous EmulationStation et en jeu.

    Si je désactive l'overscan, j'obtiens également la même chose. J'ai regardé le fichier recalbox.conf, ainsi que les quelques paramètres relatifs à l'affichage disponible sous EmulationStation, mais rien ne semble y remédier...


  • Staff
    Developer
    Team
    Creator
    Global moderator

    Désactive l'overscan

    Dans le config.txt, reagrde à la fin si il y a des caractères étranges genre ^M
    Si c'est le cas, supprime les

    Dans ES, mets sur 16/9



  • Merci pour ta réponse.

    Il y avait effectivement des ^M dans le fichier /boot/config.txt, je les ai supprimés.
    L'overscan a été désactivé.
    J'ai réglé sur 16/9 dans EmulationStation.

    Après un redémarrage :

    • L'affichage de EmulationStation déborde de la même manière que sur ma précédente photo.
    • L'affichage en jeu est étiré en plein écran, mais malgré la déformation de l'image, l'affichage déborde toujours de l'écran de ma télé.
      alt text

  • Staff
    Developer
    Team
    Creator
    Global moderator

    @claiiire

    Bon... essaie hdmi_mode=19

    Mais tu es sûre que sur ta TV tu as le bon aspect ratio?

    Parce que j'ai un pb similaire sur ma TV si je mets 16/9 ou autre. Seule l'option signal original me donne une image complète.



  • Je viens de tenter avec hdmi_mode=19, mais le résultat reste malheureusement inchangé...

    Je suis sûre que ma télé est sur le bon ratio, étant donné qu'elle n'est pas de première jeunesse, je n'ai le choix qu'entre deux modes : 4:3 & 16:9. Je n'ai absolument aucune autre possibilité de réglage. Si je me positionne sur 4:3, c'est la source d'image elle même qui est réduite, et dans le cas présent, même les menus de EmulationStation sont écrasés au centre de l'écran.

    Je n'ai malheureusement pas d'autre écran sous la main pour tester...

    Néanmoins, j'avais déjà eu ce problème avec l'essai d'une autre distribution (Happi Game Center, ou Retropie, je ne sais plus laquelle de ces deux-là). J'avais pu le résoudre en jonglant dans le fichier /boot/config.txt en bricolant péniblement avec les options :
    overscan_right=xx
    overscan_left=xx
    overscan_bottom=xx
    overscan_top=xx

    Mais avec RecalBox, ces bricolages semblent n'avoir aucun effet...


  • Staff
    Developer
    Team
    Creator
    Global moderator

    @claiiire

    tu peux les retenter maintenant que tu as viré les ^M 😉



  • C'était déjà fait... Et toujours aucun résultat 🙂
    L'article que j'ai suivi pour le faire date d'il y a plus d'un an (voir ici), ça a peut-être été modifié via une mise à jour de l'OS plus récente que le howto que j'ai trouvé 🙂


  • Staff
    Developer
    Team
    Creator
    Global moderator

    @claiiire

    Franchement pour moi ça vient de la TV



  • Je voudrais y croire, mais :

    • Sur une autre distribution, le bricolage avec les overscan_right=xxx [...] avaient fonctionné, mais je pense qu'une mise à jour de RecalBox plus récente que le howto que j'ai suivi a modifié le fonctionnement, rendant inopérantes ces modifications.
    • J'utilise un autre Raspberry Pi sur cette même télé avec OpenElec, qui ne pose aucun problème d'affichage.
    • En jonglant avec les réglages de RecalBox pour tenter de résoudre mon problème d'affichage, j'ai testé avec deux jeux ("Super Mario Bros." sur NES, et "Super Mario 64" sur N64, pour avoir un jeu en 4:3 et un autre en 16:9 pour voir si les paramètres convenaient aux deux), mais dès que je m'approchais d'un peu trop près du réglage parfait pour Super Mario Bros, Super Mario 64 était totalement décalé vers la droite : le haut et le bas de l'image collait bien avec l'écran de la télé, mais il me manquait au moins cinq centimètres à droite, et une bande noire aussi large était visible à gauche.

    Je ne vais pas jouer à la débile qui va hurler "olol recalbox c tro dla mer2", parce que je suis têtue et n'ai pas dit mon dernier mot avec ces fichiers auxquels je ne comprends pas grand chose, je suis trop convaincue qu'il ne s'agit que d'une histoire de réglages, qui me feront dire "mais quelle co**e..." lorsque j'aurai mis la main dessus 🙂

    Merci pour le temps passé à me répondre en tout cas. J'abandonne pour ce soir, à tête reposée ça marchera peut-être mieux un soir prochain 🙂 !



Want to support us ?

251
Online

81.5k
Users

22.3k
Topics

161.7k
Posts