Juegos n64 no se ven bien y falla sonido (no es problema pantalla negra)



  • Hola, tengo un problema con los juegos de n64 y no son los especificados en este foro. Quiera o no, los juegos se ven en 16:9 (aunque fuerzo desde la interfaz que se vean a 4:3) con lo que la imagen se ve muy 'ancha'. Pero lo peor de todo es el sonido, que se corrompe y la TV empieza a hacer un fuerte pitido muy molesto, tengo que apagar la Raspberry y la TV para recuperarlo. No sé qué hacer.

    Cualquier respuesta será agradecida.
    Muchas gracias!


  • Staff
    Developer
    Team
    Global moderator
    Translator

    Faltan todos los datos sobre tu configuracion.
    Que version de RPi tenes? Como la conectas al televisor? Directamente por HDMI o con algun adaptador?
    Has revisado con tvservice que el modo de video para n64 sea compatible con tu televisor?



  • @paradadf Hola, tengo la Pi3 y la conecto por hdmi, la salida de audio también está por hdmi, lo elegí desde las opciones de audio de la interfaz de Recalbox.

    Lo que no entiendo es lo de tvservice que me comentas, podrías especificar un poco?

    Gracias!


  • Staff
    Developer
    Team
    Global moderator
    Translator

    @makination mira especialmente la ultima parte de esta pagina:
    https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN)
    necesito ver el output de los ultimos dos comandos.

    Deberias intentar poner la salida de audio en auto, como viene por defecto. El escalado de tu televisor puede estar afectando la imagen.



  • Ya me vas a perdonar por ni pregunta de noob total, pero cómo y desde dónde ejecuto los comandos tvservice -s y tvservice -m CEA que me pides??

    Gracias y perdona!


  • Staff
    Developer
    Team
    Global moderator
    Translator



  • Tras ejecutar los comandos que me pides, te paso la info. Gracias por tu paciencia.

    tvservice -s

    state 0x12000a [HDMI DMT (81) RGB full 16:9], 1366x768 @ 60.00Hz, progressive

    tvservice -m CEA

    Group CEA has 16 modes:
    mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive
    mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive
    mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive
    (native) mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive
    mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced
    mode 7: 720x480 @ 60Hz 16:9, clock:27MHz x2 interlaced
    mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive
    mode 17: 720x576 @ 50Hz 4:3, clock:27MHz progressive
    mode 18: 720x576 @ 50Hz 16:9, clock:27MHz progressive
    mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz progressive
    mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz interlaced
    mode 22: 720x576 @ 50Hz 16:9, clock:27MHz x2 interlaced
    mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz progressive
    mode 32: 1920x1080 @ 24Hz 16:9, clock:74MHz progressive
    mode 33: 1920x1080 @ 25Hz 16:9, clock:74MHz progressive
    mode 34: 1920x1080 @ 30Hz 16:9, clock:74MHz progressive

    Qué puedo hacer para que los juegos se vean en 4:3?

    Por cierto! SOLUCIONADO el tema del audio poniendo 'AUTO' en salida de audio en luegar de HDMI. Gracias!


  • Staff
    Developer
    Team
    Global moderator
    Translator

    Te falto el DMT 😉 tvservice -m DMT
    Has cambiado el global.videomode? Me sorprende que lo tengas en DMT 81.
    Ajustando el aspect ratio desde el menu de recalbox y asumiendo que tu televisor no tiene el zoom o ajuste de aspecto automatico activado, deberia funcionarte.



  • Hola, no he cambiado nada del videomode. Por qué te sorprende que esté el DMT en 81? A cuánto lo deberia poner?

    Te pongo el último comando que me pides:

    Group DMT has 11 modes:
    mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive
    mode 5: 640x480 @ 72Hz 4:3, clock:31MHz progressive
    mode 6: 640x480 @ 75Hz 4:3, clock:31MHz progressive
    mode 9: 800x600 @ 60Hz 4:3, clock:40MHz progressive
    mode 10: 800x600 @ 72Hz 4:3, clock:50MHz progressive
    mode 11: 800x600 @ 75Hz 4:3, clock:49MHz progressive
    mode 16: 1024x768 @ 60Hz 4:3, clock:65MHz progressive
    mode 17: 1024x768 @ 70Hz 4:3, clock:75MHz progressive
    mode 18: 1024x768 @ 75Hz 4:3, clock:78MHz progressive
    (prefer) mode 81: 1366x768 @ 60Hz 16:9, clock:85MHz progressive
    mode 85: 1280x720 @ 60Hz 16:9, clock:74MHz progressive

    He mirado el recalbox.conf y tengo el ratio del emu de n64 a 4/3. Se me sigue viendo en 16/9. Qué raro!

    EDIT: Te pongo una info que he visto en el recalbox.conf por si sirve de algo:

    N64 emulator is configured to display a screen with a 640x480 resolution (native n64 resolution)

    So you must use one of these video modes (DMT 4 HDMI,CEA 1 HDMI).

    If your screen is not compatible with one of these video modes, please check the recalbox's wiki.

    n64.videomode=DMT 4 HDMI

    If you are using a CRT screen, please change the setting above with this one :

    n64.videomode=default


  • Staff
    Developer
    Team
    Global moderator
    Translator

    Para n64 no se recomienda utilizar una resolucion mayor a la mencionada ahi, ese valor no lo cambies. Que valor tenes en global.videomode?



  • Hola! (soy nuevo en el foro, despues de estar leyendo un poco de todo lo que hay posteado durante 3-4 dias -que coincide con el tiempo que tengo mi rasp 3 model B con recalbox 4.0). Respondo a la pregunta de makination (la misma respuesta -checkeada por mi mismo ayer- que dio paradadf en otro post sobre el tamaño del screen de n64); no cambies nada de lo que viene configurado por default en el emulador de n64, el problema del tamaño del screen (en mi tv -sony bravia- se venia un pequeño cuadrado centrado en el medio) se soluciona usando el propio menu de la tv, en el modo de imagen! (en mi caso: imput sync del control remoto de la tv, menu de la tv; imagen de pc; y ahi te da el modo, lo escalo perfecto!).



Want to support us ?

365
Online

80.5k
Users

21.7k
Topics

158.4k
Posts