Problems connecting to Recalbox *internally*



  • Hello!

    I just experienced a strange problem with my Recalbox 4.0 final.

    While I was affected by the "Not Connected" issue like many others, my problem was different:

    My Recalbox got an IP using WLAN from my OpenWrt-Router like usual, but suddenly couldn't be reached by Samba, SSH or even PING by any other PC in the network. Scraping from the Recalbox into the internet worked.

    I double-checked the IP-address, which was a 192.168.1.X as any of my PCs has. Funny thing was, that the router itself could PING the Recalbox, but no other PC could, regardless if Windows or Linux.

    On the Recalbox I closed Emulation Station using "F4" and opened a Terminal using "Alt+F2" and was able to PING the other PCs from the Recalbox. As soon as I did this, I could also reach the Recalbox (PING, Samba, SSH, even "RECALBOX" instead of IP worked) from the PCs.

    After a Reboot the Recalbox was again not reachable. Had to do open a Terminal again and PING a PC in the internal net.

    Anyone having the same problem and found a permanent solution?

    Of course I only have to reach the Recalbox only when putting new ROMs onto it, but this is still very annoying.

    Greetings from Germany

    René



  • After some further testing:

    Only PCs can PING or otherwise reach the Recalbox, whom have been PINGed by the Recalbox before.

    After that, the Recalbox can be reached by PING, SSH, SAMBA.

    Any ideas?



  • @hanker arp cache problem ? routing problem ?



  • @Substring : Sorry, I don't know, what arp cache is.

    Maybe it is a routing problem, but I haven't changed anything in my LAN over the last months, and some weeks ago, everything worked flawlessly. And I find it quite strange, that everything works fine as soon as the Recalbox "reaches out" to another computer, but before I cannot even ping it, though it is in the same subnet...



  • @hanker ip conflict ?



  • Here are my active DHCP-Leases (did remove MACs):

    RECALBOX 192.168.1.80
    android-68117d3db154994a 192.168.1.63
    SqueezeboxRadio 192.168.1.96
    android-dda599c5c3e1065e 192.168.1.58
    LaptopHnkXX 192.168.1.10
    LaptopHnkXXLAN 192.168.1.12

    No IP conflicts. RECALBOX IP is set as static lease.

    The Router has this ARP:

    ARP
    IPv4-Address MAC-Address Interface
    192.168.1.84 br-lan
    192.168.1.3 br-lan
    192.168.0.1 eth0.2
    192.168.1.80 br-lan
    10.52.1.106 br-lan
    192.168.1.96 br-lan
    192.168.1.254 br-lan
    192.168.1.81 br-lan
    192.168.1.10 br-lan
    192.168.1.87 br-lan
    192.168.1.12 br-lan
    192.168.1.63 br-lan
    192.168.1.2 br-lan

    "arp -a" on the Win7-PC using 192.168.1.12 gets

    Schnittstelle: 192.168.1.12 --- 0xb
    Internetadresse Physische Adresse Typ
    192.168.1.1 dynamisch
    192.168.1.254 dynamisch
    192.168.1.255 statisch
    224.0.0.22 statisch
    224.0.0.252 statisch
    239.255.255.250 statisch
    255.255.255.255 statisch

    And "ping 192.168.1.80" will get me "Zielhost nicht erreichbar" (not reachable).

    As sone as I ping 192.168.1.12 from the Recalbox, everything works, as written. "ping 192.168.1.80" gets an answer and "arp -a" lists the IP 192.168.1.80.

    BUT as soon as I stop pinging 192.168.1.12, I get a timeout when pinging 192.168.1.80 and then "not reachable" again. 192.168.1.80 vanisches from "arp -a".

    If I ping constantly from the Recalbox, it all seems well.

    René



  • @hanker Can you paste the result from iifconfig ? Do you have the same problem if you plug on ethernet ?



  • Sorry, I'm quite busy right now.

    Here's a screenshot of ifconfig:

    0_1483174386646_IMG_20161229_092258.jpg

    I will test connecting via LAN cable next year. 😉

    René



  • Hello and happy new year!

    I just plugged in a LAN-cable, deactivated WLAN, rebooted to be sure - and everything works fine. No pinging necessary.

    ifconfig output:

    0_1483339998446_IMG_20170102_073301.jpg

    But I still have no idea, why remote access doesn't work when using WLAN...

    Confused greetings from Germany

    René



Want to support us ?

172
Online

80.3k
Users

21.5k
Topics

157.3k
Posts