PS3/PC Afterglow wireless USB controller won't connect



  • I have a RPI3 and I just bought an Afterglow PS3/PC wireless controller with USB dongle. I plugged in the dongle and when i press the connect button on the controller it just continues to flash without connecting. I tried the controller on a PC and it connects fine. I checked the compatibility list and it says this controller should work. I tried all the options in recalbox.conf for the ps3 controllers with no change. This controller does not use Bluetooth.



  • Ok so when I plug the dongle into the PC there is a red led on it that comes on, but it doesnt come on when in the raspberry pi. I even plugged it straight into a charger block to see and the light came on and the controller kind of half connected, which is more than it ever did with the pi. I tried a few different charger blocks and cords in case it wasnt getting enough power. Is there a way the power to USB can be turned on and off internally?



  • I know that the issue is with the software, not the hardware. I took a spare sd card and flashed a different OS to it, and when I booted the Pi it synced with the controller no problem. Does anyone have any suggestions? I tried every possible combination in the recalbox.conf turning on and off the ps3 or xbox controller options but no change. I'll attach a pic of what I get with dmesg from the root prompt. Sorry I'm not sure how to get a screenshot from it.

    0_1482166191233_1219161405_HDR.jpg


  • Moderator
    Team

    Looks like it requires either a xpad update, either a general kernel update (but i don't believe so)



  • is there an update available or is that something the devs have to release?



  • Just a follow up: the new version 4.1 seems to support the controller. Thanks!



  • Did you mean 4.0.1? I just got the same controller, and am having the same problem. I'm updated to the most recent version of RecalBox - I believe it's 4.0.2, but I still cannot connect the controller. It connects to my computer no problems.

    @jesketz @Substring


  • Moderator
    Team

    @grim6 no he meant 4.1, the next version



  • @Substring How do you get 4.1? I didn't see it as a download option


  • Moderator
    Team

    @grim6 check our blog (link in the top bar). But for now it's not available as we're migrating servers, and it's still in a beta stage



Want to support us ?

Join us on :

325
Online

28232
Users

14446
Topics

109308
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.