Recalbox 7.0

How to emulate recalboxOS v4.0 using qemu?



  • Hi.

    I'm trying to launch recalboxOS v4.0.0 using qemu-system-arm and it seems I'm doing something wrong.

    After install qemu in Fedora 25:

    sudo dnf install qemu
    

    I downloaded recalbox v4 from here

    Then, I try to create a valid iso using:

    fallocate -l 1G recalbox_image.img                                     # Create img file
    mkfs.msdos recalbox_image.img                                        # Set fat32 format
    mkdir recalbox                                                                              # Create temporal folder
    sudo mount -o loop recalbox_image.img ./recalbox    # Mount img in folder
    sudo unzip recalboxOS-4.0.0.zip -d recalbox                  # Unzip recalbox 4 in img
    genisoimage -o recalbox.iso recalbox                                # Create iso
    

    After creating iso, I try to launch it using:

    qemu-system-arm -machine raspi2 -hda recalbox_image.img -m 1024 # Launch nothing
    

    It is probably a problem with missing kernel or something. I tried to download raspbian kernels to use them from:

    git clone https://github.com/dhruvvyas90/qemu-rpi-kernel
    

    But nothing:

    qemu-system-arm -machine raspi2 -hda recalbox_image.img -m 1024 -kernel qemu-rpi-kernel/kernel-qemu-4.4.13-jessie -append "root=/dev/sda2" # Nothing happend
    

    and using:

    qemu-system-arm -M versatilepb -cpu arm1176 -hda recalbox_image.img -kernel qemu-rpi-kernel/kernel-qemu-4.4.13-jessie -m 1024 -append "root=/dev/sda2"
    

    neither (any version). Someone know what kernel or configuration I must to use?



  • As far as i remember qemu id dreadly slow and hardly emulates a pi0 + iy can't handle the hdmi display, so i don't think you'll get anything with it



  • Hi, i have seen rasbpbian is emulated under windows here https://sourceforge.net/projects/rpiqemuwindows/
    I would like to virtualize recalbox for testing purpose, someone have tried?


  • Banned

    @0zzy recalbox is not a raspian. Besides emulators in emulator... Not usable at all



  • @0zzy haven't tried qemu for ages, but last time i tried it had horrible performance emulating a pi1 ... And I'm not sure it can run real video output. But you should go ahead and try, we dev don't have much time to test such things



  • hi all!
    i was looking to emulate recalbox only to test roms quickly, because my raspy is far from my desktop, and because i'm a vcp, i like to virtualize all 😄



  • @0zzy well, keep trying, i'd be curious to see how it works afterall 🙂



Want to support us ?

213
Online

79.1k
Users

20.4k
Topics

149.2k
Posts