Recalbox x86 Issues



  • Has anyone here tried the x86 version of recalbox? I can't seem to get it to run properly, it's very slow, stretched 4:3 resolution on a 16:9 1080p TV, and no sound. It's a pretty powerful machine, more than capable of running this, it seems like it doesn't have drivers. Anyone have similar issues with this?

    My Specs are:

    • Intel i7 3770
    • Nvidia GTX 1060 6GB
    • 8GB DDR3 Ram


  • Yeah, over here, but I think you're going to have provide some more information. What games/emulators are you running? USB 2.0/3.0 drives? etc.

    Edit: don't forget, it's also still in alpha, so it's got some ways to go before it's gets into beta (stable) mode.



  • @Shockwave Hey thanks. I actually haven't really tried any roms or emulators, just that Donkey Kong game that comes in the snes section, but where I noticed the issues is just in the main menu. Running from a USB 2.0 stick. I understand it's in alpha, I wont be heartbroken if it's just not compatible with my hardware yet :)


  • Moderator
    Team

    I guess current High end gpu are nit supported by the kernel we ship. You're not the first one having trouble with a 1060



  • @Substring Ah, thanks, I figured it was something like that. I'll just keep an eye on releases

    EDIT: Maybe I'll get a Raspberry Pi to hold me over, because recalbox is just too awesome



  • You might want to look into an Odroid XU4 or C2 for the meantime. They're also have alpha revisions that are supported by Recalbox. They're also pretty damn stable for alpha revisions as well especially for N64/Dreamcast emulation.



  • Currently i didn't recommend an C2, i got one and now i'm switched to an Pi 3.

    The main issues on the C2 Version is: missing Audio mixer and no control over Frambuffer (Resolution (affects Emulator performance))


Log in to reply
 

Want to support us ?

Join us on :

215
Online

25466
Users

13346
Topics

101123
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.